Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 09-24-2015, 01:16 AM   #1
grimkeit
I've made a post!
 
Drives: 2008 yaris
Join Date: Sep 2015
Location: guam
Posts: 1
Angry 2008 Yaris Pings under low rpm and load

Ug, 73,000mi of 2008 yaris, hot humid Guam Island

MY gf's car pings right after you press pedal (under A/C load) but goes away at revs. I cannot figure this out and here is what I have done:
changed plugs, irridium
changed air filter
cleaned MASensor
changed intake manifold gasket (seal) BTW the valves were very clean looking in
capped off hose lines at manifold (no change, put hoses back)
changed knock sensor (made it better)
changed fuel injectors (made it worse, need to check if sold the right ones, grrr if not)
ran about a quart of sea foam in 3 sessions through brake vacuum line (ping gone until all sea foam burned out, then back)
computer throws no errors
use 91 octane
runs great after a little low rpm pinging, idle smooth

I wonder if it is a fuel pressure issue? I am about ready to pull fuel pump assy and clean.
Or wonder if it is PCV, but when I pulled the hose and put plastic and rubber band over hole in intake nothing got better.
Wonder if it could be a pin hole in head gasket?

Last edited by grimkeit; 09-24-2015 at 02:43 AM.
grimkeit is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:35 PM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.