Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Second Generation Toyota Yaris Main Rooms > Regional Forums > UK
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 03-30-2011, 07:19 PM   #1
myahya
I've made a post!
 
Drives: toyota yaris
Join Date: Mar 2011
Location: london
Posts: 1
Yaris acceleration problem

Hi all , my 1999 1.3 Auto vvti yaris has an acceleration issue.
It happens when I start from cold( in the morning) for the first 5-10 minutes when I press the acceleration it takes around 4-5 seconds to accelerate, sometimes I have to press/release the accelerator quickly few times (like pumping the gas) for it to move. Cna anyone suggest whats wrong with it.
It has the check engine light on ( but this has been on for years and I know I should have get it checked but it has been running fine , this has just started to happen few months ago).
Thanks
myahya is offline   Reply With Quote
Old 04-01-2012, 12:07 PM   #2
f2raf
 
Drives: toyota yaris
Join Date: Apr 2012
Location: uk
Posts: 4
I am experiencing exactly the same problem with my car, its very dangerous as sometimes pulling away from a junction its very slow. Please can anyone help
f2raf is offline   Reply With Quote
Old 04-01-2012, 04:17 PM   #3
marcus
toyota
 
marcus's Avatar
 
Drives: 2007 Yaris RS Blazed
Join Date: Oct 2006
Location: toronto, canada
Posts: 3,666
my bet is on ether dirty air filter or mass flow sensor need to be cleaned..
__________________
If my calculations are correct, when this baby hits eighty-eight miles per hour... you're gonna see some serious shit!!!!!!

"Horsepower is how fast you hit the object. Torque is how far you move that object.."
marcus is offline   Reply With Quote
Old 04-01-2012, 05:38 PM   #4
WeeYari
 
WeeYari's Avatar
 
Drives: 06 Polar White 5dr, 13 Soul 4u
Join Date: Oct 2008
Location: Georgetown, Ontario, Canada
Posts: 5,061
Quote:
Originally Posted by myahya View Post
It has the check engine light on ( but this has been on for years and I know I should have get it checked but it has been running fine , this has just started to happen few months ago).
This is a concern.

In another vehicle I had a check engine light caused by a faulty o2 sensor. Vehicle ran fine, but I was advised by several people to fix it as it would eventually lead to a fouled catalytic converter.

Ignoring a check engine light is never a good thing. Get that code checked asap.
__________________
WeeYari is offline   Reply With Quote
Reply

Tags
acceleration, auto, yaris

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vibration problem with Yaris SEDAN 2009 Rohail DIY / Maintenance / Service 12 11-20-2012 03:53 AM
Consumer Reports not too pleased with Yaris Befuddled General Yaris / Vitz Discussion 132 02-28-2011 03:57 PM
AC Problem 2007 Toyota Yaris S kn27 DIY / Maintenance / Service 3 11-13-2010 02:21 PM
NEWS: TOYOTA REVEALS ALL-NEW YARIS SEDAN AT 2006 LOS ANGELES AUTO SHOW VitzBoy General Yaris / Vitz Discussion 5 09-05-2010 08:53 PM


All times are GMT -4. The time now is 12:00 PM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.