Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 02-26-2018, 04:36 PM   #1
zerosl
 
Drives: 2008 Yaris S Hatchback
Join Date: Oct 2017
Location: NJ
Posts: 25
2nd Gen Headlight wiring

Hi guys, I have a 2nd generation (08) yaris hatch S

I bought the car used from a guy who did a hackjob aftermarket HID install in which I think the existing connector for the bulb was cut on the drivers side.

Can anyone snap a picture of what the original connector looks like and where it goes?

I see a 3 prong 9003 connector female on the passenger side that accepts the 9003 bulb, but the drivers side has none i can see.

I traced the low beam and ground wire from the mess and can get the low beams working if i wired a new 9003 female connector but cant seem to locate where the high beam wire is!

any help would be much appreciated

Last edited by zerosl; 02-27-2018 at 09:07 AM.
zerosl is offline   Reply With Quote
Old 02-27-2018, 08:38 AM   #2
zerosl
 
Drives: 2008 Yaris S Hatchback
Join Date: Oct 2017
Location: NJ
Posts: 25
wow, crickets.

So I was able to figure out a lot of it, though its going to be a lot of splicing done.

I found what I think is the original 9003 connection on the passenger side with a green black and blue wire.

I plugged in my light to that and it functions as such: When the engine is on, it turns the light on (assuming this is daytime running lamp mode) and then when I click the actual headlights on, it turns up the brightness a tiny bit. The high beams activate as normal.

The Driver side is a bit more complicated. I have found an 800 series connector (often used on 9005/9006/9007) coming out of the same wiring loom as some of the other lights on that side.

The driver side didnt seem to have the 3 prong 9003 female connector so I tried powering up my bulb off the connector I did have on the driver side (This was the stuff connected to the HIDs)

I wired it up to the LOW beam prong on the 9003 bulb and ground prong and now the behavior is as such.

when the engine is on: no light on driver side, When I turn on the headlights, Headlights come on. No high beams because it is not wired up.

So I do NOT like the daytime running lamp mode, so I am planning on doing the daytime running lamp relay Delete that is under the steering column, then splice a wire and send it from the passenger side to the driver side to activate the high beam to the driver side.

Does this make any sense or should I run high beam directly off the battery and use a relay from the passenger side?
zerosl is offline   Reply With Quote
Old 02-27-2018, 04:08 PM   #3
zerosl
 
Drives: 2008 Yaris S Hatchback
Join Date: Oct 2017
Location: NJ
Posts: 25
Well, after getting some electronics consultation, I was confident in splicing from the passenger side and running them all to the drivers side.

I also went ahead and pulled the daytime running lamp relay from under the steering wheel.

Everything is working perfectly

Hope this helps someone in the future
zerosl is offline   Reply With Quote
Old 03-06-2018, 08:36 AM   #4
zerosl
 
Drives: 2008 Yaris S Hatchback
Join Date: Oct 2017
Location: NJ
Posts: 25
https://www.youtube.com/watch?v=t6LhuSXRoUE

Video summary of what I did
zerosl is offline   Reply With Quote
Old 03-21-2018, 10:17 PM   #5
g man
g_man
 
Drives: Yaris 5 Door
Join Date: Aug 2007
Location: Hamilton Ontario
Posts: 14
reply

Thanks for the effort
g man is offline   Reply With Quote
Old 03-23-2018, 10:48 AM   #6
zerosl
 
Drives: 2008 Yaris S Hatchback
Join Date: Oct 2017
Location: NJ
Posts: 25
thanks G man! encouraging to see someone at least reply!
zerosl is offline   Reply With Quote
Old 03-25-2018, 03:16 PM   #7
B.B._07
 
Drives: 07 5dr
Join Date: Nov 2015
Location: YYC
Posts: 157
The left and right side headlights have their own fuses so by running both from one side in parallel you're very likely to blow the fuse in the future. If the previous owner hacked off the connector on the drivers side you can just buy a generic H4/9003 headlight connector from an auto parts store and restore the original wiring. The drivers side headlight connector has grey, green, and brown wires going to it. It's a ground side switched setup with the grey wire being +12V power, brown is high beam ground, and green is low beam ground. Take a look at the attached wiring diagrams.

Also from watching the video I'd suggest cleaning the corrosion from your positive battery terminal before it becomes a no start condition.
Attached Files
File Type: pdf 07_Yaris_HL_WiringEWD.pdf (49.4 KB, 7 views)
File Type: pdf 07_Yaris_HLLighting.pdf (176.5 KB, 5 views)
B.B._07 is offline   Reply With Quote
Old 03-26-2018, 09:32 AM   #8
zerosl
 
Drives: 2008 Yaris S Hatchback
Join Date: Oct 2017
Location: NJ
Posts: 25
I did consult two electrical engineers and they told me a splice would be able to handle the reduced current draw from the LED bulbs, so I did take their word on it.

Ideally I would have wired separately off the original drivers side lines, but they are nowhere to be found. The documents you uploaded may help me find them in the future so thanks for that.

I have cleaned the corrosion many times, and I plan on detailing the engine bay and will clean and put some terminal protectant on at that time
zerosl is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY - Converting a 2nd gen Yaris to the best part of a 3rd gen (Steering wheel audio) CTScott DIY / Maintenance / Service 9 07-27-2018 12:21 PM
diy HID projector w/ halo headlight install tmontague DIY / Maintenance / Service 17 02-04-2016 12:34 PM
Mirror turn signals 3rd gen wiring ? NYC-SE Cosmetic Modifications (Exterior/Interior) 31 10-23-2015 10:26 PM
2nd vs 3rd gen ride quality + durability chocolab Third Gen Yaris General Discussion 23 11-17-2014 08:30 PM
2nd Gen owner's impressions: 3 days with a 3rd Gen (2013 5-door LE 18k miles) nookandcrannycar General Yaris / Vitz Discussion 7 02-22-2014 09:16 PM


All times are GMT -4. The time now is 07:23 AM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.