Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 02-06-2013, 11:49 AM   #1
volks_r_us
 
Drives: Toyota Yaris 2008 CE
Join Date: Feb 2013
Location: cold northeast
Posts: 3
Hard start in the morning 2008 Yaris CE

Hi
This is my first Toyota and I already have a problem

It's a 4 doors 2008 Toyota Yaris CE VVTI 1.5L automatic with 56K miles.
It's cold here below freezing point. Everymorning my car is hard to start.
I engine crank normally but I have to crank for like 10 sec on order to get it start.
I replaced the spark plugs and air filter without any improvement.
I checked with a scaner for fault code, Nothing.

Once it have started everything fine, it will start right away if you turn it off and back on, until the next day.

Basically the problem is only the first cold start of the day.

Anybody has an Idea what to check ?
volks_r_us is offline   Reply With Quote
Old 02-06-2013, 11:52 AM   #2
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
If it cranks over fine (i.e. the battery is not low, where the starter is barely turning the engine over), then my guess would be a fuel system issue. It sounds like the fuel system is depressurizing overnight.
CTScott is online now   Reply With Quote
Old 02-06-2013, 11:59 AM   #3
volks_r_us
 
Drives: Toyota Yaris 2008 CE
Join Date: Feb 2013
Location: cold northeast
Posts: 3
Quote:
Originally Posted by CTScott View Post
If it cranks over fine (i.e. the battery is not low, where the starter is barely turning the engine over), then my guess would be a fuel system issue. It sounds like the fuel system is depressurizing overnight.
Yeah that was my guess, is this a common issue on this car ?
I have to replace the fuel pump ?
volks_r_us is offline   Reply With Quote
Old 02-06-2013, 12:32 PM   #4
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
Quote:
Originally Posted by volks_r_us View Post
Yeah that was my guess, is this a common issue on this car ?
I have to replace the fuel pump ?
I don't think it is common, but one or two one here have mentioned a similar issue. You would really need to do some troubleshooting with measuring fuel pressure to determine if the fuel pump needed to be replaced.

It could also be that the fuel filter is plugged enough to make starting difficult. That is only a $37 part, but is located within the tank.
CTScott is online now   Reply With Quote
Old 02-06-2013, 12:50 PM   #5
MickZEL
 
MickZEL's Avatar
 
Drives: Yaris sedan
Join Date: Apr 2011
Location: Russia,Moscow
Posts: 234
I have exactly the same problem. I thought it was normal.
__________________
I like very much travel
MickZEL is offline   Reply With Quote
Old 02-07-2013, 04:17 PM   #6
Vinceb
 
Drives: 2008 5 Speed Sedan
Join Date: Jan 2011
Location: Nova Scotia, Canada
Posts: 78
I thought the car would throw a MIL code if the fuel system looses pressure?? Mine has never had an issue like that, -22c last night, started right away this morning, 204,000km
Vinceb is offline   Reply With Quote
Old 02-07-2013, 04:26 PM   #7
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
Quote:
Originally Posted by Vinceb View Post
I thought the car would throw a MIL code if the fuel system looses pressure?? Mine has never had an issue like that, -22c last night, started right away this morning, 204,000km
Only if the evaporative system looses pressure during the over-night test will it throw a code (which is actually completely separate). There is no pressure sensor between the fuel pump and the injectors.
CTScott is online now   Reply With Quote
Old 02-08-2013, 01:32 PM   #8
volks_r_us
 
Drives: Toyota Yaris 2008 CE
Join Date: Feb 2013
Location: cold northeast
Posts: 3
I checked the fuel pressure and residial fuel pressure. It's fine
volks_r_us is offline   Reply With Quote
Old 02-08-2013, 02:11 PM   #9
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
Quote:
Originally Posted by volks_r_us View Post
I checked the fuel pressure and residial fuel pressure. It's fine
OK - So you've done the plugs and checked the fuel pressure. The remaining things that I can think of are the coils (although if one or more were having issues I would think it would run horribly once started), and the fuel filter.
CTScott is online now   Reply With Quote
Old 03-09-2018, 04:18 PM   #10
Kousi
 
Drives: Toyota yaris
Join Date: Mar 2018
Location: Dk
Posts: 2
Did u find the problem
Kousi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Comparison Test: 2012 Toyota Yaris Vs. 2012 Toyota Prius c Yar Is Word Third Gen Yaris General Discussion 27 09-06-2012 11:37 PM
NEWS: TOYOTA REVEALS ALL-NEW YARIS SEDAN AT 2006 LOS ANGELES AUTO SHOW VitzBoy General Yaris / Vitz Discussion 5 09-05-2010 08:53 PM
2007 Yaris Pricing Info ! YarisBueller New YARIS Purchase Forum 104 06-24-2009 04:54 PM
2008 Yaris Sport For Sale 2008er Items for Sale by private party 5 04-22-2009 10:02 AM


All times are GMT -4. The time now is 07:52 PM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.