Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 03-18-2011, 10:00 PM   #163
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
Quote:
Originally Posted by CB900F2 View Post
Scott.. Would you happen to have a photo the the top half of AD4 connector as I got the connector off the white mount, but since it is a bit tight, I am having a hard time trying to find the latch to unhook the two halfs?..

Thanks Scott!
AD4 - From Top.jpg

AD4 - Unlatched.jpg
CTScott is offline   Reply With Quote
Old 03-19-2011, 05:28 AM   #164
CB900F2
 
Drives: 08 Sedan
Join Date: Oct 2008
Location: Toronto
Posts: 276
Thanks Scott!
CB900F2 is offline   Reply With Quote
Old 03-19-2011, 12:41 PM   #165
cdu
 
Drives: 2007 Yaris Sedan - Auto
Join Date: Mar 2011
Location: Saskatoon, SK, Canada
Posts: 4
I'm so confused...lol! I've gone through so many threads and am not sure where to start! I first came upon this video: http://www.youtube.com/watch?v=bWPXFYeLJj0

He makes it looks so easy but then I realized, after spending time on two threads here, that he doesn't touch on any of the engine work that also needs to be done.

I have an 07 Sedan/Automatic and live in Canada.

I know tons of people have asked this question and hate to do this to you guys but...what parts do I need for MY car?

Any help would be much appreciated!
cdu is offline   Reply With Quote
Old 03-19-2011, 12:49 PM   #166
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
Quote:
Originally Posted by cdu View Post
I'm so confused...lol! I've gone through so many threads and am not sure where to start! I first came upon this video: http://www.youtube.com/watch?v=bWPXFYeLJj0

He makes it looks so easy but then I realized, after spending time on two threads here, that he doesn't touch on any of the engine work that also needs to be done.

I have an 07 Sedan/Automatic and live in Canada.

I know tons of people have asked this question and hate to do this to you guys but...what parts do I need for MY car?

Any help would be much appreciated!
That's why I just put this together. This is the detailed soup to nuts instructions for all aspects of installing OEM cruise control on any Yaris from 2006-2011:

http://www.yarisworld.com/forums/showthread.php?t=33750
CTScott is offline   Reply With Quote
Old 03-21-2011, 08:55 PM   #167
CB900F2
 
Drives: 08 Sedan
Join Date: Oct 2008
Location: Toronto
Posts: 276
Installed the CC on my CND version 2008 Sedan and all went well, I want to give big thanks to every one and especially Scott for all of his great help!

I installed the OEM CC stalk and ran the CC signal line from D3 to AD4, getting to AD4 was not too bad, just trying to work in the small area under the dash was the only challenge. Grounded the GND line from D3 was no issue.

I recommend the up grade to anyone needing CC

Thanks again to Scott for all his great help and supply of connectors.

Last edited by CB900F2; 03-23-2011 at 07:06 AM.
CB900F2 is offline   Reply With Quote
Old 03-28-2011, 08:57 PM   #168
Aetre
 
Drives: 2009 3dr Liftback
Join Date: Mar 2011
Location: Northern Virginia
Posts: 13
Hi, all. Newbie with a 2009 3dr liftback automatic and the dumb question of the day:

What parts of this cruise control installation, if any, would void the warranty?
Aetre is offline   Reply With Quote
Old 03-28-2011, 09:41 PM   #169
ibanezjeepguy
 
Drives: 2010 Meteorite Liftback
Join Date: Nov 2010
Location: Myrtle Beach, SC USA
Posts: 53
none...
ibanezjeepguy is offline   Reply With Quote
Old 03-29-2011, 12:03 PM   #170
Aetre
 
Drives: 2009 3dr Liftback
Join Date: Mar 2011
Location: Northern Virginia
Posts: 13
Sweet, thanks.
Aetre is offline   Reply With Quote
Old 03-29-2011, 07:47 PM   #171
ibanezjeepguy
 
Drives: 2010 Meteorite Liftback
Join Date: Nov 2010
Location: Myrtle Beach, SC USA
Posts: 53
as long as you're adding toyota OE parts everything should be fine.... its when you start adding in your own home-brew stuff that things become grey
ibanezjeepguy is offline   Reply With Quote
Old 04-21-2011, 01:49 PM   #172
Midnightsun
 
Drives: 2006 Yaris RS 5DR White
Join Date: Apr 2011
Location: Montreal, Canada
Posts: 19
Quote:
Originally Posted by CTScott View Post
Also, I have a couple of the stalks with the wire and the screws for $40 shipped, which is less than half of that price.
Hey CTScott, I have been trying to get a hold of you as I would like to purchase this from you. Can you PM me please. Thanks.
Midnightsun is offline   Reply With Quote
Old 04-23-2011, 11:45 AM   #173
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
Quote:
Originally Posted by Midnightsun View Post
Hey CTScott, I have been trying to get a hold of you as I would like to purchase this from you. Can you PM me please. Thanks.
Sorry, I've been out of the country SCUBA diving for a week. I just hit you back by PM.
CTScott is offline   Reply With Quote
Old 04-24-2011, 09:01 PM   #174
teddy
 
Drives: 2008 5-door hatchback
Join Date: Oct 2008
Location: Ontario, Canada
Posts: 137
Send a message via MSN to teddy
Can somebody with the OEM cruise & steering wheel cover please post a picture showing the hole where the stalk comes out? Doesn't even have to be a DIY job, even with it installed from the factory.

I'm thinking about picking up an OEM steering wheel cover with the pre-cut hole. The one I drilled is a bit of an eye sore.. much larger than it needed to be because I drilled it in the wrong spot and had to adjust a few times.

thanks
__________________
teddy is offline   Reply With Quote
Old 04-24-2011, 10:48 PM   #175
hayden
 
Drives: asd
Join Date: Oct 2009
Location: dfw
Posts: 42
Well I had a pretty scary experience tonight. I installed cruise control with the OEM stalk a few (I think) months ago and it's worked flawlessly up until tonight. It was humid and raining which I think may have caused it?

Anyway, at first CC wouldn't work at all. I fiddled with the stalk a few times on the drive and eventually it turned on. All was well for a couple minutes, until I starting hearing the engine rev and noticed I was going 90MPH (I set it to about 65). It was like the cruise control stalk was stuck in the up position (it wasn't). It did this several times while also cutting out and not working several times during my 30 minute trip. I was obviously watching it very closely after it happened the first time.

Not sure what the cause could be. I'm guessing a loose wire or something? Anyway, extremely unsafe either way and a big notice to anyone out there to be sure to know what they're doing.
hayden is offline   Reply With Quote
Old 04-24-2011, 10:59 PM   #176
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
Quote:
Originally Posted by hayden View Post
Well I had a pretty scary experience tonight. I installed cruise control with the OEM stalk a few (I think) months ago and it's worked flawlessly up until tonight. It was humid and raining which I think may have caused it?

Anyway, at first CC wouldn't work at all. I fiddled with the stalk a few times on the drive and eventually it turned on. All was well for a couple minutes, until I starting hearing the engine rev and noticed I was going 90MPH (I set it to about 65). It was like the cruise control stalk was stuck in the up position (it wasn't). It did this several times while also cutting out and not working several times during my 30 minute trip. I was obviously watching it very closely after it happened the first time.

Not sure what the cause could be. I'm guessing a loose wire or something? Anyway, extremely unsafe either way and a big notice to anyone out there to be sure to know what they're doing.

If you have access to a multimeter, with the ignition off, measure the resistance between the two stalk wires with nothing pressed and then again with each switch activated.
CTScott is offline   Reply With Quote
Old 04-24-2011, 11:17 PM   #177
hayden
 
Drives: asd
Join Date: Oct 2009
Location: dfw
Posts: 42
I'll give it a try tomorrow and let you know, thanks.
hayden is offline   Reply With Quote
Old 04-25-2011, 06:13 AM   #178
CB900F2
 
Drives: 08 Sedan
Join Date: Oct 2008
Location: Toronto
Posts: 276
Teddy and all.. Use the template that comes with these installation instructions for the OEM CC installl.
I’ll take some pictures of mine and will post then shortly...


Quote:
Originally Posted by teddy View Post
Can somebody with the OEM cruise & steering wheel cover please post a picture showing the hole where the stalk comes out? Doesn't even have to be a DIY job, even with it installed from the factory.

I'm thinking about picking up an OEM steering wheel cover with the pre-cut hole. The one I drilled is a bit of an eye sore.. much larger than it needed to be because I drilled it in the wrong spot and had to adjust a few times.

thanks
Attached Files
File Type: pdf 00016-01208Yarisinst.pdf (1.70 MB, 61 views)
CB900F2 is offline   Reply With Quote
Old 04-25-2011, 09:55 AM   #179
teddy
 
Drives: 2008 5-door hatchback
Join Date: Oct 2008
Location: Ontario, Canada
Posts: 137
Send a message via MSN to teddy
Quote:
Originally Posted by CB900F2 View Post
Teddy and all.. Use the template that comes with these installation instructions for the OEM CC installl.
I’ll take some pictures of mine and will post then shortly...
Wish I had that template before I drilled the hole! Found it a few days after it was all done.

I was going in blind essentially. This considered I didn't do that bad, but it's a little rough around the edges.
__________________
teddy is offline   Reply With Quote
Old 04-25-2011, 12:19 PM   #180
SKurj
 
Drives: 09 Yaris 3dr HB, BRZ
Join Date: Mar 2011
Location: GTA
Posts: 222
Excuse my expletives... but my local dealer quoted me $700 for an aftermarket cruise today...

Guess I will be trying my hand at this DIY.....
SKurj is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
NEWS: TOYOTA REVEALS ALL-NEW YARIS SEDAN AT 2006 LOS ANGELES AUTO SHOW VitzBoy General Yaris / Vitz Discussion 5 09-05-2010 08:53 PM
Cruise Control chessclubloser DIY / Maintenance / Service 11 03-27-2010 11:59 AM
2007 Yaris Pricing Info ! YarisBueller New YARIS Purchase Forum 104 06-24-2009 04:54 PM
Using Cruise control Driver General Yaris / Vitz Discussion 14 11-09-2006 11:12 PM


All times are GMT -4. The time now is 03:23 AM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.