Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 10-20-2017, 08:48 AM   #1
Uten
 
Drives: Yaris 1.3 vvt-i
Join Date: Jun 2014
Location: Norway
Posts: 6
Question Rattling noise from engine. About to break down?

Yesterday my Yaris 2007 model started to make clacking noises from the engine. I'm always oversuspicious to new unknown sounds from the car.

Sounds like something is hitting the interior wall clonk, clonk, clonk. It could remind me of the clicking sound you get in a ford fiesta mk I from the taps that hit the valve rods.

I fear something is really wrong in the engine. It is worst at low rpm.

So my questions is. Anyone driving around with such sounds in their Yaris?
Will timing chain make noice before breaking?
How about the water/cooling pump?
Will the ac unit make such sound before giving up?

Any experience you can share in this regard?

ps: I have parked the car until I can figure it out
Uten is offline   Reply With Quote
Old 10-20-2017, 09:52 AM   #2
WeeYari
 
WeeYari's Avatar
 
Drives: 06 Polar White 5dr, 13 Soul 4u
Join Date: Oct 2008
Location: Georgetown, Ontario, Canada
Posts: 4,717
Exhaust manifold heat shield. Mine corroded out recently at the mounting points by the flange and exhibited exactly what you are experiencing.

Sent from my Elite_5_5_Octa using Tapatalk
__________________
WeeYari is offline   Reply With Quote
Old 10-20-2017, 10:03 AM   #3
tmontague
 
tmontague's Avatar
 
Drives: 08 Vios M/T, 05 4wd Vibe
Join Date: Oct 2012
Location: Hamilton Ont.
Posts: 1,773
Your engine is fine, most likely culprit is what wee states. Rip it off when the engine is cool and go about your day.

I've pulled a total of 3 heat shields off of my vibe chasing down rattles, they don't last long in the salt belt
__________________
I like to drive a slow car fast...
tmontague is offline   Reply With Quote
Old 10-20-2017, 10:22 AM   #4
WeeYari
 
WeeYari's Avatar
 
Drives: 06 Polar White 5dr, 13 Soul 4u
Join Date: Oct 2008
Location: Georgetown, Ontario, Canada
Posts: 4,717
This is the culprit.



Sent from my Elite_5_5_Octa using Tapatalk
__________________
WeeYari is offline   Reply With Quote
Old 10-20-2017, 11:42 AM   #5
Uten
 
Drives: Yaris 1.3 vvt-i
Join Date: Jun 2014
Location: Norway
Posts: 6
@WeeYari Thanks for the suggestion. Will check into that tonight.
Uten is offline   Reply With Quote
Old 10-20-2017, 04:29 PM   #6
IllusionX
It's the illusion you see
 
Drives: 07 Yaris Sedan Aero
Join Date: Oct 2006
Location: Brossard, QC
Posts: 3,557
Quote:
Originally Posted by WeeYari View Post
This is the culprit.



Sent from my Elite_5_5_Octa using Tapatalk
Did you just completely removed it?

Sent from my SM-G930W8 using Tapatalk
__________________
IllusionX is online now   Reply With Quote
Old 11-02-2017, 11:22 AM   #7
Uten
 
Drives: Yaris 1.3 vvt-i
Join Date: Jun 2014
Location: Norway
Posts: 6
I have finally found the culprit. It was a faulty ( new ) oil-filter. Luckily I did not drive the car.

After 8 days in the garage I got a car mechanic to come by and listen to it. Started it and..... dang no disturbing noise. We went outside and talked a bit and then by chance a car drove by with about the same noise but a lot worse. It was the sound of valves breaking down. The mechanic said aha and I had to confirm that I had replaced oil and filter a few days prior to the problem.

Check the oil-filter was the advice.

I drained the new oil. It was blackish even just after a few km of driving. Then took out the oil filter. The oil in it was clean, just as it is straight from the bottle. Indicating a circulation problem.

The mechanic had experienced this once before. Faulty oil-filter resulting in to low oil pressure ( my oil lamp did not indicate any fault ).

Anyway, new oil-filter and I'm back on the road. :o)
Uten is offline   Reply With Quote
Old 11-02-2017, 04:45 PM   #8
jra
 
Drives: 2015 yaris L
Join Date: Jun 2016
Location: Indiana
Posts: 64
What brand oil filter was you using?
jra is offline   Reply With Quote
Old 11-02-2017, 05:37 PM   #9
bronsin
 
bronsin's Avatar
 
Drives: 2009 Base Hatch 2 Dr Auto
Join Date: Dec 2008
Location: nj
Posts: 3,791
Wow he dodged a serious bullet! My 1980 Subaru hatchback would knock when I put a frame filter on it. I took it off right away. Tried it twice to!

Kudos to your mechanic for asking what was recently done to the car before the problem! And excellent diagnostic procedure!
__________________
Synthetic Oil: Its All In Your Head
bronsin is online now   Reply With Quote
Old 11-03-2017, 08:25 AM   #10
dogsridewith
 
Drives: 2007 2-door hatchback
Join Date: Jul 2016
Location: USAnotCA
Posts: 384
New oil filter obstructs oil flow engine rattles Toyota Yaris

Well, that's a new one on me. How is it even possible? Something to do with the anti-drainback valve? (Stuck tight somehow?) Some part installed upside down during manufacturing?
(New oil filter obstructs oil flow engine rattles)
dogsridewith is offline   Reply With Quote
Old 11-05-2017, 06:34 PM   #11
john21031
 
Drives: '10 Fit Sport MT and 2012 Fit
Join Date: Oct 2008
Location: Castaic, CA
Posts: 119
Always need to do a diagnosis near the car instead of relying on people from the internet. There is no way for anyone to know where you specific noise is coming from.
To locate the source of the noise, a stethoscope is used.
https://www.familyhandyman.com/tools...cope/view-all/
john21031 is offline   Reply With Quote
Old 11-06-2017, 05:01 PM   #12
white89gt
 
Drives: 2007 Yaris
Join Date: Aug 2017
Location: UT
Posts: 31
Please tell us what brand. I'm betting it's orange in color.
white89gt is offline   Reply With Quote
Old 11-07-2017, 08:34 AM   #13
hairygityeti
Sir Rustalot
 
Drives: Toyota Yaris silver 2000 reg
Join Date: Sep 2017
Location: United Kingdom
Posts: 113
Quote:
Originally Posted by WeeYari View Post
Exhaust manifold heat shield. Mine corroded out recently at the mounting points by the flange and exhibited exactly what you are experiencing.

Sent from my Elite_5_5_Octa using Tapatalk
Wee yari mate i thought i had the monopoly on rust! lol my heat shield is looong gone! gave its last death rattle on our first outing.
__________________
If it wasnt for my modesty ,i would be perfect !
hairygityeti is offline   Reply With Quote
Old 11-09-2017, 05:43 PM   #14
Uten
 
Drives: Yaris 1.3 vvt-i
Join Date: Jun 2014
Location: Norway
Posts: 6
Quote:
Originally Posted by jra View Post
What brand oil filter was you using?
It's a wix. Got it form the local shop ( chain shop not a garage ). Have used the same brand for 10 years on various cars, no problems. Anyway got a Lexus/Toyota" genuin part now. I guess I should try to figure out what is wrong with the filter, or if I had managed to put it on wrong ( if that is even possible). But it does not itch that bad.

Regarding the noice. I find it handy to ask on the net. Often I get answers that will lead me in the right direction, but obviously you have to verify. We have salty on my local road during the winter so it could just as well have been a rusty part. ex: the cover on the back break disk has to be replaced as it is nothing but rust.

Thanks for all comments and advice.
Uten is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Zage Turbo Kit Install - Toyota Yaris Focus_Sh1ft Forced Induction Forum 139 07-07-2017 01:26 PM
1.0 Aygo Engine: clicking noise - worn valves or bearings? dj92 General Yaris / Vitz Discussion 2 06-07-2016 03:54 PM
RATTLING NOISE EXHAUST PIPE/BACK OF ENGINE joeljcruz86 DIY / Maintenance / Service 15 09-13-2014 06:46 PM
Very loud noise from the engine Stiv DIY / Maintenance / Service 27 10-27-2009 10:09 AM
engine noise?? poshi General Yaris / Vitz Discussion 23 09-04-2006 10:45 PM


All times are GMT -4. The time now is 12:53 PM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.