Toyota Yaris Forums - Ultimate Yaris Enthusiast Site


Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 02-10-2018, 04:28 AM   #1
Drives: 2010 yaris .10
Join Date: Feb 2018
Location: cape town
Posts: 2
no power when warm

I have a 2010 1.0 three cylinder with 170000 kms on the clock.
just yesterday it lost all power and could only creep very slowly - this was during a warmed up drive. at this point it started and idled perfectly, but when feeding in the throttle, it just kind of died, unless I let it idle in gear, at which point it would slowly crawl.
this morning when it was cold it started and revved freely. I am yet to take it out and warm it up, because I am loathe to get it stuck somewhere and have to go through this again.
Any ideas please?
sniffter is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Installation of original power windows and locks in Yaris lantis DIY / Maintenance / Service 4 02-25-2012 02:38 PM
When will the Yaris hit the showrooms at dealers? Petrolhead New YARIS Purchase Forum 181 11-28-2011 08:03 AM
Power lock questions Taiyaki DIY / Maintenance / Service 22 04-22-2009 10:22 PM
Well seems the F&*king Power Package with Manual is impossible in the States(Hatch) gaffo General Yaris / Vitz Discussion 28 07-15-2007 07:55 PM
oops is too much power bad sdmf In Car Entertainment + Electronics (audio / video / alarm) 5 07-08-2007 04:08 PM

All times are GMT -4. The time now is 09:08 AM.

Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.