Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 01-28-2015, 10:05 PM   #1
Christine88
 
Drives: 2009 Yaris
Join Date: Jan 2015
Location: South Carolina
Posts: 14
2011 Yaris won't shift out of first gear

Hi I have a 2011 Yaris that suddenly won't shift out of first gear after stopping briefly to check my mail. The check engine and trac inop light is on. Also oddly when I place the car in drive, or reverse the D or R doesn't come on to indicate what gear I'm in. In fact the only letter that shows is the L for low gear. This is an automatic transmission Yaris. Also the engine sounds kind of like its racing. I checked the transmission fluid with engine hot but not running and parked on a hill. The level was in the cold section of the dip stick. Maybe because it's on a hill? Anyone have any clues to what the problem could be? Fortunately I have a spare Toyota Echo I can drive but I need to get this fixed?

Last edited by Christine88; 01-29-2015 at 09:07 AM.
Christine88 is offline   Reply With Quote
Old 01-28-2015, 10:08 PM   #2
ex-x-fire
 
Drives: 2010 yaris 3 door hatch
Join Date: Jun 2013
Location: Sheboygan Falls, Wi.
Posts: 188
I'd start by getting the check engine light code(s).
ex-x-fire is offline   Reply With Quote
Old 01-28-2015, 10:19 PM   #3
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
Definitely have the codes read for why the check engine light is on. Has any work been done recently or have you run over anything on the road? The transmission/gear display behavior sounds like a problem with the switch on the transmission that the shifter cable engages. If that switch is damaged it will behave like what you are seeing.
CTScott is offline   Reply With Quote
Old 01-28-2015, 10:42 PM   #4
Christine88
 
Drives: 2009 Yaris
Join Date: Jan 2015
Location: South Carolina
Posts: 14
Quote:
Originally Posted by CTScott View Post
Definitely have the codes read for why the check engine light is on. Has any work been done recently or have you run over anything on the road? The transmission/gear display behavior sounds like a problem with the switch on the transmission that the shifter cable engages. If that switch is damaged it will behave like what you are seeing.
Yes I did run over something come to think of it but it was days ago maybe even a week. I remember hoping it didn't do any damage so it must have been loud enough to have gotten my attention. Would checking the fluid on a hill effect the level?

Is that switch on the outside?
Christine88 is offline   Reply With Quote
Old 01-28-2015, 11:12 PM   #5
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
Checking the fluid on a hill would effect the level and fluid couldn't cause what you are seeing.

The switch is mounted to the front of the transmission, which is located just below the air intake box at the very front on the driver's side. If you pop the hood and look between the radiator and the engine you can get a view of it. To really get at it you need to remove the air intake assembly. The switch is circled in the image below.

The object which you hit may have bent the arm that actuates the switch and after a bunch times moving it, it may have come loose:

Yaris Park Reverse Neutral Switch.jpg
CTScott is offline   Reply With Quote
Old 01-28-2015, 11:14 PM   #6
Christine88
 
Drives: 2009 Yaris
Join Date: Jan 2015
Location: South Carolina
Posts: 14
Quote:
Originally Posted by CTScott View Post
Checking the fluid on a hill would effect the level and fluid couldn't cause what you are seeing.

The switch is mounted to the front of the transmission, which is located just below the air intake box at the very front on the driver's side. If you pop the hood and look between the radiator and the engine you can get a view of it. To really get at it you need to remove the air intake assembly. The switch is circled in the image below.

The object which you hit may have bent the arm that actuates the switch and after a bunch times moving it, it may have come loose:

Attachment 54884
Thanks for the photo. Is that thing expensive?
Christine88 is offline   Reply With Quote
Old 01-28-2015, 11:26 PM   #7
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
Quote:
Originally Posted by Christine88 View Post
Thanks for the photo. Is that thing expensive?
It's about $200 online or $300 from a Toyota dealer. (84540-46010)

If you are lucky though you will find that something is slightly bent or loose.
CTScott is offline   Reply With Quote
Old 01-28-2015, 11:28 PM   #8
Christine88
 
Drives: 2009 Yaris
Join Date: Jan 2015
Location: South Carolina
Posts: 14
Quote:
Originally Posted by CTScott View Post
It's about $200 online or $300 from a Toyota dealer. (84540-46010)

If you are lucky though you will find that something is slightly bent or loose.
Thank you I'll take a look at it tomorrow.
Christine88 is offline   Reply With Quote
Old 01-29-2015, 08:48 AM   #9
Christine88
 
Drives: 2009 Yaris
Join Date: Jan 2015
Location: South Carolina
Posts: 14
Quote:
Originally Posted by CTScott View Post
It's about $200 online or $300 from a Toyota dealer. (84540-46010)

If you are lucky though you will find that something is slightly bent or loose.
Actually it's a 2011. I had a 2009 but traded it in for this one. Would it be the same part?
Christine88 is offline   Reply With Quote
Old 01-29-2015, 12:55 PM   #10
bronsin
 
bronsin's Avatar
 
Drives: 2009 Base Hatch 2 Dr Auto
Join Date: Dec 2008
Location: nj
Posts: 3,901
Yes! Take the car to the shop and theyll quickly sort it out.

Or put it up on ramps and look yourself.
__________________
Synthetic Oil: Its All In Your Head
bronsin is offline   Reply With Quote
Old 01-29-2015, 02:36 PM   #11
Christine88
 
Drives: 2009 Yaris
Join Date: Jan 2015
Location: South Carolina
Posts: 14
Quote:
Originally Posted by bronsin View Post
Yes! Take the car to the shop and theyll quickly sort it out.

Or put it up on ramps and look yourself.
I looked at it and there is no obvious damage that I could see. The cable actuates the lever and the lever doesn't appear bent. The cable is still connected. So I guess it's the switch. I'm going have to have it towed to the Toyota place to have them look at. Their price is $264 for the switch and about $100 labor. Not too bad I guess but they need to look at it to be sure that it's the switch. Is it unusual for that switch to go bad only after 79000 miles?
Christine88 is offline   Reply With Quote
Old 01-29-2015, 03:31 PM   #12
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
I have only heard of one person on here having one fail and his had suffered internal corrosion from water getting into the switch body.
CTScott is offline   Reply With Quote
Old 01-29-2015, 05:26 PM   #13
Christine88
 
Drives: 2009 Yaris
Join Date: Jan 2015
Location: South Carolina
Posts: 14
Quote:
Originally Posted by CTScott View Post
I have only heard of one person on here having one fail and his had suffered internal corrosion from water getting into the switch body.
I don't know what else it could be.
Christine88 is offline   Reply With Quote
Old 01-29-2015, 08:01 PM   #14
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
Quote:
Originally Posted by Christine88 View Post
I don't know what else it could be.
I agree that it is most likely the culprit. It is just an uncommon issue and may be related to the object that you hit.
CTScott is offline   Reply With Quote
Old 11-18-2017, 10:45 AM   #15
HydeBaker
I've made a post!
 
Drives: 2009 Yaris
Join Date: Nov 2017
Location: 98403
Posts: 1
Was this issue resolved? what was the problem. I'm having a very similar problem on an 09' Yaris
HydeBaker is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: Various Parts from a 2009 Yaris Hatchback Freestylin Items for Sale by private party 17 02-24-2016 10:36 PM
**SAFETY RECALL!! 06-07 YARIS HB & SEDANS** slvryaris DIY / Maintenance / Service 84 09-30-2012 12:25 PM
2009 Yaris LB 5-speed MGargano Cars for Sale by private party 9 02-04-2012 02:01 AM
NEWS: TOYOTA REVEALS ALL-NEW YARIS SEDAN AT 2006 LOS ANGELES AUTO SHOW VitzBoy General Yaris / Vitz Discussion 5 09-05-2010 08:53 PM
2007 Yaris Pricing Info ! YarisBueller New YARIS Purchase Forum 104 06-24-2009 04:54 PM


All times are GMT -4. The time now is 08:38 PM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.