Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 03-12-2017, 01:00 PM   #1
lasherza
 
Drives: Toyota Yaris 1.3
Join Date: Mar 2017
Location: South Africa
Posts: 3
Yaris 1.3 T3+AT Hatch 08

Hi,

I have a suspected issue with the water pump system. The vehicle is a 1.3 T3 08 Automatic Hatch. I think the model year is 2010 , not sure what the 08 is but my late father bought the vehicle new in 2010, At the moment the car is in fact running with no apparent issues.

I discovered the damage after hearing a strange noise in the wheel area at very slow speeds, almost like a tin can or loose bolt was in the drum or something ,was rattling. I suspect this could be an unrelated issue, as the braking system is fine .

So what i saw was the water pump centrifuge, or the piece that sticks out, i think is the water pump, apologies i am a VERY novice mechanically with re cars. A broken piece or two.... please see pic attached here. from under the unit... I see there is no belt running off this piece. Is this how this vehicle is configured..?

Any advice is appreciated!! . Would i need to replace this whole pump ASAP , or just this end piece?

https://www.facebook.com/photo.php?f...type=3&theater

Thanks!
Laurence
Attached Images
File Type: jpg waterpump.jpg (57.3 KB, 10 views)
lasherza is offline   Reply With Quote
Old 03-12-2017, 01:20 PM   #2
WeeYari
 
WeeYari's Avatar
 
Drives: 06 Polar White 5dr, 13 Soul 4u
Join Date: Oct 2008
Location: Georgetown, Ontario, Canada
Posts: 4,492
That is not the water pump. It is the a/c compressor. Since there currently is no belt running to it, I suspect that pulley damage occurred quite some time ago, and a shorter, by-pass the a/c belt was put in. Your car currently has no air conditioning.
__________________
WeeYari is offline   Reply With Quote
Old 03-12-2017, 01:40 PM   #3
lasherza
 
Drives: Toyota Yaris 1.3
Join Date: Mar 2017
Location: South Africa
Posts: 3
You are too clever! - that is exactly the case - No aircon !! - Whew . Thanks so much for clearing this up! . I was worried it could affect the engine somehow.

At least now i know , so you saying this unit will have to be completely replaced for the aircon to work again?
lasherza is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Comparison Test: 2012 Toyota Yaris Vs. 2012 Toyota Prius c Yar Is Word Third Gen Yaris General Discussion 27 09-06-2012 11:37 PM
2nd-Gen Yaris hatch at San Diego Comic Con 2012 Mitey Photo-Video-Media Gallery 4 07-17-2012 09:21 PM
What will fit in a 5 door hatch Yaris? ruby9c New YARIS Purchase Forum 16 12-31-2010 01:46 PM
NEWS: TOYOTA REVEALS ALL-NEW YARIS SEDAN AT 2006 LOS ANGELES AUTO SHOW VitzBoy General Yaris / Vitz Discussion 5 09-05-2010 08:53 PM
Yaris Sedan Vs. Yaris 4dr. hatch Meow General Yaris / Vitz Discussion 11 10-29-2006 03:11 PM


All times are GMT -4. The time now is 11:40 AM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.