Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 05-10-2019, 01:22 PM   #1
JJRL07
 
Drives: 07 yaris
Join Date: May 2019
Location: Florida
Posts: 3
Rough running and idiling

I have an 07 and while in drive with my foot on the break it spits and sputters. It does it while driving too unless i have it floored. I have replaced the fuel pump,mass air flow sensor, coil packs, spark plugs and the throttle body. Nothing has helped. If anyone could give me any advice i could sure use it. Thank you
JJRL07 is offline   Reply With Quote
Old 05-10-2019, 01:30 PM   #2
tmontague
 
tmontague's Avatar
 
Drives: '08 2zr swapped Vios M/T
Join Date: Oct 2012
Location: Hamilton Ont.
Posts: 2,789
Vacuum leak in the brake booster? I'd be checking the booster first.

Did you replace all those other things hoping it would fix your problem? That's an expensive venture...
__________________
No one ever wants to give a Yaris the point by...
tmontague is offline   Reply With Quote
Old 05-10-2019, 02:37 PM   #3
JJRL07
 
Drives: 07 yaris
Join Date: May 2019
Location: Florida
Posts: 3
Yes i did replace all that hoping to fix the problem. Its my wifes car so im doing everything i can think of to get it fixed.
JJRL07 is offline   Reply With Quote
Old 05-11-2019, 12:02 PM   #4
seatech30
 
Drives: Yaris 2008 Sedan
Join Date: Nov 2010
Location: California
Posts: 75
Fuel injectors maybe? My yaris has had a vibration issue since around 130k miles. Never found a fix. Did just about everything you did, checked the timing chain, fuel cleaner, motor mounts twice replaced. Scotty Kilmer said it was transmission wear and his old celica has same issue, to just drive it until broke. Car is now at 262k miles about 5 years later, vibration is a bit worse, but oh well, still running great aside from that.
seatech30 is offline   Reply With Quote
Old 05-12-2019, 07:15 PM   #5
Leegamer
 
Leegamer's Avatar
 
Drives: 2008 Yaris HB 5-Speed
Join Date: Mar 2012
Location: Ashland, VA
Posts: 408
No CEL I'm guessing?
__________________
I'm a hermit named Lee
Leegamer is online now   Reply With Quote
Old 05-12-2019, 08:20 PM   #6
tmontague
 
tmontague's Avatar
 
Drives: '08 2zr swapped Vios M/T
Join Date: Oct 2012
Location: Hamilton Ont.
Posts: 2,789
Fyi- while diagnosing a terrible misfire on my Vibe this weekend I noticed that the CEL wouldn't come on during a constant misfire at idle. I needed to actually drive the car and give it throttle to trigger a CEL.

Even when the CEL did not illuminate there was a stored pending code but no CEL. In other words, you need a decent ecu scanner to pick up stored/pending codes but for ones that have yet to trigger the CEL. Something to keep in mind
__________________
No one ever wants to give a Yaris the point by...
tmontague is offline   Reply With Quote
Old 05-13-2019, 03:58 PM   #7
JJRL07
 
Drives: 07 yaris
Join Date: May 2019
Location: Florida
Posts: 3
Thank you everyone. I will look into that
JJRL07 is offline   Reply With Quote
Old 05-15-2019, 01:15 AM   #8
seatech30
 
Drives: Yaris 2008 Sedan
Join Date: Nov 2010
Location: California
Posts: 75
Do you have an ODBII reader btw? On my AT, my idling in D was below 650, cleaning the TB helped bring it back up to 650ish. Unfortunately, it still dips under a bit and causes the vibration. I noticed any additional pull on current, A/C/fans, causes the rpm to dip and lead to more vibration. Maybe you can see if your sputtering coincides with rpms. I need to perform a compression test on the engine to see how that looks, but don't have the equipment, so may have to pay to get it done.

Also, have you done the fuel injector listening test? There's videos on youtube on how to do it.
seatech30 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 02:27 PM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.