Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 07-27-2011, 08:56 PM   #1
Battlekat
 
Drives: Yaris 4 door. Sport
Join Date: Jul 2007
Location: La Puente, CA
Posts: 7
Torque converter clutch solenoid issues

I heard this is a common problem with yaris/corolla transmissions.

Car stutters. Check engine light is on.
get trouble codes. solenoid checks outs good. replace anyway. still receive trouble codes.

anyone have experience with this issue? is there something else causing the issue?

Tech wants to rebuild tranny. my wallet is bleeding.
__________________
Some mistakes are too fun to make only once.
Battlekat is offline   Reply With Quote
Old 07-27-2011, 09:18 PM   #2
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,455
There was a TSB for a torque converter clutch solenoid error code issue on 1st gen Yaris (and 04-05 Corolla), but in the TSB if the TCC solenoid checked out OK, then it pointed to following the standard troubleshooting procedures to determine if it is actually a bad torque converter. Do you know what the actual DTC is?
CTScott is offline   Reply With Quote
Old 07-27-2011, 09:38 PM   #3
Battlekat
 
Drives: Yaris 4 door. Sport
Join Date: Jul 2007
Location: La Puente, CA
Posts: 7
i think he said simply P0740
__________________
Some mistakes are too fun to make only once.
Battlekat is offline   Reply With Quote
Old 07-27-2011, 09:49 PM   #4
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,455
Quote:
Originally Posted by Battlekat View Post
i think he said simply P0740
The U340 AT on the Yaris doesn't have that code (which was the one for the Corolla). On the Yaris, the ones related to the TCC solenoid are:

P2757: Torque Converter Clutch Pressure Control Solenoid Performance (Shift Solenoid Valve SLU)

P2759: Torque Converter Clutch Pressure Control Solenoid Control Circuit Electrical (Shift Solenoid Valve SLU)
CTScott is offline   Reply With Quote
Old 07-27-2011, 09:51 PM   #5
Battlekat
 
Drives: Yaris 4 door. Sport
Join Date: Jul 2007
Location: La Puente, CA
Posts: 7
ok i must have misunderstood him. he was talking about corollas having the same problem. i probably just didnt catch it. sorry. it was a lot of information for me.
__________________
Some mistakes are too fun to make only once.
Battlekat is offline   Reply With Quote
Old 07-27-2011, 09:53 PM   #6
Battlekat
 
Drives: Yaris 4 door. Sport
Join Date: Jul 2007
Location: La Puente, CA
Posts: 7
ill ask him again next time we talk. i appreciate your response
__________________
Some mistakes are too fun to make only once.
Battlekat is offline   Reply With Quote
Old 07-27-2011, 09:54 PM   #7
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,455
Quote:
Originally Posted by Battlekat View Post
ok i must have misunderstood him. he was talking about corollas having the same problem. i probably just didnt catch it. sorry. it was a lot of information for me.
If you can, find out what the code is. On this forum there have been few complaints of AT issues on Yaris.
CTScott is offline   Reply With Quote
Old 07-28-2011, 03:41 PM   #8
Battlekat
 
Drives: Yaris 4 door. Sport
Join Date: Jul 2007
Location: La Puente, CA
Posts: 7
The code was P2757.

He also said he inspected the torque converter itself this morning and it was perfectly good also.
__________________
Some mistakes are too fun to make only once.
Battlekat is offline   Reply With Quote
Old 07-28-2011, 03:50 PM   #9
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,455
Quote:
Originally Posted by Battlekat View Post
The code was P2757.

He also said he inspected the torque converter itself this morning and it was perfectly good also.
P2757 has quite a few possible causes:

1. Shift solenoid valve SLU remains open or closed
2. Valve body is blocked
3. Shift solenoid valve SLU
4. Torque converter clutch
5. Automatic transaxle (clutch,brake or gear etc.)
6. Line pressure is too low
7. ECM

Considering how many ATs are available with low mileage from wrecked cars for well under $1000, I would probably look at replacement, rather than repair. From what I've seen with tranny shops, most rebuilds end up as replacements, often at a higher expense than a swap out would have been (due to the labor spent in the attempted repair).

How many miles are on your current tranny?
CTScott is offline   Reply With Quote
Old 07-29-2011, 10:43 PM   #10
auxmike
 
auxmike's Avatar
 
Drives: 2008 HB, A/T, Power W/L/M
Join Date: Oct 2008
Location: LI, New Yawk
Posts: 2,070
This is the first I've heard about bad A/Ts. I would hope these problems don't arise till at least after 100k...
__________________

Never take eyes off opponent - Bruce Lee
auxmike is offline   Reply With Quote
Old 02-09-2014, 01:05 PM   #11
Cudd23
 
Drives: 08 2dr
Join Date: Feb 2014
Location: MA
Posts: 2
hey guys new to the forum here. i actually just had this code pop up today with 98 thousand miles on the car. it's telling me the solenoid is stuck off, does anyone know if that solenoid is inside the transmission or not.
Cudd23 is offline   Reply With Quote
Old 02-09-2014, 01:09 PM   #12
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,455
Quote:
Originally Posted by Cudd23 View Post
hey guys new to the forum here. i actually just had this code pop up today with 98 thousand miles on the car. it's telling me the solenoid is stuck off, does anyone know if that solenoid is inside the transmission or not.
There are three solenoids within the tranny. All three are easily accessible with the pan removed (but are crazy expensive from Toyota). What specific code are you getting?
CTScott is offline   Reply With Quote
Old 02-09-2014, 01:10 PM   #13
Cudd23
 
Drives: 08 2dr
Join Date: Feb 2014
Location: MA
Posts: 2
im getting p2757
Cudd23 is offline   Reply With Quote
Old 02-09-2014, 01:25 PM   #14
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,455
Quote:
Originally Posted by Cudd23 View Post
im getting p2757
OK. That is definitely the code for the Shift solenoid valve SLU. There are actually 5, not 3, but the SLU is easily replaceable.

You can test the SLU to determine if it is bad or if the torque converter is bad.

You can grab the AT service manual from the Micro Image forum:

http://www.microimageonline.com/foru...32-YARIS-FILES
CTScott is offline   Reply With Quote
Old 09-05-2017, 10:32 AM   #15
89GLH
 
Drives: 2009 Yaris 4 door hatch
Join Date: Dec 2008
Location: Frederick, MD
Posts: 27
Anyone got an updated link since Micro Image is gone?

Sent from my VS995 using Tapatalk
89GLH is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP PLEEEASE!!! my yaris starts whenever I step on the clutch pedal. trini_per4mance DIY / Maintenance / Service 42 03-27-2017 03:59 AM
Clutch shudder when setting off in 1st gear BuildCode DIY / Maintenance / Service 88 06-17-2015 07:14 AM
NEED ENGINE CHECK LIGHT CODE LIST Attitude Forced Induction Forum 12 04-11-2011 06:38 PM
Help Me Find The Right Clutch RacerFreakXXX Performance Modifications 18 10-20-2010 05:20 PM
Having clutch issues ? hystria DIY / Maintenance / Service 10 08-22-2007 11:34 AM


All times are GMT -4. The time now is 12:05 PM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.