Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 04-10-2018, 09:28 AM   #1
vinooooo93
 
Drives: Toyota Yaris 2006 Sedan
Join Date: Aug 2014
Location: Australia
Posts: 13
Red face 2006 Yaris Headlight Issue

Hey everyone,

I recently replaced the front headlight bulb (driver's side) about a week ago and everything was working all fine.

However, this morning while I was starting the car and checked the lights, I noticed that the high beam indicator stays ON even when its on low beam mode. I pushed and pulled the stalk and the high beam sign remained there.

Also, the headlight bulb that I just replaced a week ago is now very dim, less bright and darker yellow looking compared to what it looked like before. I took the bulb out and there doesn't appear to be any signs of it being blown out..

Any thoughts on what could be causing this issue? Much appreciated
vinooooo93 is offline   Reply With Quote
Old 04-10-2018, 12:07 PM   #2
David C
 
Drives: White '07 3dr LB
Join Date: Jun 2016
Location: Montreal
Posts: 475
With the replaced bulb removed, does the high beam indicator still on all the time ?

There's a lot of over engineering going on with the beam control circuit in the Yaris (at least in my opinion), it's not just a simple on/off switch for the low and the high beams.

First I'd disconnect the connector for the driver side main bulb, then check if the high beam indicator is back to normal. If not, disconnect the other side bulb and it should not come on anymore even with the stalk on high beam, because the indicator LED is powered trough the low beam (I know it's messed up).

Next connect only the driver side bulb and see if everything is back to normal. If not, try a new bulb and if it fix the issue, change the pair.

Also with an ohmmeter, check the resistance of the high and low beam of both bulbs. They should be very similar. Otherwise change the pair.

I don't know how different the Australian Yaris are from North American ones, so I can't make too many assumptions.
David C is offline   Reply With Quote
Old 04-10-2018, 03:37 PM   #3
B.B._07
 
Drives: 07 5dr
Join Date: Nov 2015
Location: YYC
Posts: 141
From your description of the problem I'd suspect an internal short of the headlight bulb. A quick check would be to move the suspect bulb to the other headlight and see if the problem moves with the bulb. There's nothing really over engineered about the headlight wiring on the Yaris. It is a ground side switched system which is somewhat odd, but it's now common on many modern Japanese cars.
B.B._07 is offline   Reply With Quote
Old 04-10-2018, 06:35 PM   #4
David C
 
Drives: White '07 3dr LB
Join Date: Jun 2016
Location: Montreal
Posts: 475
Quote:
Originally Posted by B.B._07 View Post
From your description of the problem I'd suspect an internal short of the headlight bulb. A quick check would be to move the suspect bulb to the other headlight and see if the problem moves with the bulb. There's nothing really over engineered about the headlight wiring on the Yaris. It is a ground side switched system which is somewhat odd, but it's now common on many modern Japanese cars.


Wait till you see the wiring diagram for the cluster high beam indicator. You'll be wtf. You also loose the indicator if you switch to LED main bulbs due to the wiring design of the car.
David C is offline   Reply With Quote
Old 04-11-2018, 06:08 PM   #5
vinooooo93
 
Drives: Toyota Yaris 2006 Sedan
Join Date: Aug 2014
Location: Australia
Posts: 13
Thank for all your help,

I tested the new lightbulb by changing it to the passenger side headlight and it remained problematic. Whenever i remove the new light bulb out, the high beam indicator issue was fixed. So i guess it comes down to maybe it being a faulty bulb so im going to head out and buy a new one and see how it goes
vinooooo93 is offline   Reply With Quote
Old 04-11-2018, 06:25 PM   #6
David C
 
Drives: White '07 3dr LB
Join Date: Jun 2016
Location: Montreal
Posts: 475
Quote:
Originally Posted by vinooooo93 View Post
Thank for all your help,



I tested the new lightbulb by changing it to the passenger side headlight and it remained problematic. Whenever i remove the new light bulb out, the high beam indicator issue was fixed. So i guess it comes down to maybe it being a faulty bulb so im going to head out and buy a new one and see how it goes


Unless the other build is recent, you should change them in pairs.

Btw I did LED in mine and it's great, just make sure to buy those with the light shield if you're using H4 bulbs to get the proper cutoff.
David C is offline   Reply With Quote
Old 04-13-2018, 04:48 AM   #7
vinooooo93
 
Drives: Toyota Yaris 2006 Sedan
Join Date: Aug 2014
Location: Australia
Posts: 13
Solved: It was an issue with the bulb. Got both of them replaced. No more headlight high beam indicator problem too. Thanks for all the help!
vinooooo93 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is a 2006 Yaris coupe different from a 2007 Yaris coupe? fuzzybabybunny General Yaris / Vitz Discussion 0 02-25-2016 08:09 PM
Yaris 2014 headlight issue YarisEP Third Gen Yaris General Discussion 3 12-23-2015 06:16 PM
06-10 Yaris Sedan cold air intake $40 kylevh21 Items for Sale by private party 2 04-01-2012 02:14 PM
NEWS: TOYOTA REVEALS ALL-NEW YARIS SEDAN AT 2006 LOS ANGELES AUTO SHOW VitzBoy General Yaris / Vitz Discussion 5 09-05-2010 08:53 PM
2007 Yaris Pricing Info ! YarisBueller New YARIS Purchase Forum 104 06-24-2009 04:54 PM


All times are GMT -4. The time now is 04:46 AM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.