Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 08-19-2015, 12:12 PM   #1
garrettbeachy
 
Drives: 2009 Yaris
Join Date: Sep 2014
Location: United States
Posts: 7
09 Yaris Electrical Problems (P/S, ABS, AC, Speedo, Blinkers, Wipers Not Functioning)

Hey everybody,

I am having some trouble with my 09 base manual Yaris.

A while ago, I installed a power window conversion kit into my Yaris. Last night, I was experimenting with a new switch for the kit that would integrate into my dash a little bit better. As I was connecting the new switch, I accidentally bumped 2 of the contacts together, it arced and I popped the 25a fuse for the power window kit. At this point everything else is working fine, so I figured all that I needed was a new fuse and I would be fine.

This morning, I drove it into an auto parts store to get a new fuse. With no fuse connected to the main 12v power for the windows, I attempted to install the new switch again. At this point, the only power coming to the switch should have been acc 12v that drives a small led in the new switch when the car is on. So, with the main 12v fuse out, I connect the new switch, taking care not to touch any contacts together.

A couple of seconds after I connected the switch, everything shut off. No AC, power steering, speedometer, ABS, airbags, blinkers, wipers, cigarette lighter, or radio. The headlights still work, and the car still cranks up. When I turn the car on, the check engine light comes on momentarily and then shuts back off, but the P/S, ABS, airbags, and TPMS lights stay on.

I pulled and checked just about every fuse that I could find, including the fuse box in the engine bay, the one under the dash, and the 60a main fuse that's next to the positive battery connector.

So, I drive it to my shop. It is highway most of the way, and it seemed to drive fine the whole way there. The only weird thing that happened was the speedo jumped around once I got off of the highway. It stayed at zero the whole time on the highway, and as soon as I started slowing down, it started jumping up and down between 0 and 80, with no correlation to the actual speed of the car.

It's in the shop now, so I don't have access to it, but I'm afraid that I may have broken something very expensive, such as the ECU. I move from Georgia to Oklahoma in 8 days, so I am hoping the car is not too badly damaged. Any help would be greatly appreciated!
garrettbeachy is offline   Reply With Quote
Old 08-19-2015, 06:49 PM   #2
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
With all of the things that are not functioning it sounds like you popped one of the two fusible links on the positive battery terminal.
CTScott is offline   Reply With Quote
Old 08-20-2015, 01:19 PM   #3
garrettbeachy
 
Drives: 2009 Yaris
Join Date: Sep 2014
Location: United States
Posts: 7
Quote:
Originally Posted by CTScott View Post
With all of the things that are not functioning it sounds like you popped one of the two fusible links on the positive battery terminal.
The shop called me back and said that it indeed was a fuse. They didn't say which fuse it was, or if it was one of the fusible links. Thanks for your help CTScott!
garrettbeachy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
YARIS FAQ (frequently asked questions) PK198105 General Yaris / Vitz Discussion 97 10-20-2018 08:52 PM
Consumer Reports Is On Crack!!! doublewam General Yaris / Vitz Discussion 83 05-07-2011 11:03 AM
Consumer Reports not too pleased with Yaris Befuddled General Yaris / Vitz Discussion 132 02-28-2011 03:57 PM
NEWS: TOYOTA REVEALS ALL-NEW YARIS SEDAN AT 2006 LOS ANGELES AUTO SHOW VitzBoy General Yaris / Vitz Discussion 5 09-05-2010 08:53 PM
2007 Yaris Pricing Info ! YarisBueller New YARIS Purchase Forum 104 06-24-2009 04:54 PM


All times are GMT -4. The time now is 05:38 PM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.