Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 03-09-2017, 11:01 PM   #1
nate0
 
Drives: 2013 hatchback Yaris
Join Date: Mar 2017
Location: London On
Posts: 18
Not Starting 2013 Yaris Hatchback

Hello everyone, I just had this 2013 Hatchback Yaris for about 3weeks now with 165km no accidents. It was running good until yesterday night, on my way back from work I filled up then drove home for like 20min. An hour later, someone else in the family use it to go to grocery. It all see fine.

In the morning I tried to start it. It would start for like a second or two and stop. It would do it again if I tries to crank 2-3 times. Then it would just crank after that, will not run momentarily and die.

I tried to use the quick start spray and it would start momentarily and die.
Is this a fuel pump problem or relay?

I am trying to find the relay to swap out but could not locate it.
Can someone tell me the name I am suppose to look for please?
Attached Images
File Type: jpg image.jpg (250.9 KB, 43 views)

Last edited by nate0; 03-10-2017 at 07:38 AM.
nate0 is offline   Reply With Quote
Old 03-09-2017, 11:03 PM   #2
nate0
 
Drives: 2013 hatchback Yaris
Join Date: Mar 2017
Location: London On
Posts: 18
"
Attached Images
File Type: jpg image.jpg (257.0 KB, 38 views)
nate0 is offline   Reply With Quote
Old 03-09-2017, 11:04 PM   #3
nate0
 
Drives: 2013 hatchback Yaris
Join Date: Mar 2017
Location: London On
Posts: 18
""
Attached Images
File Type: jpg image.jpg (305.4 KB, 38 views)
nate0 is offline   Reply With Quote
Old 03-09-2017, 11:05 PM   #4
nate0
 
Drives: 2013 hatchback Yaris
Join Date: Mar 2017
Location: London On
Posts: 18
"""
Attached Images
File Type: jpg image.jpg (202.5 KB, 38 views)
nate0 is offline   Reply With Quote
Old 03-09-2017, 11:06 PM   #5
nate0
 
Drives: 2013 hatchback Yaris
Join Date: Mar 2017
Location: London On
Posts: 18
."
Attached Images
File Type: jpg image.jpg (196.0 KB, 37 views)
nate0 is offline   Reply With Quote
Old 03-09-2017, 11:06 PM   #6
nate0
 
Drives: 2013 hatchback Yaris
Join Date: Mar 2017
Location: London On
Posts: 18
".
Attached Images
File Type: jpg image.jpg (156.3 KB, 37 views)
nate0 is offline   Reply With Quote
Old 03-09-2017, 11:10 PM   #7
nate0
 
Drives: 2013 hatchback Yaris
Join Date: Mar 2017
Location: London On
Posts: 18
When I turn the key to ON I don't hear the fuel pump. No sound from the back.
I was reading the other threads for 07 yaris they would jump the pins to manual activate the fuel.

Anyway I can do this on the 2013? Thanks
nate0 is offline   Reply With Quote
Old 03-10-2017, 12:09 PM   #8
Bluevitz-rs
1NZ-6spd Turbo
 
Bluevitz-rs's Avatar
 
Drives: '05 6-Spd Vitz RS Turbo
Join Date: Oct 2008
Location: Courtice, Ontario, Canada
Posts: 2,827
The pump will only turn on after cranking the engine. But it's much simpler to just check for power at the pump with a volt meter. Just remover the rear seat bottom and pull open the cover. You can use cheap sewing needles as pin probes.
Bluevitz-rs is offline   Reply With Quote
Old 03-10-2017, 02:30 PM   #9
nate0
 
Drives: 2013 hatchback Yaris
Join Date: Mar 2017
Location: London On
Posts: 18
Alright thanks for the good advice. I will take off the back seat sometime today and report back.
nate0 is offline   Reply With Quote
Old 03-10-2017, 03:19 PM   #10
tmontague
2zr-fe dream team
 
tmontague's Avatar
 
Drives: 08 Vios M/T, 05 4wd Vibe
Join Date: Oct 2012
Location: Hamilton Ont.
Posts: 1,641
How low was your fuel tank before you filled up?
__________________
2zr swapped Vios, oil catch can, TRD rear sway bar, MI lowering springs, In cabin+under hood SSK, TRD shift knob, HID projector/Halo lights, 10mm rear axle spacers, custom header back exhaust, Front splitter, Sickspeed dual horns, Tokiko Blue's in rear, triple gauges, Whiteline bushings, Sparco pedal covers, Viper Keyless entry, DC Sports CAI, NST u/d crank pulley, solid poly engine mounts, MR Racing Flywheel, Konig Dial Ins 15x7 +35
tmontague is offline   Reply With Quote
Old 03-10-2017, 06:12 PM   #11
nate0
 
Drives: 2013 hatchback Yaris
Join Date: Mar 2017
Location: London On
Posts: 18
Just a little under 1/4 left of a tank.

It's snowing outside today so I didn't took the back seat out yet.
But I did put in new Bosch plugs since it need a tuneup away. Plugs look old but clean no grease or anything. It's definitely not the battery as I tried to start it a few times normally(without quick start spray) and it start and stop.
So cranked, start for like a second and stop. Depress the gas pedal does not do anything.
nate0 is offline   Reply With Quote
Old 03-10-2017, 06:15 PM   #12
Bluevitz-rs
1NZ-6spd Turbo
 
Bluevitz-rs's Avatar
 
Drives: '05 6-Spd Vitz RS Turbo
Join Date: Oct 2008
Location: Courtice, Ontario, Canada
Posts: 2,827
Add a gallon of gas just to be 100% sure it isn't out of gas and the gauge is simply wrong.
Bluevitz-rs is offline   Reply With Quote
Old 03-10-2017, 06:26 PM   #13
tmontague
2zr-fe dream team
 
tmontague's Avatar
 
Drives: 08 Vios M/T, 05 4wd Vibe
Join Date: Oct 2012
Location: Hamilton Ont.
Posts: 1,641
If is cranks, catches and then died withinntje next 3 seconds that is what the immobliser does when it reads an incorrect key. Something to check just to be sure
__________________
2zr swapped Vios, oil catch can, TRD rear sway bar, MI lowering springs, In cabin+under hood SSK, TRD shift knob, HID projector/Halo lights, 10mm rear axle spacers, custom header back exhaust, Front splitter, Sickspeed dual horns, Tokiko Blue's in rear, triple gauges, Whiteline bushings, Sparco pedal covers, Viper Keyless entry, DC Sports CAI, NST u/d crank pulley, solid poly engine mounts, MR Racing Flywheel, Konig Dial Ins 15x7 +35
tmontague is offline   Reply With Quote
Old 03-10-2017, 06:36 PM   #14
nate0
 
Drives: 2013 hatchback Yaris
Join Date: Mar 2017
Location: London On
Posts: 18
I hook up the innova scantool. I forgot I had this.
It does show Engine Immobiliser System Malfunction and another Startability Malfunction.

For the gas, what I mean was I filled up when it was just below the 1/4. So it full and its show that on gauge.

What can I do if it reads the key as incorrect?
Attached Images
File Type: jpg image.jpg (285.1 KB, 26 views)

Last edited by nate0; 03-10-2017 at 06:50 PM.
nate0 is offline   Reply With Quote
Old 03-10-2017, 06:51 PM   #15
nate0
 
Drives: 2013 hatchback Yaris
Join Date: Mar 2017
Location: London On
Posts: 18
.
Attached Images
File Type: jpg image.jpg (285.4 KB, 26 views)
nate0 is offline   Reply With Quote
Old 03-10-2017, 07:03 PM   #16
tmontague
2zr-fe dream team
 
tmontague's Avatar
 
Drives: 08 Vios M/T, 05 4wd Vibe
Join Date: Oct 2012
Location: Hamilton Ont.
Posts: 1,641
Go to the dealership and get them to re program it. Or buy a techstream tool of eBay for cheap and do it yourself.

Although I'm curious As to how it suddenly stopped reading the key? What did the person do who drove your car? Could be a key issue or could be an immobilizer issue
__________________
2zr swapped Vios, oil catch can, TRD rear sway bar, MI lowering springs, In cabin+under hood SSK, TRD shift knob, HID projector/Halo lights, 10mm rear axle spacers, custom header back exhaust, Front splitter, Sickspeed dual horns, Tokiko Blue's in rear, triple gauges, Whiteline bushings, Sparco pedal covers, Viper Keyless entry, DC Sports CAI, NST u/d crank pulley, solid poly engine mounts, MR Racing Flywheel, Konig Dial Ins 15x7 +35
tmontague is offline   Reply With Quote
Old 03-10-2017, 07:08 PM   #17
Dodge Aries K
My Yaris is a taxi
 
Drives: 2014 Yaris LE and 2016 Yaris L
Join Date: Jul 2016
Location: Machesney Park, IL
Posts: 228
Try another key for the car. That's very odd for it to do that. Hopefully you have more than one?
__________________
-Karl the Uber/Lyft Driver
Dodge Aries K is offline   Reply With Quote
Old 03-10-2017, 08:44 PM   #18
nate0
 
Drives: 2013 hatchback Yaris
Join Date: Mar 2017
Location: London On
Posts: 18
Only have the one key :(
Dealership only option then for now as I kinda need the car. As ebay can take a while.
nate0 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
starting problem on 2008 d4d yaris georgeg General Yaris / Vitz Discussion 15 06-13-2016 10:26 AM
Yaris 2013 engine braking problem? pikador DIY / Maintenance / Service 5 01-05-2014 05:12 AM
2014 Mazda 3 Kal-El Off-topic / Other Cars / Everything else Discussions 32 11-08-2013 01:51 PM
NEWS: TOYOTA REVEALS ALL-NEW YARIS SEDAN AT 2006 LOS ANGELES AUTO SHOW VitzBoy General Yaris / Vitz Discussion 5 09-05-2010 08:53 PM
2007 Yaris Pricing Info ! YarisBueller New YARIS Purchase Forum 104 06-24-2009 04:54 PM


All times are GMT -4. The time now is 06:29 PM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.