Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 07-12-2017, 08:30 PM   #1
danggilmore
 
Drives: 2008 toyota yaris
Join Date: Jun 2017
Location: bay area
Posts: 4
Help Diagnose Sound Please!

Hi all!

I've got a 2008 with 137k on her.

I've been experiencing a high pitched electrical sounding sound that directly relates to when I push the gas pedal to accelerate. When I let go, the sound lets off but decelerates with the car if that makes sense.

I can't make the sound occur with the car in neutral or park so its really hard to pinpoint. I tried listening inside my alternator and i can hear a similar electrical noise but very quiet. I'm not too sure what an alternator is supposed to sound like.

It's not a super alarming sound. It sounds like a supercharged engine! Runs and drives wonderfully as always.

I looked under the hood and noticed coolant leak from my water pump. I was all excited and thought I found the cure to the noise. After new water pump installation today, the noise continued. :[

Is it my alternator? Is it possible its the fan?

Any input and help would be greatly appreciated! Thanks!
danggilmore is offline   Reply With Quote
Old 07-12-2017, 11:23 PM   #2
ABSPLASTIC
 
Drives: Twin-charged rotary V8 w/nos
Join Date: Nov 2011
Location: CALIFORNIA
Posts: 231
Sounds like a grounding issue. Do you have your radio on or anything plugged into your auxiliary during these times?
ABSPLASTIC is offline   Reply With Quote
Old 07-12-2017, 11:50 PM   #3
Kaotic Lazagna
 
Kaotic Lazagna's Avatar
 
Drives: '14 GT86, '08 Vitz
Join Date: Dec 2006
Location: Bay Area, CA
Posts: 9,581
If you can somehow record the sound, that would help.
Kaotic Lazagna is offline   Reply With Quote
Old 07-13-2017, 07:56 AM   #4
dogsridewith
 
Drives: 2007 2-door hatchback
Join Date: Jul 2016
Location: USAnotCA
Posts: 378
"Electrical Sound"

electrical sounds--spark plug discharge snap, thunder, area buzz during lightning storm, arc welder, transformer hum, various undesired noises coming out of the TV or stereo, ?
dogsridewith is offline   Reply With Quote
Old 07-13-2017, 09:38 AM   #5
tmontague
 
tmontague's Avatar
 
Drives: 08 Vios M/T, 05 4wd Vibe
Join Date: Oct 2012
Location: Hamilton Ont.
Posts: 1,759
check your electrical silencer which is a connector from your main engine harness that essentially attaches to a rubber block that is molded to a metal bracket that attached to your block.

If that has come disconnected then it could be the source of your issue as that is what it is designed to fix.
__________________
I like to drive a slow car fast...
tmontague is offline   Reply With Quote
Old 07-13-2017, 01:14 PM   #6
danggilmore
 
Drives: 2008 toyota yaris
Join Date: Jun 2017
Location: bay area
Posts: 4
I tried recording a sound but its so faint and high pitched, my phone won't pick it up. The more I drive, the louder it gets. I'll try and get a good recording tmrw.

I tried unplugging my aux cord as its always plugged in and it didn't help anything.

Can you be a little more specific on where to find that electrical silencer on the engine block? Left, right, bottom, top?

Thanks!
danggilmore is offline   Reply With Quote
Old 07-13-2017, 02:03 PM   #7
KCALB SIRAY
それを吸ってください
 
KCALB SIRAY's Avatar
 
Drives: black sand lb
Join Date: Oct 2008
Location: Virginia
Posts: 8,969
Quote:
Originally Posted by ABSPLASTIC View Post
Sounds like a grounding issue. Do you have your radio on or anything plugged into your auxiliary during these times?
Quote:
Originally Posted by danggilmore View Post
I tried recording a sound but its so faint and high pitched, my phone won't pick it up. The more I drive, the louder it gets. I'll try and get a good recording tmrw.

I tried unplugging my aux cord as its always plugged in and it didn't help anything.

Can you be a little more specific on where to find that electrical silencer on the engine block? Left, right, bottom, top?

Thanks!
Question reworded for the OP, do you have an after market stereo installed? If so, is the noise coming from the speakers?
KCALB SIRAY is offline   Reply With Quote
Old 07-13-2017, 02:40 PM   #8
tmontague
 
tmontague's Avatar
 
Drives: 08 Vios M/T, 05 4wd Vibe
Join Date: Oct 2012
Location: Hamilton Ont.
Posts: 1,759
Quote:
Originally Posted by danggilmore View Post
I tried recording a sound but its so faint and high pitched, my phone won't pick it up. The more I drive, the louder it gets. I'll try and get a good recording tmrw.

I tried unplugging my aux cord as its always plugged in and it didn't help anything.

Can you be a little more specific on where to find that electrical silencer on the engine block? Left, right, bottom, top?

Thanks!
Unfortunately I do not remember where it is located on the 1nz engine, I just remember seeing one when I removed the harness to do my engine swap.

On my signature picture of my 2zr engine it is located on the right side of the valve cover and just to the right of the black hose that comes off of the cold air intake. It is like a ground but the metal part from the bracket that mounts onto the engine runs into a rubber dampener and then that goes to a connector to attach it to the engine harness
__________________
I like to drive a slow car fast...
tmontague is offline   Reply With Quote
Old 07-13-2017, 02:50 PM   #9
danggilmore
 
Drives: 2008 toyota yaris
Join Date: Jun 2017
Location: bay area
Posts: 4
Quote:
Originally Posted by KCALB SIRAY View Post
Question reworded for the OP, do you have an after market stereo installed? If so, is the noise coming from the speakers?
Its coming from the engine compartment for sure. I think its something spinning thats causing the sound but can't tell for sure.

No aftermarket stereo. Everything stock on the car.
danggilmore is offline   Reply With Quote
Old 07-13-2017, 05:45 PM   #10
Nu18F
 
Drives: Yaris
Join Date: Feb 2009
Location: USA
Posts: 22
Could be the water pump- look for evidence of coolant.
Nu18F is offline   Reply With Quote
Old 07-13-2017, 06:36 PM   #11
danggilmore
 
Drives: 2008 toyota yaris
Join Date: Jun 2017
Location: bay area
Posts: 4
Thats what i thought it was but i just replaced it! there was a coolant leak but all is well now with a new gasket and pump.
danggilmore is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
YARIS 2005 Rattling sound mik23 DIY / Maintenance / Service 6 05-15-2016 05:34 AM
2007 hatchback making a weird whirring sound robkay DIY / Maintenance / Service 20 03-19-2016 06:53 PM
Sound when making a left turn (a water flow sound) jimmydie DIY / Maintenance / Service 9 06-20-2013 05:35 PM
2008 Yaris sedan ĎSí sound deadening project. Herbicidal In Car Entertainment + Electronics (audio / video / alarm) 155 09-04-2011 11:56 PM
New Sound System - Sound Issues click.mine In Car Entertainment + Electronics (audio / video / alarm) 11 03-20-2009 03:11 AM


All times are GMT -4. The time now is 11:54 AM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.