Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 07-24-2017, 01:18 PM   #1
miiser
 
miiser's Avatar
 
Drives: yaris 2009
Join Date: Nov 2014
Location: greece
Posts: 220
Cluster is saking on 2009 HB

Hey guys,

I Haven't posted something in a while.
Here I am tho, I have a problem with my digital cluster.

I own a 2009 HB, with the cluster in the middle. In the last 2 months it's saking badly when I go on a bump or if the road is not smooth. It's like something is loose or out of its place.

Has-had anyone the same problem??
I can post a video too later to give you a taste


Sent from my iPhone using Tapatalk
miiser is offline   Reply With Quote
Old 07-24-2017, 04:19 PM   #2
B.B._07
 
Drives: 07 5dr
Join Date: Nov 2015
Location: YYC
Posts: 104
The gauge cluster is held on only by two Philips screws so I would suspect that one of the screws is loose or missing. It's very easy to get to the gauge cluster, just pull off the two vertical plastic trim pieces around the radio and then pull the gauge cluster trim up and towards you. The only tool you need is #2 Phillips screwdriver.

Here's a video of a guy removing the three trim pieces (in under 15 seconds).
https://www.youtube.com/watch?v=VyWAXdO_83w
B.B._07 is offline   Reply With Quote
Old 07-24-2017, 04:57 PM   #3
miiser
 
miiser's Avatar
 
Drives: yaris 2009
Join Date: Nov 2014
Location: greece
Posts: 220
Cluster is saking on 2009 HB

Quote:
Originally Posted by B.B._07 View Post
The gauge cluster is held on only by two Philips screws so I would suspect that one of the screws is loose or missing. It's very easy to get to the gauge cluster, just pull off the two vertical plastic trim pieces around the radio and then pull the gauge cluster trim up and towards you. The only tool you need is #2 Phillips screwdriver.



Here's a video of a guy removing the three trim pieces (in under 15 seconds).

https://www.youtube.com/watch?v=VyWAXdO_83w


Thanks mate I will check it out.
It's weird tho, because it doesn't seem that the screw is loose or missing. In normal roads, it's in place. But in the bumps it's saking up and down. Not left and right


Sent from my iPhone using Tapatalk
miiser is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: 2009 OEM tachometer gauge cluster mrbond Items for Sale by private party 8 05-24-2013 12:00 AM


All times are GMT -4. The time now is 11:53 AM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.