Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 07-17-2017, 06:31 AM   #1
GuySmily
 
GuySmily's Avatar
 
Drives: 2005 Toyota MR2
Join Date: May 2006
Location: Sacramento, CA, USA
Posts: 158
Loud whine from engine around idle speed

I've never heard a car make a sound like this. Car drives fine, but I have no idea what the sound is and don't want to risk damaging something. Any ideas/suggestions?

https://youtu.be/o7spt25irSY

Edit- now that the engine has cooled down the noise is much quieter and I can tell the sound is coming from a pulley or something near the accessory drive belt. Going to try driving some more and will be extra careful.

Last edited by GuySmily; 07-17-2017 at 07:04 AM.
GuySmily is offline   Reply With Quote
Old 07-17-2017, 10:05 AM   #2
tmontague
 
tmontague's Avatar
 
Drives: 08 Vios M/T, 05 4wd Vibe
Join Date: Oct 2012
Location: Hamilton Ont.
Posts: 1,759
Either your belt is slipping or your alternator is starting to go. Belt will be a loud squeal whereas the alternator sounds like a quiet supercharger and usually will have an electrical smell to it
__________________
I like to drive a slow car fast...
tmontague is offline   Reply With Quote
Old 07-17-2017, 01:53 PM   #3
Rigaud
 
Drives: 2009 Yaris
Join Date: Jan 2014
Location: Rigaud, Quebec, Can.
Posts: 353
Quote:
Originally Posted by tmontague View Post
Either your belt is slipping or your alternator is starting to go. Belt will be a loud squeal whereas the alternator sounds like a quiet supercharger and usually will have an electrical smell to it
Your right about being the alternator but it`s not electrical. Most likely the bearings are shot.
__________________


2009 Toyota Yaris (Little toy)
2002 Audi A4 Avant Quattro 3.0L (Big boy toy)
1998 Subaru Legacy GT 2.5 (winter & DD)
Rigaud is offline   Reply With Quote
Old 07-17-2017, 02:34 PM   #4
tmontague
 
tmontague's Avatar
 
Drives: 08 Vios M/T, 05 4wd Vibe
Join Date: Oct 2012
Location: Hamilton Ont.
Posts: 1,759
Just realized there was a video link attached. Ya, definitely bearings likely from the alt. A bad alt won't sound nearly that loud if it's the internals going and not the bearing
__________________
I like to drive a slow car fast...
tmontague is offline   Reply With Quote
Old 07-17-2017, 06:18 PM   #5
GuySmily
 
GuySmily's Avatar
 
Drives: 2005 Toyota MR2
Join Date: May 2006
Location: Sacramento, CA, USA
Posts: 158
Thanks guys. Hopefully it can go a couple hundred miles like this so I can get home. Don't have any big tools on me so I can't do any further troubleshooting myself.
GuySmily is offline   Reply With Quote
Old 07-20-2017, 07:47 PM   #6
GuySmily
 
GuySmily's Avatar
 
Drives: 2005 Toyota MR2
Join Date: May 2006
Location: Sacramento, CA, USA
Posts: 158
Bad news. It's the AC compressor pulley bearing. A mechanic without even looking at it said that's what it probably was and quoted us $1600 or something like that.

Surely there's a way to replace the bearing.. Any input?

Edit- guess I gotta do this:
http://www.yarisworld.com/forums/showthread.php?t=46975

Last edited by GuySmily; 07-20-2017 at 08:04 PM.
GuySmily is offline   Reply With Quote
Old 07-20-2017, 09:22 PM   #7
tmontague
 
tmontague's Avatar
 
Drives: 08 Vios M/T, 05 4wd Vibe
Join Date: Oct 2012
Location: Hamilton Ont.
Posts: 1,759
What it "probably was" or what it is? Use a long screwdrive as a stethoscope to determine the exact auxiliary unit causing the issue.

If is is the compressor then either get a recycled oem one from the local recycler or buy a reman'd unit off eBay and do it your self. Just pay a garage to discharge and full up the refridgerant for you
__________________
I like to drive a slow car fast...
tmontague is offline   Reply With Quote
Old 07-22-2017, 05:38 PM   #8
GuySmily
 
GuySmily's Avatar
 
Drives: 2005 Toyota MR2
Join Date: May 2006
Location: Sacramento, CA, USA
Posts: 158
Heh, sorry, should have been more clear.

While I was out of town / where the problem happened, that mechanic guessed at the problem without even looking at the car.

Now that I'm home, I pulled the belt off and found he was right. So I installed a shorter belt to bypass the AC compressor for now (Dayco 5040362 from AutoZone). No more noise!

I'm hoping it will be more cost effective to swap out the bearing than to discharge/recharge the AC. I need to go to socal this weekend, so I'm going to grab part # 35BX5212-DDST2NB from bearingsdirect.com in Glendale, CA and see if my mechanic has time to do the install. I'll let you guys know if it works out.
GuySmily is offline   Reply With Quote
Old 07-22-2017, 06:04 PM   #9
SirDigby
 
Drives: 2007 yaris 3 door
Join Date: Sep 2015
Location: Denver, Colorado
Posts: 791
you will have to recover the r134a out of the system before removing the compressor to replace bearing. then you will have to charge it back up.
SirDigby is offline   Reply With Quote
Old 07-23-2017, 04:10 PM   #10
Kaotic Lazagna
 
Kaotic Lazagna's Avatar
 
Drives: '14 GT86, '08 Vitz
Join Date: Dec 2006
Location: Bay Area, CA
Posts: 9,581
Yo Rusty, what's up? When did you get a Yaris? Thought you had a first gen Insight?
Kaotic Lazagna is offline   Reply With Quote
Old 07-27-2017, 07:28 PM   #11
GuySmily
 
GuySmily's Avatar
 
Drives: 2005 Toyota MR2
Join Date: May 2006
Location: Sacramento, CA, USA
Posts: 158
Quote:
Originally Posted by SirDigby View Post
you will have to recover the r134a out of the system before removing the compressor to replace bearing. then you will have to charge it back up.
Yeah that's what ended up happening. We trashed the pulley bolt trying to get it off and rather than trying to drill it out and all that we just replaced the whole compressor.

So, sorry I can't report on how the bearing works, but the owner over at bearings direct was super friendly. Bearing was twenty-something bucks. I still have mine in the package. Guess I'll throw it on eBay.

Quote:
Originally Posted by Kaotic Lazagna View Post
Yo Rusty, what's up? When did you get a Yaris? Thought you had a first gen Insight?
Hey Laz! This is actually my sister's car. Her pulley went while we were on our way to her place in Santa Cruz.

Actually my Insight was with my mechanic in socal so Annie and I took the Yaris down there to get it fixed and to pick my car up.

But yeah I'm still driving both the insight and mr2. I also bought an electric smart too, but my mom's driving it now. That smart car is than the mr2 lol. Tbh I think I can confidently say that I'm never buying a gasoline car ever again.
GuySmily is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Japanese engine into French Yaris 1.0 2002 Jamie101 DIY / Maintenance / Service 3 05-21-2017 08:31 PM
The Nitrous Thread ChinoCharles Performance Modifications 116 02-16-2016 04:07 PM
DIY: Intake Installation redyaris DIY / Maintenance / Service 53 08-23-2014 05:34 AM
Engine brake with cold engine and high rotation speed josellwoll General Yaris / Vitz Discussion 3 11-06-2012 07:52 PM
Yaris engine loud..? buccaneer64 New YARIS Purchase Forum 33 01-25-2009 01:45 PM


All times are GMT -4. The time now is 11:55 AM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.