Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 05-12-2009, 02:32 PM   #19
Creeper
 
Creeper's Avatar
 
Drives: Silver 2DLB Yaris
Join Date: May 2007
Location: Georgia
Posts: 155
Send a message via AIM to Creeper
Ill try and clarify alittle more. Fogs are going to ground and pin 1. switch is wired up just like tk's picture with ground going to ground spot on kicker panel. it is a base 2007 (maybe the problem?) the switch lights up and turns off like its supposed to. relay clicks. but the fogs dont light up. also i had to cut the connector on the wire to pin 1. as it was the wrong ytype of connector. would the fact that the wire is kinda pushed in there effect it? im gonna try and get the right end peice before i head to work.
Creeper is offline   Reply With Quote
Old 05-12-2009, 02:57 PM   #20
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
Quote:
Originally Posted by Creeper View Post
Ill try and clarify alittle more. Fogs are going to ground and pin 1. switch is wired up just like tk's picture with ground going to ground spot on kicker panel. it is a base 2007 (maybe the problem?) the switch lights up and turns off like its supposed to. relay clicks. but the fogs dont light up. also i had to cut the connector on the wire to pin 1. as it was the wrong ytype of connector. would the fact that the wire is kinda pushed in there effect it? im gonna try and get the right end peice before i head to work.
Make sure you have a good connection on Pin 1 before trying to turn the fogs on, as they draw a decent amount of current.

TK's picture is just showing the connection for the switch lighting wires. You still have to make the connections to the headlight stalk connector.
CTScott is offline   Reply With Quote
Old 05-12-2009, 03:52 PM   #21
Creeper
 
Creeper's Avatar
 
Drives: Silver 2DLB Yaris
Join Date: May 2007
Location: Georgia
Posts: 155
Send a message via AIM to Creeper
ok so i have to make the stalk connections even if i dont want the dash to light up with the symbols? what wires do i use for thouse i only have the ground pink and white on the switches and they go to the relay i don hae he 2 wires like the one in this kit. also would it be easier to just run he fogs through and connect them through the switch? im just at a loss seems like everyone has more wires on their kits then i do
Creeper is offline   Reply With Quote
Old 05-12-2009, 04:01 PM   #22
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
If you came through the firewall via the existing wiring (that goes from pin 1 to the relay slot in the interior fuse panel) then you have to make the connection at the stalk connector. Did you add the Toyota relay to the inside panel, or are you trying to use the relay that came with your kit?

There are two primary ways of wiring the aftermarket fogs:

1. Use the existing wiring to come through the firewall, and add the Toyota relay. With the aftermarket kits, this requires modifying their harness and eliminating the included relay.

2. Come through the firewall with the aftermarket harness and connect switch per aftermarket directions, using included relay.
CTScott is offline   Reply With Quote
Old 05-12-2009, 05:39 PM   #23
Creeper
 
Creeper's Avatar
 
Drives: Silver 2DLB Yaris
Join Date: May 2007
Location: Georgia
Posts: 155
Send a message via AIM to Creeper
ok so to use the kit relay i need to run the wire from the lights to the relay right?
Creeper is offline   Reply With Quote
Old 05-12-2009, 08:00 PM   #24
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
Quote:
Originally Posted by Creeper View Post
ok so to use the kit relay i need to run the wire from the lights to the relay right?
Yes. Also, with the kit relay you will need to supply a power circuit. The aftermarket kit, I saw instructions for, required you to come directly off the positive battery terminal with to a fuse, then to the fog kit. That's what makes connecting via the OEM wiring much cleaner.

You can pick up a used Toyota relay off ebay for just over $10, including shipping:

http://cgi.ebay.com/ebaymotors/ws/eB...3AIT&viewitem=
CTScott is offline   Reply With Quote
Old 05-12-2009, 10:21 PM   #25
Creeper
 
Creeper's Avatar
 
Drives: Silver 2DLB Yaris
Join Date: May 2007
Location: Georgia
Posts: 155
Send a message via AIM to Creeper
guess im going to have to get the stalk and toyota relay, got the lights working for an hour untill the switch burnt out. oh well
Creeper is offline   Reply With Quote
Old 07-06-2009, 07:30 PM   #26
Pikachu
 
Drives: 2009 Yellow Jolt Yaris 3 door
Join Date: Mar 2009
Location: Rochester N.Y.
Posts: 7
So do I have this right?

This is how I interpret the way the modified install kit works. Please tell me if I got it right:

1) I install the Toyota factory Fog Light relay in the D46 slot on the top right of the Relay block, and a 15 amp fuse in position 12.

2) I disassemble the wiring harness and wire one side of the switch to D4 pin 3 (Yellow wire into the Headlight switch connector)

3) I wire the other side of the switch to D4 pin 4 (Orange wire). This takes the place of the fancy headlight switch and grounds the coil side of the relay through the dimmer switch.

4) I wire the illumination from the switch to the green wire in the console (Instrument lights).

5) I attach the hot wire from the fog lights to either pin 1 or 2 of B13 in the engine room fuse box.

6) I connect the ground wires from the switch harness and the Foglight harness to ground.

6) Did I miss anything?
Pikachu is offline   Reply With Quote
Old 07-06-2009, 09:05 PM   #27
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
Quote:
Originally Posted by Pikachu View Post
This is how I interpret the way the modified install kit works. Please tell me if I got it right:

1) I install the Toyota factory Fog Light relay in the D46 slot on the top right of the Relay block, and a 15 amp fuse in position 12.

2) I disassemble the wiring harness and wire one side of the switch to D4 pin 3 (Yellow wire into the Headlight switch connector)

3) I wire the other side of the switch to D4 pin 4 (Orange wire). This takes the place of the fancy headlight switch and grounds the coil side of the relay through the dimmer switch.

4) I wire the illumination from the switch to the green wire in the console (Instrument lights).

5) I attach the hot wire from the fog lights to either pin 1 or 2 of B13 in the engine room fuse box.

6) I connect the ground wires from the switch harness and the Foglight harness to ground.

6) Did I miss anything?


That's correct and all of it.

I installed a set on my 09 as above, except I didn't like the included switch or the console location for it, so I installed an LED lighted rocker switch next to the dimmer rheostat. I grabbed the illumination feed right off of the rheostat output (Brown wire in Pin 5 is +, Green wire in pin 2 is -).
CTScott is offline   Reply With Quote
Old 07-06-2009, 10:40 PM   #28
Pikachu
 
Drives: 2009 Yellow Jolt Yaris 3 door
Join Date: Mar 2009
Location: Rochester N.Y.
Posts: 7
Quote:
Originally Posted by CTScott View Post
That's correct and all of it.

I installed a set on my 09 as above, except I didn't like the included switch or the console location for it, so I installed an LED lighted rocker switch next to the dimmer rheostat. I grabbed the illumination feed right off of the rheostat output (Brown wire in Pin 5 is +, Green wire in pin 2 is -).
Thanks for the feedback. I ordered a relay and 09 bezels. (I hand carved the old ones but am not happy with the results. It isn't easy to carve a good elipse.) I will let you know how it comes out.
Pikachu is offline   Reply With Quote
Old 09-03-2009, 01:17 PM   #29
CaysE
That Focus Guy
 
CaysE's Avatar
 
Drives: 2004 Focus RSVT
Join Date: Jul 2007
Location: USA
Posts: 51
Thank you for reposting this!! I haven't been on here in a while and I must've spent two days looking for this thread.
CaysE is offline   Reply With Quote
Old 02-09-2010, 12:52 AM   #30
bairjo
 

Join Date: Feb 2010
Posts: 558
1234

Last edited by bairjo; 02-15-2011 at 08:51 AM.
bairjo is offline   Reply With Quote
Old 02-09-2010, 09:55 AM   #31
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
Quote:
Originally Posted by bairjo View Post
Does anyone have the manufacturer and part number for a new switch. The one that came with my kit works but only has one bulb and does not illuminate when not turned on.
Are you sure that it only has one indicator (that is, did you pop it open and only see one bulb)? The reason I ask is that depending on how you wire the switch, can determine if both lights work/work correctly.
CTScott is offline   Reply With Quote
Old 02-09-2010, 01:41 PM   #32
bairjo
 

Join Date: Feb 2010
Posts: 558
1234

Last edited by bairjo; 02-15-2011 at 08:52 AM.
bairjo is offline   Reply With Quote
Old 02-09-2010, 03:08 PM   #33
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
Quote:
Originally Posted by bairjo View Post
Yes, I opened the switch and only one bulb is there.
OK. I am not sure about part numbers for aftermarket fog light switches, but you may have to make some wiring changes to support a two light switch. When I installed my MicroImage fogs, I used the OEM wiring method and then installed my own lighted switch:

CTScott is offline   Reply With Quote
Old 02-14-2010, 04:46 AM   #34
bairjo
 

Join Date: Feb 2010
Posts: 558
1234

Last edited by bairjo; 02-15-2011 at 08:55 AM.
bairjo is offline   Reply With Quote
Old 05-01-2010, 07:37 PM   #35
joeljcruz86
Little Eggy
 
joeljcruz86's Avatar
 
Drives: Toyota Yaris Liftback 3DR 2009
Join Date: Apr 2010
Location: North Plainfield, NJ
Posts: 31
Send a message via AIM to joeljcruz86 Send a message via Skype™ to joeljcruz86
Hey Goku87, I bought the same kit that you did. Only one problem, the Fog Light doesn't light up in my guage cluster. Everything works except the Fog lights will only work if the head lights are on. The way I have it hooked up basically i have the red wire from the fog light harness connected to the red wire from the switch harness. Then I have the green wire from the switch itself tapped into the factory wire harness by the shifter like you did. Then I have the last remaining wire which is the blue/yellowish wire from the relay tapped into the cigarette lighter. Now the "pin connector" plug under my steering wheel is a little different. The Yellow wire is yellow, but the white wire in your picture, it is brown for mine. I don't have any wires tapped into those. So can you or anybody help me to get the Fog Light to light up in my guage cluster??

PS. I drive a 2009 Liftback 3DR

Last edited by joeljcruz86; 05-01-2010 at 07:38 PM. Reason: forgot to put something
joeljcruz86 is offline   Reply With Quote
Old 05-01-2010, 08:48 PM   #36
1NZYaris1
 
1NZYaris1's Avatar
 
Drives: Yaris
Join Date: Oct 2008
Location: New Zealand
Posts: 2,598
you cant tap into the cluster , if you are not running a relay in the
factory relay postion , or running the fog lights through the factory wiring that
is installed in all Yaris's .
1NZYaris1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fog light install 07yaris_fe Cosmetic Modifications (Exterior/Interior) 10 07-20-2010 01:18 PM
Looking for the Toyota Fog Light install RocknRollRon DIY / Maintenance / Service 33 06-13-2010 06:46 PM
DIY:Day time running light Disabled with stock fog light remain function summergxz DIY / Maintenance / Service 12 09-26-2007 10:42 AM
Before I start calling around: fog light install prices St_G Cosmetic Modifications (Exterior/Interior) 4 03-17-2007 09:45 AM
Finally installed oem ebay fog light for hatchback Adriaan General Yaris / Vitz Discussion 6 12-27-2006 05:24 PM


All times are GMT -4. The time now is 02:11 AM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.