Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 11-03-2016, 01:49 AM   #1
Bajan_Yarisman
I've made a post!
 
Drives: 2005 Belta
Join Date: Jun 2013
Location: Barbados
Posts: 1
Thumbs down Check Engine Light disabled by previous owner, need help to re-enable it.

About 3 years ago I purchased a JDM 11/2005 Belta with a 2SZ-FE engine.

I recently noticed that my Check Engine Light has never lit up even when I have experienced problems, under any condition.

When the car is started, all the other status lights turn on except the CEL.

Furthermore, I recently had diagnostic check done, and 3 codes where pulled which should have caused the light to appear, P1605, P1589 & P0717. It never did.

I took the car to an auto electrician and he was unable to find the cause of the issue but suggested that the CEL bulb was physically removed or disabled in some way by the previous owner.

I removed the instrument cluster (its an XP03) and checked it, however the particular cluster uses LED which is soldered to the circuit and it is physically still there.

Does anyone have any ideas what this could be? How do I get the CEL working again?
Could this be solved by me replacing the instrument cluster?
Bajan_Yarisman is offline   Reply With Quote
Old 11-03-2016, 11:12 PM   #2
CoryM
 
Drives: 2009 5-door, 5-speed
Join Date: Sep 2011
Location: White Rock BC
Posts: 632
Start by checking all your fuses. Assuming your car is the same as my diagram (07 Yaris), the MIL runs off the "7.5A MET" fuse. After that it's time to check the ground wire between the meter and the ECM. Black wire, pin 4 at meter. Pin 24 at ECM.

You'll want to double-check your car's wiring diagram to make sure it's the same but he has likely cut the ground wire.

Cheers.
CoryM is offline   Reply With Quote
Old 11-03-2016, 11:16 PM   #3
SirDigby
 
Drives: 2007 yaris 3 door
Join Date: Sep 2015
Location: Denver, Colorado
Posts: 663
you can use a volt meter to check the continuity through the LED. they do burn out sometimes. then check continuity on wiring harness. then from fuse to battery power source.
SirDigby is offline   Reply With Quote
Reply

Tags
cel, check engine light

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine light on after Water Pump change gumby002 DIY / Maintenance / Service 3 03-19-2014 09:06 AM
help..check engine again dindy DIY / Maintenance / Service 12 12-13-2012 07:17 PM
check engine light, engine turns but not start willygoodness DIY / Maintenance / Service 10 07-23-2012 05:10 PM
Check engine light Geelmeel DIY / Maintenance / Service 7 11-29-2009 12:32 AM
Check engine light flashes during high reving AlphaFox DIY / Maintenance / Service 40 08-21-2007 01:43 PM


All times are GMT -4. The time now is 09:44 PM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.