Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 10-30-2019, 08:31 AM   #1
Cartel
 
Cartel's Avatar
 
Drives: 2007 Yaris Hatch
Join Date: Mar 2017
Location: Chilliwack, BC
Posts: 43
Exclamation 2007 Yaris Charge voltage too low, tried everything

My alternator has been giving me trouble and has a low charge voltage.
I took it apart and cleaned the regulator, checked the brushes and cleaned up the commutator and it all looks good (60,000KM).

The problem is it only charges at 13.6v-13.8v with nothing on while another identical car charges at 14.2v-14.4v.
I checked for voltage drop at full load (130mv) positive and negative (0.001mv) and AC (0mv)
I think my audio amp may have hurt it somehow. (guessing)

I am looking for a heavy duty alternator if possible or I guess I'm going to replace the regulator and see if that helps.
Could the ECM be damaged somehow?

I can find my alternator (27060-21150):



But I also see one with a bigger heat-sink on the regulator and a bigger body too:



Is there a better version?
These both say 80 amps but 1 looks much beefier.

My audio amplifier only uses 40 amps.

Thanks

Last edited by Cartel; 10-31-2019 at 06:18 PM.
Cartel is offline   Reply With Quote
Old 10-30-2019, 11:07 AM   #2
Toolaholic
 
Drives: Olive yaris,FRS, Dakota R/T
Join Date: Aug 2013
Location: Pa
Posts: 147
I had chestnut hill electric in Denver pa rebuild mine for $108. New bearing , voltage regulator and brushes.
Toolaholic is offline   Reply With Quote
Old 10-30-2019, 01:00 PM   #3
Cartel
 
Cartel's Avatar
 
Drives: 2007 Yaris Hatch
Join Date: Mar 2017
Location: Chilliwack, BC
Posts: 43
I took mine to the shop and they tested it, it 80+ amps at 13.5 they said no problem.
Its just that the ECM is throttling the voltage back or something.
Maybe someones run into this before?
Cartel is offline   Reply With Quote
Old 10-31-2019, 06:17 PM   #4
Cartel
 
Cartel's Avatar
 
Drives: 2007 Yaris Hatch
Join Date: Mar 2017
Location: Chilliwack, BC
Posts: 43
I notice the idle doesn't go up when I put the heater fan on.
Maybe the sense chip in the regulator is dead?
The A/C amplifier toast?

Anyone seen this issue?
Cartel is offline   Reply With Quote
Old 11-03-2019, 09:04 AM   #5
06YarisRS
 
Drives: 2006 Yaris RS
Join Date: Aug 2017
Location: Beaver Harbour, New Brunswick, Canada
Posts: 1,665
The internal voltage regulator is a common failure point as the contacts corrode due to water ingress. One of my Yari runs at ~ 13.8 - 13.9 and the other ~14.2 - 14.4. Both have passed voltage drop tests and neither have any driveability or starting problems. I too looked at an upgraded alternator as I was adding some additional electronics (stereo with amp 75w x 4 and NVX 8" powered sub etc), but the stock 80 amp alternator has proved more than capable of handling the power demands. I think the upgraded alternator I was looking at was 120A. Since your alternator tested good and you don't have a flickering or steady battery light on in the instrument cluster, you're probably fine. Then again, if you drive your amp hard, an upgrade might be a good option.

Here is an upgraded 145 amp alternator for 06 - 14:

https://www.ebay.com/itm/High-Output...cAAOSwI4xa4l9L
__________________


2006 Yaris 5 Door RS 2ZR-FE (2011 Corolla 1.8L) Swapped, Automatic, T-28 Turbocharged (8 psi), custom 3" cold air intake, custom 2.5" exhaust, TRD rear sway bar, Penguin Garage 13mm spacers (rear), custom Civic front lip, full repaint, Android 6.0 7" touchscreen, Rockford Fosgate speakers, tweeters, NVX underseat subwoofer https://www.youtube.com/watch?v=5Edvs_TSGkY
2008 Yaris LE H&R 10mm spacers (rear), RS rear spoiler
06YarisRS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY Cruise Control FAQ (2006-2010 Yaris) CTScott DIY / Maintenance / Service 461 09-26-2019 01:47 AM
YARIS FAQ (frequently asked questions) PK198105 General Yaris / Vitz Discussion 98 11-29-2018 11:46 PM
Natural Gas Yaris MadMax General Yaris / Vitz Discussion 13 06-03-2017 06:10 AM
Vacationed in Italy - Brought home a D4D diesel Yaris CTScott Photo-Video-Media Gallery 19 07-26-2012 03:13 AM
NEWS: TOYOTA REVEALS ALL-NEW YARIS SEDAN AT 2006 LOS ANGELES AUTO SHOW VitzBoy General Yaris / Vitz Discussion 5 09-05-2010 08:53 PM


All times are GMT -4. The time now is 04:27 AM.




YarisWorld
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.