Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 08-04-2019, 11:16 AM   #1
Toolaholic
 
Drives: Olive yaris,FRS, Dakota R/T
Join Date: Aug 2013
Location: Pa
Posts: 96
Intermittent misfire cyl 1 07 Yaris 1.5 sedan

Hi all, I have replaced plugs ,coils, pvc valve, O2 sensor MAF sensor plus Techron fuel cleaner. Sprayed intake with carb cleaner no change in idle. It’s intermittent. Daughter drove it 50 miles and I got a a misfire reading of 334. And yes I know it’s a algorithm. I replaced plug and swapped a coil in. I drove it hard 3 times and got 69,77 and wait for it 1. I will post pics of changing a plug out in another thread.
Toolaholic is offline   Reply With Quote
Old 08-04-2019, 12:22 PM   #2
Toolaholic
 
Drives: Olive yaris,FRS, Dakota R/T
Join Date: Aug 2013
Location: Pa
Posts: 96
It idles smooth with air off. So smooth the steering wheel doesn’t vibrate at all .
Toolaholic is offline   Reply With Quote
Old 08-04-2019, 07:15 PM   #3
Toolaholic
 
Drives: Olive yaris,FRS, Dakota R/T
Join Date: Aug 2013
Location: Pa
Posts: 96
Daughter got back after 50 mile trip home. Cylinder 1 had reading of 1. I got it to 100 twice to get to the 6,000 rpm full throttle shift from 2nd to 3rd. Reading was 2 on cylinder 1. Now at some time later in the week she’ll come home and it will read 80 or something high like that. Unless the Techron works and it’s fixed. Makes no sense sometimes you flog it and get a 1. Sometimes a 69 or 77. It can take being run hard every now and again . Mobil 1 5w30 and amsoil in transmission plus cooling system serviced twice. Well taken care of.
Toolaholic is offline   Reply With Quote
Old 08-05-2019, 07:51 AM   #4
Toolaholic
 
Drives: Olive yaris,FRS, Dakota R/T
Join Date: Aug 2013
Location: Pa
Posts: 96
She taking it on a 100 mile trip to the beach then 100 back . Fingers crossed. Hoping the Techron fixed it and it was a plugged injector.
Toolaholic is offline   Reply With Quote
Old 08-11-2019, 09:50 AM   #5
Toolaholic
 
Drives: Olive yaris,FRS, Dakota R/T
Join Date: Aug 2013
Location: Pa
Posts: 96
It’s at martins auto center. They do outstanding work. Replaced intake manifold gasket. Still no improvement. It drives great for 20 minutes then misfires and flashes engine light on clylinder 1. Pull over for 5-10 minted and it runs great again for 20 minutes
Toolaholic is offline   Reply With Quote
Old 08-12-2019, 02:57 PM   #6
Toolaholic
 
Drives: Olive yaris,FRS, Dakota R/T
Join Date: Aug 2013
Location: Pa
Posts: 96
Garage called fuel injector
Toolaholic is offline   Reply With Quote
Old 08-12-2019, 03:37 PM   #7
Brighton
Knower of little
 
Drives: 07 Yaris Hatch
Join Date: Jul 2019
Location: NOVA
Posts: 18
If it's fuel injectors, you could try BG44K cleaner, if it's a matter of them being clogged/sticky that will help.
Brighton is offline   Reply With Quote
Old 08-12-2019, 08:19 PM   #8
Toolaholic
 
Drives: Olive yaris,FRS, Dakota R/T
Join Date: Aug 2013
Location: Pa
Posts: 96
Quote:
Originally Posted by Brighton View Post
If it's fuel injectors, you could try BG44K cleaner, if it's a matter of them being clogged/sticky that will help.
used Techron 3 times. It runs awesome for 30 minutes at a time then misfires heavily . Runs great again after 5 minute break. They tested injector said it tested bad. I’m assuming with a multi meter. I should of tested it but assumed it ran too good to be injector . I thought it was electrical problem somewhere. $350 labor / parts . I could of did it myself but it was $100 to diagnose it. So $250 more to fix. Oh well I put everything else on.
Toolaholic is offline   Reply With Quote
Old 08-12-2019, 10:02 PM   #9
Brighton
Knower of little
 
Drives: 07 Yaris Hatch
Join Date: Jul 2019
Location: NOVA
Posts: 18
Sometimes it's worth it to just get a fresh set of eyes on a problem. I'd see if you could swap the injector to another location and see if the misfire CEL changes cylinders.
Brighton is offline   Reply With Quote
Old 08-15-2019, 03:32 PM   #10
thebarber
daily driver
 
thebarber's Avatar
 
Drives: the #wrecho
Join Date: Jun 2006
Location: Grand Rapids, MI
Posts: 5,858
swap the injectors between cyl 1 and 2 and coil from 1 to 3 and see if the issue moves.
__________________
thebarber is offline   Reply With Quote
Old 08-15-2019, 09:47 PM   #11
Toolaholic
 
Drives: Olive yaris,FRS, Dakota R/T
Join Date: Aug 2013
Location: Pa
Posts: 96
$284. $144 labor and $124.95 for injector. It was the injector on cylinder 1. Got a denso injector for $45 (eBay) and a fel pro cylinder head cover gasket set for $9 ( amazon) to have in hand should this happen again.
Toolaholic is offline   Reply With Quote
Old 08-16-2019, 11:55 AM   #12
thebarber
daily driver
 
thebarber's Avatar
 
Drives: the #wrecho
Join Date: Jun 2006
Location: Grand Rapids, MI
Posts: 5,858
Glad you found the issue
__________________
thebarber is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
06-10 Yaris Sedan cold air intake $40 kylevh21 Items for Sale by private party 2 04-01-2012 02:14 PM
Consumer Reports Is On Crack!!! doublewam General Yaris / Vitz Discussion 83 05-07-2011 11:03 AM
NEWS: TOYOTA REVEALS ALL-NEW YARIS SEDAN AT 2006 LOS ANGELES AUTO SHOW VitzBoy General Yaris / Vitz Discussion 5 09-05-2010 08:53 PM
2007 Yaris Pricing Info ! YarisBueller New YARIS Purchase Forum 104 06-24-2009 04:54 PM
yaris Advance Sedan Rudeshady Central and South America 14 06-25-2007 01:50 AM


All times are GMT -4. The time now is 09:51 AM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.