Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 08-12-2019, 09:20 AM   #1
kenora
 
Drives: 2009 Yaris LE 5 dr
Join Date: Feb 2009
Location: Winnipeg. Canada
Posts: 38
09 yaris hatch has gone nuts

09 hatch le 4 dr auto 1.5 l ....I was on the highway yesterday when the car started hesitating.. I could feel it miss every few seconds..then it got bad enuff the cruise would kick off.. then the engine would actually shit off for a second and restart causing a major thump. It was as if the key was being turned off..on..since the dash would go black for a moment then illuminate again...
I had to drive in 3 instead of d due to the transmission constantly shifting to neutral and the rpms flaring to 5000 or more.. I slowed to 80 kph.
I limped to a family memebrts place and shut it down for the night.. this morning there was no response from the key..just a hard click from a solenoid under the hood.. I thought the battery was dead..its newish...
The electric locks would not work I had to use the key to lock it and the doors last nite
I opened the hatch this morning and suddenly it tries to start..the starter was engaged and turning the engine e over...the car wouldn't start but it turned over fora coupe of minutes while I tried to stop it...I put the key in the ignition and turned it to every position but no luck it kept turning over..then I tried to shift to drive and it stopped.
Open the hatch and it does it again..
It's getting towed to Toyota but really WTF?

Sent from my SM-G950W using Tapatalk
kenora is offline   Reply With Quote
Old 08-12-2019, 11:05 AM   #2
Brighton
Knower of little
 
Drives: 07 Yaris Hatch
Join Date: Jul 2019
Location: NOVA
Posts: 17
It's really hard to say without being there in person to do some simple diagnostics. But when I've had cars do a random assortment of stuff similar to what you describe, it ended up being the ECU failing. I don't know if this is a common issue with Yaris' but I'd do some simple stuff, check air, fuel, charging system etc to try and narrow it down first. IF it's the ECU, I'd try to find a used factory unit in ebay or from a junkyard. In my experience, the aftermarket/refurb ECUs don't run/work exactly like factory.
Brighton is offline   Reply With Quote
Old 08-12-2019, 12:00 PM   #3
kenora
 
Drives: 2009 Yaris LE 5 dr
Join Date: Feb 2009
Location: Winnipeg. Canada
Posts: 38
My thought went to the ecu as well.. I hope not they are crazy expensive

Sent from my SM-G950W using Tapatalk
kenora is offline   Reply With Quote
Old 08-12-2019, 01:01 PM   #4
Brighton
Knower of little
 
Drives: 07 Yaris Hatch
Join Date: Jul 2019
Location: NOVA
Posts: 17
I just did a quick browse around ebay, they all seem to be <$120 so not bad, but definitely find the exact model of your existing one and confirm it's identical to the one you find to replace it. There are tons of minute differences. This is ALL assuming the ECU is even bad, this could be as simple as bad grounds.
Brighton is offline   Reply With Quote
Old 08-12-2019, 04:51 PM   #5
kenora
 
Drives: 2009 Yaris LE 5 dr
Join Date: Feb 2009
Location: Winnipeg. Canada
Posts: 38
its fixed...

turns out the (after market) remote start ground wire had corroded a bit and was intermittent causing the ecu to go nuts..the installer (about 7 years ago)...used the same master ground as the main fuse from the box under the hood but it was loose and rusty...caused all sorts of high resistance/heat/nastiness

the ecu seems fine and the cruise control module removed... the ground was burned as was a solenoid..they were replaced and the ground cleaned up....thanks Birchwood Toyota
just an fyi for others...
kenora is offline   Reply With Quote
Old 08-13-2019, 03:07 PM   #6
kenora
 
Drives: 2009 Yaris LE 5 dr
Join Date: Feb 2009
Location: Winnipeg. Canada
Posts: 38
Opps not the cruise control
.it was the remote start.. cruise is ok

Sent from my SM-G950W using Tapatalk
kenora is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: A few things on my 07 Yaris Hatch NE njiteb Items for Sale by private party 11 05-09-2014 06:57 PM
Getting ready to buy a 2007 Yaris hatch Type456 New YARIS Purchase Forum 26 02-17-2014 12:48 AM
NEWS: TOYOTA REVEALS ALL-NEW YARIS SEDAN AT 2006 LOS ANGELES AUTO SHOW VitzBoy General Yaris / Vitz Discussion 5 09-05-2010 08:53 PM
2008/2009 yaris hatch. Looks different? Twistoffate0817 General Yaris / Vitz Discussion 15 01-20-2009 01:04 AM
Yaris Sedan Vs. Yaris 4dr. hatch Meow General Yaris / Vitz Discussion 11 10-29-2006 03:11 PM


All times are GMT -4. The time now is 01:33 AM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.