Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 08-23-2018, 03:31 PM   #1
vaironl
 
vaironl's Avatar
 
Drives: 2010 Yaris 3 door, manual tran
Join Date: Jul 2013
Location: --
Posts: 193
ABS & Traction Control Lights On After Raising Car

I recently went back to stock suspension (both shocks and springs) as I might be selling my Yaris in the near future.

After having a friend help me out, both the ABS and traction control lights turned on. Which I do not recall happening when I lowered it. We drove for about 10-15 miles and then disconnected the battery for about 20-30 minutes and after reconnecting it the lights were still on.

My friend told me clearing the codes with an OBD2 might be the best solution, but I am not sure if that applies in this situation and if I should do that after aligning the car again.

What do you all recommend?
vaironl is offline   Reply With Quote
Old 08-23-2018, 09:37 PM   #2
CoryM
 
Drives: 2009 5-door, 5-speed
Join Date: Sep 2011
Location: White Rock BC
Posts: 674
Likely one of two things:
-broken/unplugged wheel speed sensor or wire
-steering wheel is so far off the T/C doesn't know what to do.

Scan it, see what codes and go from there.
CoryM is offline   Reply With Quote
Old 08-24-2018, 03:23 AM   #3
vaironl
 
vaironl's Avatar
 
Drives: 2010 Yaris 3 door, manual tran
Join Date: Jul 2013
Location: --
Posts: 193
Quote:
Originally Posted by CoryM View Post
Likely one of two things:
-broken/unplugged wheel speed sensor or wire
-steering wheel is so far off the T/C doesn't know what to do.

Scan it, see what codes and go from there.
I'll have to get a better look, but the lines all "seem" to be plugged in correctly. One of the reasons I asked my friend for help is since he's a mechanic and I did not trust myself entirely with suspension work.

My steering wheel is definitely not centered anymore and I noticed now that it's raised the right wheel will rub when it's fully turned left.
vaironl is offline   Reply With Quote
Old 08-24-2018, 10:46 AM   #4
vaironl
 
vaironl's Avatar
 
Drives: 2010 Yaris 3 door, manual tran
Join Date: Jul 2013
Location: --
Posts: 193
Quote:
Originally Posted by CoryM View Post
Likely one of two things:
-broken/unplugged wheel speed sensor or wire
-steering wheel is so far off the T/C doesn't know what to do.

Scan it, see what codes and go from there.
Just came back from AutoZone. ABS and traction control lights are still on but there were no codes thrown. Not sure what this means but I'll get the alignment done regardless and keep monitoring it.
vaironl is offline   Reply With Quote
Old 08-24-2018, 11:25 AM   #5
CoryM
 
Drives: 2009 5-door, 5-speed
Join Date: Sep 2011
Location: White Rock BC
Posts: 674
Is your brake fluid low? That's really the only thing that should be able to turn the lights on w/o having a code. If somethings was unplugged/broken it *should* have a code.
CoryM is offline   Reply With Quote
Old 08-24-2018, 12:56 PM   #6
vaironl
 
vaironl's Avatar
 
Drives: 2010 Yaris 3 door, manual tran
Join Date: Jul 2013
Location: --
Posts: 193
Quote:
Originally Posted by CoryM View Post
Is your brake fluid low? That's really the only thing that should be able to turn the lights on w/o having a code. If somethings was unplugged/broken it *should* have a code.
I will check this, but I just learned the scan tool used cannot read ABS codes so a friend will be using his tool tomorrow to read the codes. I am really hoping it is not an ABS line broken as everything seemed fined every time I've looked at it.
vaironl is offline   Reply With Quote
Old 09-11-2018, 01:14 AM   #7
vaironl
 
vaironl's Avatar
 
Drives: 2010 Yaris 3 door, manual tran
Join Date: Jul 2013
Location: --
Posts: 193
To everyone reading this in the future, it was the ABS sensor indeed.

I bought the whole cable and sensor from rockauto for about $45 and after replacing it, a real simple job, the ABS and traction control lights went off without having to drive anywhere.
vaironl is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Does your liftback have ABS? BensVitz General Yaris / Vitz Discussion 75 05-24-2011 07:11 PM
Consumer Reports not too pleased with Yaris Befuddled General Yaris / Vitz Discussion 132 02-28-2011 03:57 PM
Yaris ABS and Brake warning lights stay on vinny121 DIY / Maintenance / Service 2 01-31-2011 01:02 PM
New car shopping - long post littlecarlove General Yaris / Vitz Discussion 19 11-01-2006 11:58 PM


All times are GMT -4. The time now is 02:46 AM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.