Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 03-07-2016, 05:38 PM   #1
Tommy8030
 
Drives: 2009 Yaris
Join Date: Mar 2016
Location: New York
Posts: 4
Electrical Problems

Hi guys so I cannot figure this out for the life of me maybe you guys can help me out. I have a 2009 Yaris and changed the oil replaced the spark plugs and when I replaced the spark plugs I removed the battery terminals.... Went to start it up everything was fine and about couple days later the dash lights came on, abs,power steering, battery light so I was ok maybe it was the alternator... So I replaced the alternator and ran good for another couple days and next thing I know all those lights come back on!!! The belt is tight just can't figure it out... Is it a fuse? Any help or wisdom would be kindly appreciated!
Tommy8030 is offline   Reply With Quote
Old 03-07-2016, 05:39 PM   #2
Tommy8030
 
Drives: 2009 Yaris
Join Date: Mar 2016
Location: New York
Posts: 4
I also bought a new battery as well...
Tommy8030 is offline   Reply With Quote
Old 03-08-2016, 07:34 PM   #3
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
Check the fusible links on the positive battery terminal
CTScott is offline   Reply With Quote
Old 03-09-2016, 04:46 PM   #4
Tommy8030
 
Drives: 2009 Yaris
Join Date: Mar 2016
Location: New York
Posts: 4
just checked the fuseable links and there fine...
Tommy8030 is offline   Reply With Quote
Old 03-09-2016, 07:44 PM   #5
Tommy8030
 
Drives: 2009 Yaris
Join Date: Mar 2016
Location: New York
Posts: 4
Think autozone gave me a junk alternator because I returned it installed the new one fired it up and no abs p/s lights at all... Drove it around for a hour think it solved the problem
Tommy8030 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical Problems PS,A/C,RADIO,SPEEDOMETER,SIGNALS,AIR BAG LIGHT ON, ALTERNATOR toystory DIY / Maintenance / Service 41 04-19-2016 11:44 PM
Electrical System Upgrade Advice sqcomp In Car Entertainment + Electronics (audio / video / alarm) 6 03-23-2016 01:15 AM
09 Yaris Electrical Problems (P/S, ABS, AC, Speedo, Blinkers, Wipers Not Functioning) garrettbeachy DIY / Maintenance / Service 2 08-20-2015 01:19 PM
follow up on 2010 yaris problems + more problems heavenswaitin DIY / Maintenance / Service 18 09-03-2013 03:47 PM
Starter (or possibly electrical) Problems with 2008 Yaris Sedan amandadalton DIY / Maintenance / Service 6 11-21-2012 06:32 PM


All times are GMT -4. The time now is 06:38 AM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.