Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 03-22-2014, 04:38 PM   #1
SignPirate
 
SignPirate's Avatar
 
Drives: 2007 Blue Yaris
Join Date: Aug 2009
Location: Pembroke Pines,Fl
Posts: 14
Broke a sensor

I was changing the fan belt on my 07 yaris. I tried to unplug the wire from a sensor that screws in near the alternator and snapped off the plug. Not sure what type of sensor or how to get it out to replace it. Removed the alternator bracket for better access to the bolt unless the silver cover comes off the sensor it wont turn complete. Car seems to be running fine the check engine light is on. It looks like a head sensor? Any ideas?
SignPirate is offline   Reply With Quote
Old 03-22-2014, 05:29 PM   #2
yarisugi
やりすぎだ~
 
yarisugi's Avatar
 
Drives: Me: Nuts:
Join Date: Nov 2008
Location: ハワイ
Posts: 1,997
Does it look like the one in this link?
Or how about the pics in this link?

If it is, then it's the oil control valve sensor - a popular (and expensive) piece to snap off inadvertently.
yarisugi is offline   Reply With Quote
Old 03-22-2014, 09:26 PM   #3
alanwagen
 
Drives: 2015Yaris, Son's car, 10 Prius
Join Date: May 2010
Location: Texas
Posts: 130
oil control valve

A lot of people have learned the hard way about this device. It is placed in a bad place for belt tightening.
alanwagen is offline   Reply With Quote
Old 03-23-2014, 08:12 AM   #4
SignPirate
 
SignPirate's Avatar
 
Drives: 2007 Blue Yaris
Join Date: Aug 2009
Location: Pembroke Pines,Fl
Posts: 14
Yep thats the sucker! Thank you. Now how do I get it out to replace? Took off the alt bracket to get to the small bolt but not sure how to remove the sensor,does it push in or screw out? Tried to screw it out but it only turns so much then hits that block above it. Thanks again guys
SignPirate is offline   Reply With Quote
Old 03-23-2014, 08:38 AM   #5
WeeYari
 
WeeYari's Avatar
 
Drives: 06 Polar White 5dr, 13 Soul 4u
Join Date: Oct 2008
Location: Georgetown, Ontario, Canada
Posts: 4,641
It pulls out.
__________________
WeeYari is offline   Reply With Quote
Old 03-23-2014, 09:46 AM   #6
Bluevitz-rs
1NZ-6spd Turbo
 
Bluevitz-rs's Avatar
 
Drives: '05 6-Spd Vitz RS Turbo
Join Date: Oct 2008
Location: Courtice, Ontario, Canada
Posts: 2,854
That controls the VVT-i. You can run without it to no ill effects, but you'l have the Check Engine light on.
Bluevitz-rs is offline   Reply With Quote
Old 03-23-2014, 10:04 AM   #7
SignPirate
 
SignPirate's Avatar
 
Drives: 2007 Blue Yaris
Join Date: Aug 2009
Location: Pembroke Pines,Fl
Posts: 14
broke a sensor

I have run the car a little, definite check engine light. Thanks for your input. Will have to change it this week. Just googled it, not too bad, I want to thank all of you that responded, VERY HELPFUL!! This site still continues to be a GREAT resource for Yaris owners.Thank you.
SignPirate is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Zage Turbo Kit Install - Toyota Yaris Focus_Sh1ft Forced Induction Forum 139 07-07-2017 01:26 PM
DIY : changing the Oxygen / O2 sensor on Yaris hatch MANY PICS auxmike DIY / Maintenance / Service 43 10-13-2016 06:05 AM
2nd time O/2 sensor is needing replacing Astroman DIY / Maintenance / Service 8 01-29-2014 10:32 PM
The "let's brainstorm how to make a piggyback work" thread eTiMaGo Forced Induction Forum 100 08-17-2011 03:54 PM
NEED ENGINE CHECK LIGHT CODE LIST Attitude Forced Induction Forum 12 04-11-2011 06:38 PM


All times are GMT -4. The time now is 03:36 AM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.