Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 03-18-2011, 04:26 PM   #1
gboezio
 
gboezio's Avatar
 
Drives: Yaris 4dr 2008
Join Date: Nov 2008
Location: victoriaville,Qc,Canada
Posts: 28
Cold engine light randomly comes on while warm.

Am I the only one who gets the cold light to come on while driving ??
When I mean driving, I mean on the highway for 30 minutes.

I have searched the forum for this and it does not seem to be a common problem. The heater is blowing hot air at will, the coolant level is right on, I figured that maybe the ECT sensor is faulty, but the ECM throws no codes and should, unless there was air or steam pockets in the coolant stream or the engine temp dipped under 130 F ??

Unlikely I say, but any input on this will be appreciated.

Anyone knows the resistance of the ECT @ X temp in ohms ?
gboezio is offline   Reply With Quote
Old 11-17-2018, 04:57 PM   #2
faridmakhloufi
 
Drives: yaris sedan
Join Date: Feb 2009
Location: algeria
Posts: 2
my same problem i have a toyota yaris 1.3 engine 2nz-fe with 150000 miles but this appears only in winter or cold weather please help me
faridmakhloufi is offline   Reply With Quote
Old 11-17-2018, 08:59 PM   #3
tmontague
 
tmontague's Avatar
 
Drives: '08 2zr swapped Vios M/T
Join Date: Oct 2012
Location: Hamilton Ont.
Posts: 2,348
Could be a faulty water temp sensor. Even when my car goes back below 129 degrees F the sensor doesnt kick back on, so once it's off it should stay off even if the cars cools down due to running the heat.

Use a scanner to read coolant temp and see if your sensor is shot
__________________
I like to drive a slow car fast...
tmontague is online now   Reply With Quote
Old 11-17-2018, 10:37 PM   #4
ex-x-fire
 
Drives: 2010 yaris 3 door hatch
Join Date: Jun 2013
Location: Sheboygan Falls, Wi.
Posts: 222
Yeah, could have a t-stat that won't close all the way. Best way is to scan it. Let the car idle till it gets to 180 or 190. Drive it, the temp shouldn't fall below 170 or so.
ex-x-fire is offline   Reply With Quote
Old 11-20-2018, 02:17 PM   #5
faridmakhloufi
 
Drives: yaris sedan
Join Date: Feb 2009
Location: algeria
Posts: 2
i have changed the ect sensor and the thermostat the problem is persisting and i have scanned the memory no error codes it is very strange realy i I think it's the maf that gives false data on the air temperature , not sure
faridmakhloufi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Differntial diagnosis for the check engine light yaris sedan dante2086 DIY / Maintenance / Service 1 12-18-2010 10:04 AM
Engine management light for 300 miles then off for 300 - this cycle keeps repeating stripey DIY / Maintenance / Service 0 08-01-2010 05:43 PM
Yaris Squealing Sound Yaris General Yaris / Vitz Discussion 19 01-18-2010 11:58 PM
Cold Engine and Gear Shifting captainm27 General Yaris / Vitz Discussion 9 01-29-2009 09:27 AM
service engine light @ 9000 mi? dandj DIY / Maintenance / Service 21 01-03-2007 01:30 AM


All times are GMT -4. The time now is 11:30 PM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.