Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > In Car Entertainment + Electronics (audio / video / alarm)
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 08-15-2012, 10:35 AM   #1
worduphomes
I've made a post!
 
Drives: 2007 Yaris SR
Join Date: Aug 2012
Location: Herefordshire, England
Posts: 1
Keyless Entry stopped working but buttons do work!

Hey All

I have a 2007 Yaris SR and I recntly installed an amp and sub-woofer that works very well and I experienced no keyless entry problem at first...

About 2 weeks after installing the amp, my keyless entry started playing up. At first the keyless entry would work fine if I returned to the car within about 3-4 hours of last driving it but if I left it over-night say, it would not automatically unlock as I approached the car and I would have to press the unlock button (on the fob) about 10 times before it unlocked. Also, when I get out of the car and press the door button to lock the car, nothing happens. I have to press the button on the fob again (about 10 times) before it locks.

Over time this has deteriorated and now the 3-4 hour period (mentioned above) is null and void. Even if get out and I lock the car and then walk away and come straight back within a few seconds it will not unlock and I have to press the unlock button about 10 times again.

I have tried a new battery in the fob and also tried the spare fob and results are exactly the same, so the only thing I can think is that it is related to the installation of the amp. The amp installation is very basic with a fused positive wire running from the battery and the remote cable (that turns the amp on) is spliced to the antenna wire in the back of the standard stereo head unit. The amp is well grounded to a sanded bit of chassis in the boot.

I read CTScott's excellent post about re-programming the fob (http://www.yarisworld.com/forums/showthread.php?t=20865) but unfortunately my Yaris does not have an ignition but has a 'push button' start, so I don't think it will help work.

Any help or ideas would be greatly appreciated.
worduphomes is offline   Reply With Quote
Old 08-15-2012, 11:28 AM   #2
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,455
Unfortunately the smart entry remotes can only be reprogrammed with the Toyota service tool.

Try temporarily disconnecting that antenna wire connection to see if it makes a difference. The smart entry system has three antennae (one built into each of the two front door handles and one on the hatch). They have a really short range, so anything putting out RF harmonics in their frequency range would stomp on them.
CTScott is offline   Reply With Quote
Old 01-16-2013, 12:14 PM   #3
Lady J
 
Drives: Efficient
Join Date: Jun 2012
Location: United States
Posts: 19
Did you ever sort out your problem?as I am experiencing the same issues.
Lady J is offline   Reply With Quote
Old 01-16-2013, 06:52 PM   #4
marcus
toyota
 
marcus's Avatar
 
Drives: 2007 Yaris RS Blazed
Join Date: Oct 2006
Location: toronto, canada
Posts: 3,666
try opening the keyfob take the battery out maybe clean it up a bit and put it back on... worked for me and still have the same original battery since 2007.
__________________
If my calculations are correct, when this baby hits eighty-eight miles per hour... you're gonna see some serious shit!!!!!!

"Horsepower is how fast you hit the object. Torque is how far you move that object.."
marcus is offline   Reply With Quote
Old 01-17-2013, 01:12 PM   #5
Bluevitz-rs
1NZ-6spd Turbo
 
Bluevitz-rs's Avatar
 
Drives: '05 6-Spd Vitz RS Turbo
Join Date: Oct 2008
Location: Courtice, Ontario, Canada
Posts: 2,913
I've done the "clean the battery" thing on my regular old fashioned key fob and it worked wonders.
Bluevitz-rs is offline   Reply With Quote
Old 01-17-2013, 10:35 PM   #6
yaris2010RS
 
yaris2010RS's Avatar
 
Drives: no-longer-boosted '10 Yaris
Join Date: Nov 2009
Location: Angus, Ontario
Posts: 1,884
i know the original was last year but imo sounds like the amp isnt turning off and killing the car battery till even the doors wont unlock.....
__________________
If it has boobs or wheels sooner or later your gonna have problems with it
yaris2010RS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Question about remote keyless entry shela.me DIY / Maintenance / Service 1 08-13-2012 08:01 AM
Fog lights, or parking lights stopped working sylvermagyk DIY / Maintenance / Service 4 03-24-2011 05:13 PM
Electric Windows Stopped Working !?!? MattyP DIY / Maintenance / Service 0 09-14-2010 07:20 AM
Keyless Entry BLKYRSSDN In Car Entertainment + Electronics (audio / video / alarm) 44 09-16-2007 10:27 PM
DIY KEYLESS ENTRY on Power Liftback? TC-LIFTBACK DIY / Maintenance / Service 0 08-23-2006 09:57 AM


All times are GMT -4. The time now is 08:55 AM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.