Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 12-29-2014, 06:39 PM   #55
CueBall
Ruler of the free world
 
Drives: 09 Yaris 2D HB
Join Date: Jul 2010
Location: Utah
Posts: 49
09 MT LB Mine does sometines..
I dont believe this is 'normal', as some have stated theirs does NOT do it.
My experience is the same as XYaris'. Most noticeable after a freeway run when stopped at the offramp, in neutral, brake lights on. RPM does a little dance.. about 550 then dips to 450 for a sec or two, shakes, then back to 550, then back to 450.. up and down til I change something. Very annoying, feels like it's gonna die.. it would be fine if it would just hold 550 RPM.
I will be looking at the motor and trans mounts for possible wear/breakage.
If it were just an ECM flash, like some say, I would gladly give up the miniscule amout of fuel it would take to keep it running smooth..
I was thinking I might have some carbon buildup in the idle control valve (or whatever controls idle ???) and maybe I do.. Any tips on where/what controls the idle - and how to clean it???
CueBall is offline   Reply With Quote
Old 01-13-2015, 01:33 PM   #56
esse10
 
Drives: 2009 yaris 2 door
Join Date: Feb 2013
Location: richmond TX.
Posts: 183
vibrations at idle

I hate to bring up this old thread but was wondering if anybody has come up with a solution to this RPM Idle being too low and fluctuating up and down causing the motor to vibrating as if it's gonna stop? I think that motor vibration at Idle will cause wear & Tear on your engine Mounts.
esse10 is offline   Reply With Quote
Old 05-29-2018, 12:52 PM   #57
mr_robot
 
Drives: Yaris
Join Date: Oct 2017
Location: NYC
Posts: 68
Quote:
Originally Posted by CueBall View Post
09 MT LB Mine does sometines..
I dont believe this is 'normal', as some have stated theirs does NOT do it.
My experience is the same as XYaris'. Most noticeable after a freeway run when stopped at the offramp, in neutral, brake lights on. RPM does a little dance.. about 550 then dips to 450 for a sec or two, shakes, then back to 550, then back to 450.. up and down til I change something. Very annoying, feels like it's gonna die.. it would be fine if it would just hold 550 RPM.
I will be looking at the motor and trans mounts for possible wear/breakage.
If it were just an ECM flash, like some say, I would gladly give up the miniscule amout of fuel it would take to keep it running smooth..
I was thinking I might have some carbon buildup in the idle control valve (or whatever controls idle ???) and maybe I do.. Any tips on where/what controls the idle - and how to clean it???
Did you ever find the idle control valve? Where is it on this car? Bought a gasket for it to replace it when I clean it but seems like it's part of the TB?
mr_robot is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY (08' USDM Liftback): ESUSE Fog Light Install v2.0 goku87 DIY / Maintenance / Service 125 08-23-2015 09:12 PM
NEWS: TOYOTA REVEALS ALL-NEW YARIS SEDAN AT 2006 LOS ANGELES AUTO SHOW VitzBoy General Yaris / Vitz Discussion 5 09-05-2010 08:53 PM
2007 Yaris Pricing Info ! YarisBueller New YARIS Purchase Forum 104 06-24-2009 04:54 PM
Waiting for the Taiwan Yaris heybai General Yaris / Vitz Discussion 13 03-12-2006 08:26 AM


All times are GMT -4. The time now is 07:46 PM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.