Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Second Generation Toyota Yaris Main Rooms > General Yaris / Vitz Discussion
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 02-19-2009, 01:53 AM   #1
GeneralDon7
 
Drives: Yaris Sedan
Join Date: Oct 2008
Location: Frederick, MD
Posts: 231
Water Pump issue, after taking in for Recall

Ok, so today I took my 2007 Sedan, into get that recall seatbelt issue fixed, by the way, I havent noticed any difference in outside noice. I was told that my water pump was malfuctioning an they have to replace it, even though the car never showed me the check engine light, the toyota person told me, that it wasnt a big issue, so I scheduled it for 2 saturdays from now. Has anyone else had this issue?, its covered under warranty, so its a free fix either way, i was just curious how commmon this was. My car has 40000 and is 2 years old. Good thing I havent gotten the water pump pulley upgrade yet.
GeneralDon7 is offline   Reply With Quote
Old 02-19-2009, 08:09 AM   #2
SailDesign
 
Drives: .
Join Date: Feb 2007
Location: .
Posts: 1,991
I have a 2007 Hatchback, about 32000 miles on it, and no problem yet. i'll be curious to see what other folks have to say, though.
SailDesign is offline   Reply With Quote
Old 02-19-2009, 08:35 AM   #3
YAR1S
 
YAR1S's Avatar
 
Drives: 07 Yaris 3dr LB (Bayou Blue)
Join Date: Oct 2008
Location: Raleigh, NC
Posts: 2,640
Send a message via AIM to YAR1S Send a message via Skype™ to YAR1S
36k no problems?? :S
__________________
-Jen <3



Quote:
"Spendin money that I don't have to buy parts that I don't need to impress people that I don't know"
YAR1S is offline   Reply With Quote
Old 02-19-2009, 10:25 AM   #4
IllusionX
It's the illusion you see
 
Drives: 07 Yaris Sedan Aero
Join Date: Oct 2006
Location: Brossard, QC
Posts: 3,696
i had problems with both the alternator bearings and the water pump getting ceased up.
a little over 2 years old, and 56000km when both was changed.
IllusionX is offline   Reply With Quote
Old 02-19-2009, 10:46 AM   #5
*MAD DOG*
 
*MAD DOG*'s Avatar
 
Drives: 2011 Toyota Camry Hybrid
Join Date: Oct 2008
Location: Victoria, Australia
Posts: 6,448
Send a message via MSN to *MAD DOG*
15,000km and no issue with water pump.
__________________


"Manual labour is not for me. In fact i'm not even sure non manual work is either." -Anthony Linton

Check out ▬▬► I like I like ◄▬▬ for more fun on Facebook
*MAD DOG* is offline   Reply With Quote
Old 02-19-2009, 01:44 PM   #6
Danish Yaris
 
Drives: Toyota Yaris 1,8 TS 5dr. 2007
Join Date: Dec 2008
Location: Copenhagen, Denmark
Posts: 166
Hi

If the water pump need replacing it won´t put a check light in the display. It will leak water and perhaps it´s not very much, but when it´s on the guarantee it doesn´t matter.
I work at Toyota and I think we have replaced only one on the guarantee on a Toyota Yaris.

Regards Steven.
Danish Yaris is offline   Reply With Quote
Old 02-19-2009, 02:07 PM   #7
BLAZINBLUEVITZ
 
BLAZINBLUEVITZ's Avatar
 
Drives: 2007 YARIS 3DOOR
Join Date: Jan 2009
Location: NEW YORK
Posts: 1,281
Quote:
Originally Posted by *MAD DOG* View Post
15,000km and no issue with water pump.
same here.....
BLAZINBLUEVITZ is offline   Reply With Quote
Old 02-19-2009, 03:35 PM   #8
PetersRedYaris
 
PetersRedYaris's Avatar
 
Drives: 2005 Scion xB
Join Date: Nov 2006
Location: The Black Hills of South Dakota
Posts: 1,061
Water pump failure is not uncommonon the 2004-2006 Scion Xb's. If you check over on Scion life you will see it is actually quite common. In fact on my 2005 Xb with 59,000 mile is starting to show a little dried coolant "crust" under the weep hole, so mine is on it's way out too.

PS- Yaris and Xb have the same motor, though I'm not sure the water pump is identical...
PetersRedYaris is offline   Reply With Quote
Old 02-19-2009, 04:01 PM   #9
BLAZINBLUEVITZ
 
BLAZINBLUEVITZ's Avatar
 
Drives: 2007 YARIS 3DOOR
Join Date: Jan 2009
Location: NEW YORK
Posts: 1,281
echo prius xa xb and yaris share same water pump....
BLAZINBLUEVITZ is offline   Reply With Quote
Old 02-19-2009, 05:03 PM   #10
IllusionX
It's the illusion you see
 
Drives: 07 Yaris Sedan Aero
Join Date: Oct 2006
Location: Brossard, QC
Posts: 3,696
ah, i haven't had prob with my 05 echo with 60000km. (2 years old when i sold it)
IllusionX is offline   Reply With Quote
Old 02-19-2009, 05:07 PM   #11
firemachine69
School'er of hard knocks
 
Drives: Silver Yaris 4dr. HB
Join Date: Oct 2008
Location: Sudbury, On
Posts: 557
Surprised they covered it. IIRC the water pump does not consist of the "powertrain", thus falling under the bumper-to-bumper warranty (which should have expired with that kind of mileage).
firemachine69 is offline   Reply With Quote
Old 02-19-2009, 05:11 PM   #12
BLAZINBLUEVITZ
 
BLAZINBLUEVITZ's Avatar
 
Drives: 2007 YARIS 3DOOR
Join Date: Jan 2009
Location: NEW YORK
Posts: 1,281
Quote:
Originally Posted by firemachine69 View Post
Surprised they covered it. IIRC the water pump does not consist of the "powertrain", thus falling under the bumper-to-bumper warranty (which should have expired with that kind of mileage).
extended warranty.........
BLAZINBLUEVITZ is offline   Reply With Quote
Old 02-19-2009, 05:12 PM   #13
firemachine69
School'er of hard knocks
 
Drives: Silver Yaris 4dr. HB
Join Date: Oct 2008
Location: Sudbury, On
Posts: 557
Ha, don't know too many folks who actually get those (as they are usually a rip-off).
firemachine69 is offline   Reply With Quote
Old 02-19-2009, 05:41 PM   #14
kou
 
Drives: 08 lb
Join Date: Aug 2007
Location: nj
Posts: 953
on my last yaris the waterpump went bad with under 15ooo miles. http://www.yarisworld.com/forums/sho...=waterpump+diy
kou is offline   Reply With Quote
Old 01-17-2012, 01:18 PM   #15
Nova Scotia
I've made a post!
 
Drives: 2007 Toyota Yaris Hatchback
Join Date: Jan 2012
Location: Nova Scotia
Posts: 1
Quote:
Originally Posted by YAR1S View Post
36k no problems?? :S
My 2007 yaris hatchback has over 250,000 on it with all original parts minus the break pads/shoes, sparkplugs, oil filters and whatever they change during regular maintances...which we kept doing.

good little car.

Im thinking maybe the water pump is finally starting to go....a whiring sound from motor area...grindy. will check for water leaks
Nova Scotia is offline   Reply With Quote
Old 01-17-2012, 01:24 PM   #16
marcus
toyota
 
marcus's Avatar
 
Drives: 2007 Yaris RS Blazed
Join Date: Oct 2006
Location: toronto, canada
Posts: 3,666
had mine replaced at 80k kms but it might have been leaking since 60k
__________________
If my calculations are correct, when this baby hits eighty-eight miles per hour... you're gonna see some serious shit!!!!!!

"Horsepower is how fast you hit the object. Torque is how far you move that object.."
marcus is offline   Reply With Quote
Old 01-17-2012, 01:29 PM   #17
marcus
toyota
 
marcus's Avatar
 
Drives: 2007 Yaris RS Blazed
Join Date: Oct 2006
Location: toronto, canada
Posts: 3,666
easy to tell check the inside part of the pulley you should see pink stuff if its leaking..

Quote:
Originally Posted by Nova Scotia View Post
My 2007 yaris hatchback has over 250,000 on it with all original parts minus the break pads/shoes, sparkplugs, oil filters and whatever they change during regular maintances...which we kept doing.

good little car.

Im thinking maybe the water pump is finally starting to go....a whiring sound from motor area...grindy. will check for water leaks
__________________
If my calculations are correct, when this baby hits eighty-eight miles per hour... you're gonna see some serious shit!!!!!!

"Horsepower is how fast you hit the object. Torque is how far you move that object.."
marcus is offline   Reply With Quote
Old 01-17-2012, 03:29 PM   #18
mazilla
advocatus diaboli
 
mazilla's Avatar
 
Drives: 07 Yaris hatch
Join Date: Mar 2011
Location: San Jacinto California
Posts: 1,127
I'm not going to tell you it's been hundreds of thousands of miles with no problems, because I don't want to jinx myself. ;)
__________________
-Type 07 FFL-



My odometer 03/11
http://i205.photobucket.com/albums/b...a/2843ed85.jpg
mazilla is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
electric water pump help! mandriu Performance Modifications 39 10-24-2009 02:56 AM
bye bye water pump cali yaris Performance Modifications 29 01-03-2009 06:06 PM


All times are GMT -4. The time now is 10:56 PM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.