Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 06-02-2018, 02:52 AM   #1
Mhemmings
I've made a post!
 
Drives: Yaris
Join Date: May 2018
Location: Whitehorse
Posts: 1
10A GAUGE FUSE Blowing/Indicator Problems

Hello,

This is my first post on here but I've been reading quite a bit trying to solve an issue I'm having with my Yaris.

I have a 2009 Yaris RS Hatchback manual transmission.

I have been having troubles with my dash lights, a/c fan, and indicators for a few months now.

Every so often the 10A Gauge fuse under the driver's side dash will blow. Sometimes it's weeks apart sometimes it's seconds. Recently I've also started experiencing a situation where the indicator and the battery warning light go on and off in tandem. Imagine every time the indicator turns off the battery light turns on but speed that up by 3x.

I've checked a few things, but am definitely no expert so was hoping for some input.

I know that the fuse powers:
A/C Blower
Back up Lights
Alternator Volt Reg
Dimer resistor
Rear window Defrost Relay
Passenger Seat Belt Warning Light
Flasher Relay

Currently, I have tested for:
Voltage in the battery > Seems to be 12.6 volts though occasionally as high
as 14 volts.
Continuity from the battery (negative lead off and bridging with a
multimeter) > it's basically at zero which I believe is normal.
Indicator Lights > Checked for shorts on the lights I can't see any though not
really sure what I'm looking for

My current theory is something to do with the Flasher Relay, but it's a pain to get off. The manual says to use a screwdriver but I can't figure it out.

It seems to blow when I'm making tight turns like during a three point turn, but not exclusively.

Usually, when it blows, the Passenger Airbag light comes on and the Rear Defrost Light comes on.

I've read that it could be a problem with the voltage regulator, but I had the whole alternator replaced on my first visit to the mechanic to diagnose the fuse blowing so I don't think it is that.

If someone has some suggestions or advice I would greatly appreciate it.

Thanks!

Mike
Mhemmings is offline   Reply With Quote
Old 07-27-2018, 11:47 PM   #2
Clintondmb
 
Drives: '08 3DrLB.
Join Date: Sep 2010
Location: Shenandoah Valley
Posts: 17
Hmm I have an aftermarket blinker relay and have this exact issue on my 08 hatchback. I am blowing my gauge fuse as well.

I'll look into swapping back to the original and replacing the LED bulbs in the signals and see what happens.
Clintondmb is offline   Reply With Quote
Reply

Tags
alternator, blower motor, electrical, fuse blown, indicator

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
3rd Gen Gauge Cluster Swap :D KenTK808 Third Gen Yaris General Discussion 22 10-21-2017 07:58 AM
help re wiring fuse box please kommodore DIY / Maintenance / Service 1 04-01-2014 02:11 PM
power outlet/cigarette lighter fuse location Idahotom General Yaris / Vitz Discussion 1 01-08-2014 06:45 PM
Blown or missing gauge fuse causes strange symptoms on a 2007 Yaris hatchback vandallen DIY / Maintenance / Service 1 06-06-2013 09:59 PM
30A Power Fuse Instrument Panel Location? Kioshi DIY / Maintenance / Service 16 03-31-2013 06:53 PM


All times are GMT -4. The time now is 12:40 AM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.