Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 11-17-2010, 11:09 PM   #1
bieniman
 
bieniman's Avatar
 
Drives: vitz rs 1500 2001
Join Date: Dec 2008
Location: Suriname South America
Posts: 28
Unhappy Engine noise and Oil Lamp on

I just got my Vitz RS 2001 1500 AT repainted. So the car was idle for about a month. After it was finished painted, took it home. I noticed the oil lamp warning light coming on when the engine heats up. I checked the oil level and everything is ok. So took for a drive hoping the lamp will go off. It didn't and even worse I hear a noise coming from my engine now when I rev the car.
I immediately shut off the engine, affraid of getting the engine worse, PANIC!!!. The day after I started the engine again and there was no oil lamp on, I left it for a while and again, as the engine warmed up the oil lamp went on and a while after that the noise comes back when the engine is revved.
PLease help.....

I have been thinking of this idea:
Because the car was idle, the carbon and dirt had time to sink and clogged up something (I heard there is a filter in the oil pan, which can get clogged). This causes the low pressure, hence the oil lamp, which in turn causes the noise because something is not getting lubed.

I am not a machanic so I cannot check this myself, still waiting on the (busy)mechanic to diagnose the problem, still I hope something is not severely damaged inside the motor.....

Can somebody suggest anything besides a complete overhaul and giving me instructions on how to do it myself??...Please please please (desperate)
bieniman is offline   Reply With Quote
 

Tags
engine, low pressure, noise, oil, oil lamp

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel Economy swng Fuel Economy Forum 2097 01-23-2015 07:41 PM
Transmission Oil for Yaris 1st Gen adigilani DIY / Maintenance / Service 3 10-23-2011 02:48 PM
My first noise bst82551 DIY / Maintenance / Service 9 08-13-2010 09:05 AM
1NZ-FE tuned by Phoenix-r sujonol78 Performance Modifications 50 02-08-2010 02:34 PM
Anyone running Royal Purple? firebird1999us DIY / Maintenance / Service 80 02-27-2009 11:30 PM


All times are GMT -4. The time now is 05:54 PM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.