Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 04-21-2014, 05:00 AM   #1
aleksii
 
Drives: Yaris
Join Date: Apr 2014
Location: Australia
Posts: 5
2006 Yaris Fuel Pump and relay

Hi all,

My first post here, so I hope I'm thorough enough.

My wife's Yaris is having the dreadful issue of not starting. It cranks but just will not turn over. I have an engine light on.

I have checked:

Battery OK
All fuses OK
Fuel level half full
Spark plugs OK (1 month old)
Removed one spark plug, grounded to battery and confirms it fires

Only thing I am left to think is that the fuel pump has died. I can't hear it pumping any fuel prior to turning the key over.

I am having issues locating the fuel pump relay. Can anyone tell me where to find it? I am in Australia so chances are that the location of fuse boxes is different to America etc.

One thing I have done is removed the rear seat and removed the cover for the fuel pump/filter assembly. When I removed one of the tubes (middle tube that has the yellow clip http://www.yarisworld.com/forums/showthread.php?t=42906) and it poured out with some fuel and the splattered air and fuel and then stopped. I assume this is because I didnt remove any pressure from it via the fuel fill cap.

ANY help would be greatly appreciated.
aleksii is offline   Reply With Quote
Old 04-21-2014, 06:24 AM   #2
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
Was the check engine light on before it stopped starting? The light always comes on with the key and then goes off once the engine stops.

With the key in the on position you should see 12 volts between the two pins for the fuel pump.

Look at this thread for instructions on how to test if the relay is bad (which is integrated into the body ECU).
http://www.yarisworld.com/forums/showthread.php?t=45663

Besides the fuel pump relay or fuel pump itself, the engine immobilizer (if your car has the transponder type keys) cuts the fuel if the key is not recognized.
CTScott is offline   Reply With Quote
Old 04-21-2014, 08:25 AM   #3
aleksii
 
Drives: Yaris
Join Date: Apr 2014
Location: Australia
Posts: 5
Nope no engine light before that. The boxes we have look different, there's one under the good and one under te glove box which has several fuses and relays as well as wiring going into it.

The car had turned on, I reversed out of the driveway, put it into first gear (manual) and accelerated it then sounded like it was trying to stay on (sounded just like when it's cranking but slowly dying) then it died

I don't have a volt meter. Is it the c/opn relay I'm looking for?
aleksii is offline   Reply With Quote
Old 04-21-2014, 08:33 AM   #4
aleksii
 
Drives: Yaris
Join Date: Apr 2014
Location: Australia
Posts: 5
Ok my apologies I just re read the thread and understand that the actual relay is within that box under the dash. Therefore testing it would be needed using a meter and then either replacing it or looking at replacing the fuel pump.
aleksii is offline   Reply With Quote
Old 04-21-2014, 09:23 AM   #5
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
Correct. Definitely time to grab a cheap multimeter.
CTScott is offline   Reply With Quote
Old 04-21-2014, 07:48 PM   #6
aleksii
 
Drives: Yaris
Join Date: Apr 2014
Location: Australia
Posts: 5
Any idea which other model toyotas have a compatible pump?
aleksii is offline   Reply With Quote
Old 04-21-2014, 08:55 PM   #7
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,456
Quote:
Originally Posted by aleksii View Post
Any idea which other model toyotas have a compatible pump?
The 1NZ-FE Yaris uses the same pump as the Toyota Ractis and many other non-Toyotas (Suzuki Swift, etc.)
CTScott is offline   Reply With Quote
Old 04-22-2014, 02:48 AM   #8
aleksii
 
Drives: Yaris
Join Date: Apr 2014
Location: Australia
Posts: 5
Yep, turns out it was a faulty fuel pump. Got one from a wrecker here for $110 and all running, running better than it had been for a while. Seemed a little hesitant to accelerate at times but now runs quite smoothly. I'd say fuel efficiency will improve too. Thank you for the help @CTScott
aleksii is offline   Reply With Quote
Old 04-22-2014, 06:00 AM   #9
bronsin
 
bronsin's Avatar
 
Drives: 2009 Base Hatch 2 Dr Auto
Join Date: Dec 2008
Location: nj
Posts: 3,992
Brilliant!
__________________
Synthetic Oil: Its All In Your Head
bronsin is offline   Reply With Quote
Reply

Tags
fuel, fuel pump, fuses, relay

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
07 cranks, won't start--no fuel?... tylerwatts53 DIY / Maintenance / Service 18 03-03-2014 06:03 PM
fuel pump relay with standalone Radou Performance Modifications 0 07-10-2013 05:06 PM
Fuel Pump Relay bronsin General Yaris / Vitz Discussion 4 08-07-2012 07:19 AM
Help, Rear Defogger shuts off Fuel Pump sm2by DIY / Maintenance / Service 3 05-30-2011 12:10 PM
NEED ENGINE CHECK LIGHT CODE LIST Attitude Forced Induction Forum 12 04-11-2011 06:38 PM


All times are GMT -4. The time now is 06:24 PM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.