Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 04-02-2017, 01:47 PM   #1
Mickman
 
Drives: 2006 Yaris RS
Join Date: May 2015
Location: Toronto
Posts: 12
Battery Light Flicker

Hey everyone,

I apologize if this has been answered already, I tried searching but couldn't find a clear answer.

Left my 2006 Yaris Hatch sitting for a week while we were on vacation. Came home and started no problem but the battery light is on (flickering).

Voltage was 11.3 with car off, 13.5-13.7 running, and now rests at about 12.5 when the car is off.

I turned the car on, disconnected the battery, and the car ran perfectly fine off of the alternator alone.

I read about the voltage regulator issues, is that what this sounds like to you guys? Car is still driving fine, seems to be charging at the right voltage as well.

What steps should I be taking?

Any help would be greatly appreciated.

Mike
Mickman is offline   Reply With Quote
Old 04-02-2017, 03:39 PM   #2
WeeYari
 
WeeYari's Avatar
 
Drives: 06 Polar White 5dr, 13 Soul 4u
Join Date: Oct 2008
Location: Georgetown, Ontario, Canada
Posts: 4,489
Almost definitely the voltage regulator. If you just now returned from vacation, then the car has recently been subjected to very moist air conditions. When mine initially started to show signs of failing, it happened during rain or heavy fog events. Went away when things dried out again, then back to flickering when the next wet atmospheric conditions occurred. This went on for several years before I finally had a permanent battery light rather than intermittent flickering. Replaced alternator at that time.
__________________
WeeYari is offline   Reply With Quote
Old 04-02-2017, 07:12 PM   #3
Mickman
 
Drives: 2006 Yaris RS
Join Date: May 2015
Location: Toronto
Posts: 12
Thanks for confirming my suspicion. Do I have time to replace this or should it be done ASAP? Reason I ask, is it is cheaper to order from Rockauto rather than buy local. I'm sure you can relate as I see you're in Canada as well!
Mickman is offline   Reply With Quote
Old 04-02-2017, 07:46 PM   #4
WeeYari
 
WeeYari's Avatar
 
Drives: 06 Polar White 5dr, 13 Soul 4u
Join Date: Oct 2008
Location: Georgetown, Ontario, Canada
Posts: 4,489
An excellent seller and local.

http://www.yarisworld.com/forums/showthread.php?t=57949

Sent from my Elite_5_5_Octa using Tapatalk
__________________
WeeYari is offline   Reply With Quote
Old 04-10-2017, 01:59 PM   #5
Mickman
 
Drives: 2006 Yaris RS
Join Date: May 2015
Location: Toronto
Posts: 12
So before I replaced the alternator, I thought I would take the alternator out and clean all the contacts and voltage regulator to see if the problem was corrosion. Put it all back together and the light flickers more and was off for a little bit but still no fix.

But now the car idles low and rough.. is this because the ECM is relearning after the battery disconnect? Drove 30+KM and still like this. Tried playing with the belt tension and no luck either.

Help!! lol
Mickman is offline   Reply With Quote
Old 04-10-2017, 02:15 PM   #6
tmontague
2zr-fe dream team
 
tmontague's Avatar
 
Drives: 08 Vios M/T, 05 4wd Vibe
Join Date: Oct 2012
Location: Hamilton Ont.
Posts: 1,550
Your car will fluctuate revs and idle higher sometimes when the ecu is relearning, that part is definitely normal and happens to me whenever I unplug the battery
__________________
2zr swapped Vios, oil catch can, TRD rear sway bar, MI lowering springs, In cabin+under hood SSK, TRD shift knob, HID projector/Halo lights, 10mm rear axle spacers, custom header back exhaust, Front splitter, Sickspeed dual horns, Tokiko Blue's in rear, triple gauges, Whiteline bushings, Sparco pedal covers, Viper Keyless entry, DC Sports CAI, NST u/d crank pulley, solid poly engine mounts, MR Racing Flywheel, Konig Dial Ins 15x7 +35
tmontague is offline   Reply With Quote
Old 04-10-2017, 09:10 PM   #7
Mickman
 
Drives: 2006 Yaris RS
Join Date: May 2015
Location: Toronto
Posts: 12
Quote:
Originally Posted by tmontague View Post
Your car will fluctuate revs and idle higher sometimes when the ecu is relearning, that part is definitely normal and happens to me whenever I unplug the battery
Thanks man! Just wanted to make sure. Should be back to normal soon.
Mickman is offline   Reply With Quote
Old 05-04-2017, 05:03 PM   #8
Mickman
 
Drives: 2006 Yaris RS
Join Date: May 2015
Location: Toronto
Posts: 12
Just wanted to update. Got the alternator fixed and now all is good.

Big thank you to tmontague for the alternator (Great seller) and pointing me in the right direction after I blew the main fusible link while rushing and forgetting to disconnect the battery during the alternator change.

Thanks everyone!
Mickman is offline   Reply With Quote
Old 05-04-2017, 05:09 PM   #9
WeeYari
 
WeeYari's Avatar
 
Drives: 06 Polar White 5dr, 13 Soul 4u
Join Date: Oct 2008
Location: Georgetown, Ontario, Canada
Posts: 4,489
Excellent.

Sent from my Elite_5_5_Octa using Tapatalk
__________________
WeeYari is offline   Reply With Quote
Old 05-06-2017, 09:56 PM   #10
xdarkxfirex
 
Drives: 08 yaris base
Join Date: Feb 2015
Location: hamilton, on
Posts: 61
Check for draw, battery and connections before ruling out a bad alternator. Most problems start at the connections
xdarkxfirex is offline   Reply With Quote
Old 05-06-2017, 10:58 PM   #11
tmontague
2zr-fe dream team
 
tmontague's Avatar
 
Drives: 08 Vios M/T, 05 4wd Vibe
Join Date: Oct 2012
Location: Hamilton Ont.
Posts: 1,550
^the op just stated the alternator fixed his issue. It was a bad regulator in the alternator
__________________
2zr swapped Vios, oil catch can, TRD rear sway bar, MI lowering springs, In cabin+under hood SSK, TRD shift knob, HID projector/Halo lights, 10mm rear axle spacers, custom header back exhaust, Front splitter, Sickspeed dual horns, Tokiko Blue's in rear, triple gauges, Whiteline bushings, Sparco pedal covers, Viper Keyless entry, DC Sports CAI, NST u/d crank pulley, solid poly engine mounts, MR Racing Flywheel, Konig Dial Ins 15x7 +35
tmontague is offline   Reply With Quote
Old 05-13-2017, 05:18 PM   #12
The_OB_YA-Rice
Toyota Tech
 
The_OB_YA-Rice's Avatar
 
Drives: 2007 Toyota Yaris
Join Date: Apr 2017
Location: New York
Posts: 1
This thread is probably pretty old, but I can almost promise you its the alternator, mine does the same, and I work for Toyota and know that in some yaris' there is a connection in the alternator that can rust and require you to get a new one.
__________________
The best rice. The Ya-rice.
My goal is to be faster than those people in their Hondas and Subarus.
The_OB_YA-Rice is offline   Reply With Quote
Old 05-13-2017, 06:19 PM   #13
WeeYari
 
WeeYari's Avatar
 
Drives: 06 Polar White 5dr, 13 Soul 4u
Join Date: Oct 2008
Location: Georgetown, Ontario, Canada
Posts: 4,489
^ another newbie who doesn't read entire thread. This issue has been resolved.

Sent from my Elite_5_5_Octa using Tapatalk
__________________
WeeYari is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Remote for remote starter draining its own battery. bad DIY / Maintenance / Service 4 11-01-2015 02:00 PM
Battery Warning Light - Different Twist maybe RutherfordmanX DIY / Maintenance / Service 3 06-08-2015 08:59 PM
battery light on and off yariseggvvti DIY / Maintenance / Service 43 05-04-2014 11:18 AM
Charging System Light N9QGS DIY / Maintenance / Service 1 07-26-2010 06:53 PM
Light weight race battery. buddyjim Performance Modifications 24 01-27-2009 09:33 PM


All times are GMT -4. The time now is 01:36 AM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.