Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 10-11-2017, 04:27 PM   #1
yaris2010RS
 
yaris2010RS's Avatar
 
Drives: no-longer-boosted '10 Yaris
Join Date: Nov 2009
Location: Angus, Ontario
Posts: 1,873
ABS sensor brainstorming

Hey inmates,

So I recently changed my CV shaft (last night) due to a torn boot and right after I was done, I got an ABS code.....yay....

so I assume when I was putting the new shaft in, I clobbered the ABS sensor and broke it.

Back story, I also own a 2013 wrangler and need to do speed sensors every few months because Chrysler is garbage.....but anyways they cost like 30 bucks so w.e.

So I got out my trusty ABS code reader (because when you own a jeep you need all the goodies) and found the code to be C1405, which is open circuit/ fault in the front right. which to me solidifies the fact that I clobbered it with the CV shaft.

The problem, the new ABS sensor is about 280 bucks from Toyota (CV shaft from Canadian tire with lifetime warranty was only 140 with tax).....so I don't want to replace it and have it be something silly, im pretty sure with the code c1405 even if I has installed the CV shaft backwards, it still says the issue is with the sensor not the encoder. its been cold and raining all day so I haven't had a chance to pull the sensor and see how it looks or test the circuit.

anyone know of a cheaper alternative to the Toyota ABS sensor? contacted all local wreckers and no one has a yaris in the lot.
__________________
If it has boobs or wheels sooner or later your gonna have problems with it
yaris2010RS is offline   Reply With Quote
Old 10-11-2017, 04:58 PM   #2
WeeYari
 
WeeYari's Avatar
 
Drives: 06 Polar White 5dr, 13 Soul 4u
Join Date: Oct 2008
Location: Georgetown, Ontario, Canada
Posts: 4,704
Quote:
Originally Posted by yaris2010RS View Post
anyone know of a cheaper alternative to the Toyota ABS sensor?
Good old rockauto would be my guess. They seem pretty inexpensive there, even with shipping charges.

Is this what you need?

https://www.rockauto.com/en/catalog/...ed+sensor,1912

Sent from my Elite_5_5_Octa using Tapatalk
__________________
WeeYari is offline   Reply With Quote
Old 10-11-2017, 06:08 PM   #3
tmontague
2zr-fe dream team
 
tmontague's Avatar
 
Drives: 08 Vios M/T, 05 4wd Vibe
Join Date: Oct 2012
Location: Hamilton Ont.
Posts: 1,735
I second rock auto. As a side $140 for lifetime warranty?! Damn, I know where I'm getting my new drivers side cv axle from when it starts making noise. Its spit out a bunch of grease from an obvious torn boot that I can't seem to locate the tear
__________________
2zr swapped Vios, oil catch can, TRD rear sway bar, MI lowering springs, In cabin+under hood SSK, TRD shift knob, HID projector/Halo lights, 10mm rear axle spacers, custom header back exhaust, Front splitter, Sickspeed dual horns, Tokiko Blue's in rear, triple gauges, Whiteline bushings, Sparco pedal covers, Viper Keyless entry, DC Sports CAI, NST u/d crank pulley, solid poly engine mounts, MR Racing Flywheel, Konig Dial Ins 15x7 +35, Hawk HPS pads
tmontague is offline   Reply With Quote
Old 10-12-2017, 10:31 AM   #4
Bluevitz-rs
1NZ-6spd Turbo
 
Bluevitz-rs's Avatar
 
Drives: '05 6-Spd Vitz RS Turbo
Join Date: Oct 2008
Location: Courtice, Ontario, Canada
Posts: 2,883
you did plug it back in right?
Bluevitz-rs is offline   Reply With Quote
Old 10-12-2017, 12:08 PM   #5
Kawiman
 
Drives: 2010 hatch
Join Date: Aug 2017
Location: South Florida
Posts: 17
I recently replaced mine (All 4)And used the $20 Chinese ones on the left and both rears. Funny enough, I found the front right EOM Toyota part for $30. Also on Ebay. It was the same packaging with a Toyota parts decal on it. Also made in China.
The other couple of hundred dollars seems to be pure profit for Toyota............
First pull it out and make sure you didn't just get a glob of grease on it.
Kawiman is offline   Reply With Quote
Old 10-12-2017, 04:11 PM   #6
Lux
 
Lux's Avatar
 
Drives: NCP91
Join Date: Jul 2012
Location: Markham, Ontario, Canada
Posts: 110
C1405 open circuit RH side is usually poor electrical contact or disconnection of the connector. In rare cases, it is also a wire cross.

A damaged, dead, or improperly seated sensor will normally produce C1401 sensor malfunction.

Erratic wafeforms from damaged or misaligned sensor/reluctor ring should have given C1413 output/signal malfunction.

Double check your connector for contact and inspect the sensor head for trauma.
Lux is offline   Reply With Quote
Old 10-13-2017, 04:07 PM   #7
yaris2010RS
 
yaris2010RS's Avatar
 
Drives: no-longer-boosted '10 Yaris
Join Date: Nov 2009
Location: Angus, Ontario
Posts: 1,873
i still have to check it, for reference I did not unplug it when I change the CV shaft, unbolted the knuckle from the strut and it gave me enough room to move the knuckle out of the way and get the cv shaft out/in.

Ill check the connectors, I suppose possibly the wiring was broken but ill have to do a once over before I order the new one.

Thanks WeeYari for the link, that's a better price lol. Ive been debating driving out to the wrecker by you (king auto wrecker or something), they use to have a few yarii on site and ive pillaged many parts from them. no one here in the north seems to have any wrecked Yarii
__________________
If it has boobs or wheels sooner or later your gonna have problems with it
yaris2010RS is offline   Reply With Quote
Old 10-13-2017, 04:27 PM   #8
Bluevitz-rs
1NZ-6spd Turbo
 
Bluevitz-rs's Avatar
 
Drives: '05 6-Spd Vitz RS Turbo
Join Date: Oct 2008
Location: Courtice, Ontario, Canada
Posts: 2,883
Chances are you broke a wire in it by not disconnecting it.
Bluevitz-rs is offline   Reply With Quote
Old 10-13-2017, 05:34 PM   #9
WeeYari
 
WeeYari's Avatar
 
Drives: 06 Polar White 5dr, 13 Soul 4u
Join Date: Oct 2008
Location: Georgetown, Ontario, Canada
Posts: 4,704
Don't know of any king-something auto wreckers. There was a Mega City real close to me but that was ordered shut down a few years back.

Sent from my Elite_5_5_Octa using Tapatalk
__________________
WeeYari is offline   Reply With Quote
Old 10-15-2017, 10:09 AM   #10
yaris2010RS
 
yaris2010RS's Avatar
 
Drives: no-longer-boosted '10 Yaris
Join Date: Nov 2009
Location: Angus, Ontario
Posts: 1,873
ah mega city, that was the one I was talking about. crap really it closed? that was the best Upick lot in the GTA.

Makes sense it closed. it was an environmental hazard lol.
__________________
If it has boobs or wheels sooner or later your gonna have problems with it
yaris2010RS is offline   Reply With Quote
Old 10-15-2017, 10:53 AM   #11
Bluevitz-rs
1NZ-6spd Turbo
 
Bluevitz-rs's Avatar
 
Drives: '05 6-Spd Vitz RS Turbo
Join Date: Oct 2008
Location: Courtice, Ontario, Canada
Posts: 2,883
Cookstown Auto is pretty good
Bluevitz-rs is offline   Reply With Quote
Old Today, 08:32 AM   #12
yaris2010RS
 
yaris2010RS's Avatar
 
Drives: no-longer-boosted '10 Yaris
Join Date: Nov 2009
Location: Angus, Ontario
Posts: 1,873
ended up testing the ABS sensor and having no resistance, possibly a broken wire inside. swapped it out and now it works great!

also had to do the rear wheel bearing (had some play), rear shoes, and the swaybar end links.

for a 2010 with almost 300k, bearing came out like butter, rear drums came off with no issue and the shoes were possibly original and they wernt seized either. Love my Toyota
__________________
If it has boobs or wheels sooner or later your gonna have problems with it
yaris2010RS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
First Generation Vitz ABS Issue Owais Yunus DIY / Maintenance / Service 0 10-29-2016 11:14 AM
ABS !!! wassimusa DIY / Maintenance / Service 3 06-03-2016 07:15 AM
Noise From ABS when Braking + ABS & (!) Light On - Please Help Chris Jackson DIY / Maintenance / Service 2 04-23-2016 12:00 AM
ABS brakes / Would you buy a Yaris without them? 3cyltrbo General Yaris / Vitz Discussion 74 03-26-2011 08:21 PM
What's with ABS? jgag123 Canada 11 01-01-2009 07:04 PM


All times are GMT -4. The time now is 11:53 PM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.