Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 12-08-2008, 11:33 AM   #1
mizhgolightly
I've made a post!
 
Drives: Yaris 2007
Join Date: Dec 2008
Location: Toronto, Ontario
Posts: 1
Cool HELP! ABS & BRAKE LIGHT ON SIMULTANEOUSLY!

I have a 2007 Yaris which I just bought less than two years ago and yesterday when I started the car the brake light & ABS brake light went on simultaneously. The speedometer is working fine. There was an incident 2 days ago when I was driving and an ambulance ran a red light but didn't turn its siren on so I had to brake very hard and abruptly which made the brakes screech a bit.....also, there is alot of snow here right now so I'm not sure if that affects anything? I have winter tires....but I was just wondering a couple of things:

-what could possibly be the problem?
-will it be expensive to fix? If so, approximately how much?
-I have the toyota extra care protection - will this cover it?
-is it still safe to drive around the city in it? I have an appointment at my Toyota dealer in three days but I need to run some errands with my car before then....

PS. I don't know ANYTHING about cars....
mizhgolightly is offline   Reply With Quote
Old 12-08-2008, 11:43 AM   #2
voodoo22
 
Drives: Yaris Sedan (auto)
Join Date: Jun 2007
Location: Toronto, Ontario
Posts: 544
Check out this thread in the Canada forum

http://www.yarisworld.com/forums/showthread.php?t=11533
__________________
voodoo22 is offline   Reply With Quote
Old 12-08-2008, 03:40 PM   #3
PetersRedYaris
 
PetersRedYaris's Avatar
 
Drives: 2005 Scion xB
Join Date: Nov 2006
Location: The Black Hills of South Dakota
Posts: 1,061
Check the level of the fluid in the reservoir, if it's full and your brake pedal is firm (as in normal, it hasn't gone soft or squishy), I'd say your safe to drive it...
PetersRedYaris is offline   Reply With Quote
Old 12-08-2008, 10:08 PM   #4
tetzyamis
'09 5dr
 
tetzyamis's Avatar
 
Drives: 2009 Yaris 5-Door Bayou Blue
Join Date: Oct 2008
Location: HI
Posts: 239
ABS light of my 2003 Corolla went on when both of the tail lights were out.
Brake light of my 2001 Prius went on when the brake oil was low.
Yours probably is caused by something else if it happened after you braking hard, but just FYI.
__________________
2009 5-Door Yaris LB Bayou Blue Pearl
2009 5-Door Yaris LB Black Sand Pearl
tetzyamis is offline   Reply With Quote
Old 12-14-2008, 01:39 AM   #5
Jem_hadar
MORDSITH
 
Jem_hadar's Avatar
 
Drives: 2007 Yaris Hatchback
Join Date: Apr 2006
Location: Collingwood, ON
Posts: 632
Send a message via ICQ to Jem_hadar
Quote:
Originally Posted by voodoo22 View Post
Check out this thread in the Canada forum

http://www.yarisworld.com/forums/showthread.php?t=11533
!!!!

Check this thread.


Jem
__________________
2007 Yaris Hatchback 5 Door LE, Manual, Package B, Bayou Blue Metallic
Jem_hadar is offline   Reply With Quote
Old 12-15-2010, 10:22 AM   #6
mleon4740
 
Drives: 2007 Yaris Sedan
Join Date: Dec 2010
Location: Newmarket
Posts: 2
Guys... here a new dissatisfied Toyota 2007 Yaris customer, had the ABS and Emergency Brake lights ON since yesterday, my warranty expired six months ago, has anyone heard of a change in Toyota's response to this type of problems?
mleon4740 is offline   Reply With Quote
Old 12-15-2010, 10:31 AM   #7
JBougie
Banned
 
JBougie's Avatar
 
Drives: 2010 Yaris LB (Prev: 07 Sedan)
Join Date: Mar 2009
Location: Beech Bluff, TN
Posts: 1,293
Why would you be a dissatisfied Toyota customer if you have a 2007 and the ABS and EBrake light just came on yesterday?
JBougie is offline   Reply With Quote
Old 12-15-2010, 03:33 PM   #8
41magmag41
 
Drives: Loaded 2007 mica silver sedan
Join Date: Sep 2007
Location: New hampshire
Posts: 226
Had the same problem with my 2007 sedan at about 75000 miles. It was winter time and the brake and ABS lite came on, but went out a day or so later. About two weeks later the same thing happened and both lites stayed on. I took it to the dealer and was told the abs wiring harrness and sensors on the rear tires were corroaded and shorting out the system. It took the dealer 7 weeks to get the replacement parts to fix the car and the cost was about 700 PER tire on the rear, i.e. 1400.00 dollars, to replace the sensors and wiring harness. I was lucky enough that I had purchased the toyota 100,000 mile warranty on the car and got the work done for nothing.

Toyota is aware of the problem and has know about the problem since 2008 with the ABS on the yaris and has refused to issue a recall. There is a TSB on the issue but only if the customer calls attention to it within the warranty period. Do a quick search at this site and you can get the TSB number as well as a lenghthy thread on this very issue.
41magmag41 is offline   Reply With Quote
Old 01-17-2011, 11:43 PM   #9
lrondeau
I've made a post!
 
Drives: Yariz 2007
Join Date: Jan 2011
Location: Québec, Canada
Posts: 1
Happened to me too

Happened once last winter and almost every day since the beginning of this winter.

Both break and ABS lights have been turning on when weather is -10C and off after driving a few kms and the car is warm. I sometimes hear weird noises like something is detached in the back wheels.

I thought my snow tires were lousy and was sometimes having a hard time engaging first gear and today, the lady in the car behind me notified me that my right wheel at the back was locked ! Driving on snow and ice, I didn't realize it. I turned around and went directly to the dealer. They didn't seem too concerned but I'm wondering what would have happened had I been on the highway, driving at 100kms instead of on a country road at 40km?

I'm a rental at 60,800 kms and 3years and 10 months so not on the warranty anymore. Dealer has offered to pay part of the bill but I still have to fork out 500$. I have to get the repairs done before I return the car next year.

But the parts are back ordered. They can't get them anywhere - Ontario or California (they say). They disconnected the ABS brakes and ordered the part. Now boht lights are on continuously. How do I know that everything is safe? I am loosing faith in Toyota!

I am definitely filing a complaint with Transport Canada.
lrondeau is offline   Reply With Quote
Old 01-18-2011, 10:17 AM   #10
swidd
 
Drives: Yaris HB
Join Date: Jul 2007
Location: Central Alabama, GOD BLESS AMERICA
Posts: 757
Check the stop light switch on top of the brake pedal, you only have to remove the cover under the steering wheel. Place a piece of tape on top of the pin that gets pushed by the pedal, or wrap tape on top of the pedal thing. Problem solved. Its just a lose switch.
swidd is offline   Reply With Quote
Old 01-18-2011, 05:32 PM   #11
brg88tx
 
Drives: 07 Yaris Sedan, Auto
Join Date: Jun 2010
Location: SE Texas
Posts: 318
yet another reason i'm glad i got a bare bones yaris. less crap to break.
brg88tx is offline   Reply With Quote
Old 01-26-2011, 09:07 AM   #12
bcolwill
 
Drives: 2007 Yaris 4DR Hatchback
Join Date: Feb 2010
Location: Toronto, Canada
Posts: 3
Possible Resolution

I have a 2007 Yaris which I purchased from my mother-in-law in December 2009 with only 3500 KM on it. Not long after I had the same problem as many here. Brake lights on and disabled ABS when driving in salt & slush. I was able to obtain the code pointing to a rear speed sensor. This past summer I purchased some dielectric grease at CDN Tire, removed the connectors at the rear wheels, filled the stationary end full of the grease and plugged them back in. Since I have done that I have yet to see the problem appear again.
bcolwill is offline   Reply With Quote
Old 12-31-2012, 05:10 PM   #13
chr1s
 
Drives: Toyota Yaris
Join Date: Dec 2012
Location: Cookstown, Ontario
Posts: 3
How to remove the rear wheel ABS connector

Hi all,

I've got the dreaded ABS light and Brake light illuminated together...
I've managed to remove the outer cover for the sensor plug but i can't get the actual plug off. Does anyone know how this connector comes off?
chr1s is offline   Reply With Quote
Old 12-31-2012, 05:34 PM   #14
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 11,450
Quote:
Originally Posted by chr1s View Post
Hi all,

I've got the dreaded ABS light and Brake light illuminated together...
I've managed to remove the outer cover for the sensor plug but i can't get the actual plug off. Does anyone know how this connector comes off?
With the outer cover off, just squeeze the back part of the flat side and pull.
CTScott is online now   Reply With Quote
Old 01-02-2013, 06:52 PM   #15
chr1s
 
Drives: Toyota Yaris
Join Date: Dec 2012
Location: Cookstown, Ontario
Posts: 3
Quote:
Originally Posted by CTScott View Post
With the outer cover off, just squeeze the back part of the flat side and pull.
Got them both off, thank you.
The nearside is humped...the pin has broken off and is stuck in the connector so will need to replace both the male and female ends...wonder how much this wil cost
chr1s is offline   Reply With Quote
Old 02-06-2013, 09:01 AM   #16
mkegmn
I've made a post!
 
Drives: 2007 Toyota Yaris 4 Door
Join Date: Feb 2013
Location: Indianapolis, IN
Posts: 1
My wife came home last night and said that when she left work, her ABS and Brake light came on. She didn't notice a difference in the way the car was driving until she was almost home. She said that when she was just a few blocks from the house, when she tried to stop, the ABS instantly engauged which made it almost impossible to stop, also, the speedometer was stuck at 20. It only done it once, she had stopped at a gas station cause it scared her. She turned the car off and let it sit for a minute and then restarted it, which helped with the ABS engauging instantly. When she restarted it, the lights went out but as she was driving, they came back on but no issues with stopping. When she got home, I went to drive it to see if I could try figure it out. When I started it, the lights were on. I went and drove it around the block and I kinda crammed the breaks a couple times, not too hard and the lights went out and have been out ever since.

I used to work for one of the biggest dealerships here in Indianapolis and from working in the shop, I dealt with a lot of techs. One big thing they told me and I have seen for myself, is, gunk and buildup can coat one or more of the sensors and keep them from reading correctly, hense, the ABS and Brake light. We have been having alot of snow, ice, etc. We have lots of salt that has been thrown on our roads and alot of buildup. If this happens to you, it would be a good idea to take your car through a good carwash and a heavy pressurized underbody, I prefer Mike's Car Wash, to clean the undercarriage and get those sensors cleaned off. We are supposed to get rain within the next day or so, so I'm hoping with that, it will clean the buildup off. I hope this helps!
mkegmn is offline   Reply With Quote
Old 01-15-2014, 12:34 PM   #17
vk2193
 
Drives: 2008 Toyota Yaris Sedan
Join Date: Jan 2014
Location: Calgary, AB
Posts: 2
Hey guys, i've got the same problem, ABS and Brake light came on on one snowy day... after reading ur comments i took my yaris sedan 2008 to the mechanic, he cleaned the connections and the light came off... i left my mechanic's parking lot and the the lights came on again! i came back he looked at it and said drive for one week look how it goes and if problem is still there come back. i came home and ht lights came off!!! not sure what the problem is, i will try to wash the underbody of the car, i never washed it there before...
vk2193 is offline   Reply With Quote
Old 01-15-2014, 12:35 PM   #18
vk2193
 
Drives: 2008 Toyota Yaris Sedan
Join Date: Jan 2014
Location: Calgary, AB
Posts: 2
ABS and Brake light

Hey guys, i've got the same problem, ABS and Brake light came on on one snowy day... after reading ur comments i took my yaris sedan 2008 to the mechanic, he cleaned the connections and the light came off... i left my mechanic's parking lot and the the lights came on again! i came back he looked at it and said drive for one week look how it goes and if problem is still there come back. i came home and ht lights came off!!! not sure what the problem is, i will try to wash the underbody of the car, i never washed it there before...
vk2193 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY (08' USDM Liftback): ESUSE Fog Light Install v2.0 goku87 DIY / Maintenance / Service 117 09-11-2014 02:08 AM
Installing Trailer Light Harness vandallen DIY / Maintenance / Service 6 04-25-2009 08:11 PM
Trouble putting 3rd brake light after rear speaker install..... YarisSedan In Car Entertainment + Electronics (audio / video / alarm) 5 12-05-2008 04:10 AM
DIY:Day time running light Disabled with stock fog light remain function summergxz DIY / Maintenance / Service 12 09-26-2007 10:42 AM
Removing third brake light lightyearsgirl DIY / Maintenance / Service 8 08-06-2006 11:26 AM


All times are GMT -4. The time now is 01:51 PM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.