Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Second Generation Toyota Yaris Main Rooms > General Yaris / Vitz Discussion
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 10-19-2010, 03:54 PM   #1
zimso
I've made a post!
 
Drives: Yaris Cool
Join Date: Oct 2010
Location: Germany
Posts: 1
Low engine coolant temperature indicator light -> stays on for 5 minutes... normal ?

Hello,

I have a brand new Yaris 1.0.
When I start the engine the "Low engine coolant temperature indicator light"
stays on for about 4-5 minutes till it turns off.

Is this behaviour normal ? Shouldn't it turn off very shortly after the
engine has been started ?

We have about 54F/12C here....

I'm used that this display turns off really fast after engine has been
started from other cars, is this different with Toyota ?

Thanks
Tim
zimso is offline   Reply With Quote
Old 10-19-2010, 04:00 PM   #2
WeeYari
 
WeeYari's Avatar
 
Drives: 2006 Polar White 5dr
Join Date: Oct 2008
Location: Georgetown, Ontario, Canada
Posts: 3,021
Short and simple answer - Normal.

This question gets asked a couple times a year from noobs. Welcome to YW and enjoy your stay with us.
__________________
WeeYari is offline   Reply With Quote
Old 10-19-2010, 04:17 PM   #3
BLH
 
Drives: 2007 Yaris Sedan
Join Date: Apr 2009
Location: CT
Posts: 198
On my 2007 it will stay on until my Scanguage says the water temperature is 130 degrees F.
BLH is offline   Reply With Quote
Old 10-19-2010, 07:17 PM   #4
DebbyM46227
 
DebbyM46227's Avatar
 
Drives: 2010 LB, 5 Speed, Carmine Red
Join Date: Jun 2010
Location: Indianapolis
Posts: 464
Yes, normal, especially since the weather has gotten cooler lately. It's around 40F when I leave in the morning now.
DebbyM46227 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help ASAP!!!! low coolant indicator MeggiemobileSFLA DIY / Maintenance / Service 29 08-03-2013 01:09 AM
A Mystery Oi'll Say! Yar Is Word Fuel Economy Forum 16 05-11-2013 04:22 AM
Zage Turbo Kit Install - Toyota Yaris Focus_Sh1ft Forced Induction Forum 135 05-01-2013 04:42 PM
The Nitrous Thread ChinoCharles Performance Modifications 113 02-06-2012 01:05 PM
Engine Coolant Temperature djino General Yaris / Vitz Discussion 18 07-16-2007 12:26 AM


All times are GMT -4. The time now is 04:07 PM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.