Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > Performance Modifications
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 01-09-2012, 10:52 PM   #1
JohnnyMalice
 
Drives: 2007 Toyota Yaris 4 door sedan
Join Date: Jan 2012
Location: North Bay, Ca
Posts: 19
Cold air intake....check engine light on...???

Hey guys, first post on here. I have a 2007 Yaris and tonight I jsut put in a cold air intake. after I started up my car, the check engine light came on. Any secrets? or any reason why this is happening?! any input would be most appreciated.
JohnnyMalice is offline   Reply With Quote
Old 01-10-2012, 02:23 AM   #2
cali yaris
ULTIMATE
 
cali yaris's Avatar
 
Drives: 07 Yaris Turbo
Join Date: May 2007
Location: Canoga Park, CA
Posts: 14,864
Send a message via AIM to cali yaris
1. did you disconnect the battery so the ECU would "relearn" after your install?
2. were you extremely careful with your MAF sensor? 95% of the time this area is the cause of CELs with a CAI install.

Most important: which product did you install and where did you get it?
__________________
357 whp @ 24psi on pump gas!
www.MicroImageOnline.com
cali yaris is offline   Reply With Quote
Old 01-10-2012, 03:26 AM   #3
Kaotic Lazagna
 
Kaotic Lazagna's Avatar
 
Drives: '14 GT86
Join Date: Dec 2006
Location: Bay Area, CA
Posts: 9,210
Make sure all hoses and connectors are connected. I accidentally left the EGR valve connector (I think that's what it was) disconnected and that was the cause of my CEL. Can you get it scanned and report back was the code is?
__________________
Kaotic Lazagna is offline   Reply With Quote
Old 01-10-2012, 03:28 AM   #4
Kaotic Lazagna
 
Kaotic Lazagna's Avatar
 
Drives: '14 GT86
Join Date: Dec 2006
Location: Bay Area, CA
Posts: 9,210
Try disconnecting your battery, pump the brakes until you can't anymore, reconnect the battery AFTER 30 minutes, and start the engine and let the car idle for 10 minutes (don't rev the engine).
__________________
Kaotic Lazagna is offline   Reply With Quote
Old 04-29-2012, 09:46 PM   #5
JohnnyMalice
 
Drives: 2007 Toyota Yaris 4 door sedan
Join Date: Jan 2012
Location: North Bay, Ca
Posts: 19
Hey guys sorry it took so long, My computer has been down and my phone doesnt seem to like this page LOL

Well after I did the battery disconnect it went away, but I think I want to replace my MAF anyways. Its just a off the wall (or internet) CAI. I customized it so it would sit down further in the wheel well but not too far down to where id suck up water in puddles.
JohnnyMalice is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
AEM cold air intake vs Afe intake... djgab101 Performance Modifications 69 04-28-2013 02:03 PM
Changing to cold air intake and insurance problem ExtremeCold Fuel Economy Forum 7 04-24-2011 07:20 PM
NEED ENGINE CHECK LIGHT CODE LIST Attitude Forced Induction Forum 12 04-11-2011 06:38 PM
FS: AFE Air Intake System (Cold Air Intake) jjbG35yaris Items for Sale by private party 7 04-01-2011 02:58 PM
HELP! Have I killed some sensor? NO POWER AFTER Headers and Cold Air Intake pasapaca Performance Modifications 7 02-07-2011 10:58 PM


All times are GMT -4. The time now is 10:29 PM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.