Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 02-25-2018, 06:16 PM   #1
zoidberg444
 
zoidberg444's Avatar
 
Drives: Yaris 06 - 5dr hatchback
Join Date: Aug 2015
Location: Birmingham, UK
Posts: 226
ABS faults C0210 & C1238

On Friday when I left my house I had some brief unwanted ABS activation before the ABS and (!) lights came on. Plugged my scanner in and got these codes.




The last one seems a little odd to me. Isn't the rear ABS sensor on the Yaris sealed inside the bearing?



In any case. The live data seems to suggest that there is no joy from the RR ABS sensor. I'm going to test for signal output with my oscilloscope and check the wiring and connections but it looks like it might be pooched.

Not really very happy because my guess is the rear bearing and speed sensor is probably the best part of 300 from the dealer but we'll see. Maybe its just a wiring problem or there is some crust in a connector.

Anyone else in the hive mind have any experiences with this?
__________________
- Yaris 2006, 1.0, 5 door hatchback "Betty" - 150,000 miles
UK to Nordkapp in a Yaris
zoidberg444 is offline   Reply With Quote
Old 02-25-2018, 09:36 PM   #2
tmontague
 
tmontague's Avatar
 
Drives: '08 2zr swapped Vios M/T
Join Date: Oct 2012
Location: Hamilton Ont.
Posts: 2,065
The sensor is sealed inside the bearing as I recall. I would clean the connector with come electrical cleaner and then throw some dielectric grease in there. Clear the codes and see if it comes back. If it does then I'd get the harness first and if that doesn't fix it then replace the bearing assembly. Unless your bearings are already worn then change those first.

I don't think there is a way to know if it's the bearing side or wire side that is at fault, other than testing for resistance
__________________
I like to drive a slow car fast...
tmontague is offline   Reply With Quote
Old 02-26-2018, 04:16 AM   #3
komichal
 
Drives: Yaris 2007 1.3 2SZFE 64kW
Join Date: May 2012
Location: CZ
Posts: 89
I was told that rear right ABS malfunction is a typical problem of Yaris. I had it too.
The ABS sensor is insufficiently covered and suffers until it dies eventually.
Usually when you try to disconnect the wiring it falls apart too, totally rotted. Therefore the harness needs to be replaced as well.
It happened to me a few months after I bought my used Yaris. I was under time pressure so I had to ask the authorized servicing center to take care of this. 340 USD.
komichal is offline   Reply With Quote
Old 02-27-2018, 07:39 AM   #4
zoidberg444
 
zoidberg444's Avatar
 
Drives: Yaris 06 - 5dr hatchback
Join Date: Aug 2015
Location: Birmingham, UK
Posts: 226
Thanks for the suggestions chaps. The UK is currently in the grip of the "beast from the east" and its to cold and snowy for working on the car outside of an emergency. I will update in a few weeks as to what the problem was exactly.
__________________
- Yaris 2006, 1.0, 5 door hatchback "Betty" - 150,000 miles
UK to Nordkapp in a Yaris
zoidberg444 is offline   Reply With Quote
Old 02-28-2018, 01:50 PM   #5
400 dollar yaris
 
400 dollar yaris's Avatar
 
Drives: 2007 Yaris sedan
Join Date: Nov 2011
Location: dayton, ohio
Posts: 64
actually got a c0215 code this morning myself. clean with contact cleaner, check the wires that lead from the back of the car into the speed sensor for damage also. could be damaged somewhere along the line. also try erasing the code and see if it comes back, connection at the sensor could have been jarred loose by a bump in the road. good luck.
400 dollar yaris is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ABS sensor brainstorming yaris2010RS DIY / Maintenance / Service 11 10-23-2017 08:32 AM
First Generation Vitz ABS Issue Owais Yunus DIY / Maintenance / Service 0 10-29-2016 11:14 AM
ABS module and light reset 07 Yaris (sedan) DevilzMafia DIY / Maintenance / Service 6 10-02-2016 11:48 AM
Noise From ABS when Braking + ABS & (!) Light On - Please Help Chris Jackson DIY / Maintenance / Service 2 04-23-2016 12:00 AM
What's with ABS? jgag123 Canada 11 01-01-2009 07:04 PM


All times are GMT -4. The time now is 11:44 AM.




YarisWorld
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.