Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 11-13-2012, 12:26 PM   #1
danrachita
 
Drives: YARIS
Join Date: Nov 2012
Location: Romania
Posts: 7
Yaris 2012 door lock-unlock problem

Hi.
I have one Toyota Yaris from 2012 and i have problem with door locks.
Dont work from driver door key and when i press from remote lock nothing happend.
When i press unlock just lights flicker but doors dont unlock.
Please if anyone can help with door lock system diagram for this car or have any sugestion about.
Thank you.
BR.
danrachita is offline   Reply With Quote
Old 11-13-2012, 04:39 PM   #2
1NZYaris1
 
1NZYaris1's Avatar
 
Drives: Yaris
Join Date: Oct 2008
Location: New Zealand
Posts: 2,598
1 of your doors or hatch is not closed properly
1NZYaris1 is offline   Reply With Quote
Old 11-13-2012, 04:44 PM   #3
danrachita
 
Drives: YARIS
Join Date: Nov 2012
Location: Romania
Posts: 7
Thanks for answer my friend.
Your answer is very good but unfortunatelly for me this is not the reason of malfunction.
All doors are closed and hatch i cant open anymore.
It is sure some serious problem and i supose only some diagram can help me.
BR.
danrachita is offline   Reply With Quote
Old 11-13-2012, 05:09 PM   #4
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,478
There are seven fuses related to the door lock control. I would start with checking the 25A D/L and 25A D/L No. 2 fuses, since the flashing lights indicated that the system is receiving the command to unlock and is trying to do so. Those two fuses actually drive the door lock actuators.
__________________
CTScott is offline   Reply With Quote
Old 11-13-2012, 05:18 PM   #5
danrachita
 
Drives: YARIS
Join Date: Nov 2012
Location: Romania
Posts: 7
Thank you Sir for answer.
Can you eplain please where are situated that fuses because i dont found that panel thats why i ask for an manual or diagram?
BR.
danrachita is offline   Reply With Quote
Old 11-13-2012, 05:26 PM   #6
danrachita
 
Drives: YARIS
Join Date: Nov 2012
Location: Romania
Posts: 7
I found where are that fuses but if i remmber i check both of them and are ok.
I will check again but if they are ok what other reason can be?
Thank you.
BR.
danrachita is offline   Reply With Quote
Old 11-13-2012, 06:14 PM   #7
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,478
Quote:
Originally Posted by danrachita View Post
I found where are that fuses but if i remmber i check both of them and are ok.
I will check again but if they are ok what other reason can be?
Thank you.
BR.
It could be something like what Ray (1NZYaris) said above, where the system is in an incorrect state. You could try disconnecting the battery for a couple of minutes to reset the Body ECU, which controls the door lock functions.
__________________
CTScott is offline   Reply With Quote
Old 11-14-2012, 02:37 PM   #8
danrachita
 
Drives: YARIS
Join Date: Nov 2012
Location: Romania
Posts: 7
Hi.
I didnt solve yet door lock-unlock problem.
Please if you can explain to me what fuses are responsable for good work of door look system.
And if is posibile to found some diagram to check actuators from doors and hatch.
After measuremnt i found an yelow wire in connector for doors in left side where resistance must be under 1 ohm but is around 8 ohms and i supose comparing with other diagrams this wire is comand driver door actuator and is not looking well.
Thank you.
BR.
danrachita is offline   Reply With Quote
Old 11-14-2012, 04:58 PM   #9
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,478
I don't have the service manual for the 2012 European Yaris, but I do have the wiring diagrams.

The fuses used by the door lock system are: 25A D/L, 25A D/L No.2, 15A DOME, 5A ECU-B, 5A ECU-B No.2, 5A ECU-IG No.1, and 5A ACC.

On the drivers door there are two larger wires for the door lock motor - A yellow and a pink wire. The Body ECU switches the polarity on those wires to drive the lock to the locked position (yellow = +12 volts, Pink = Ground) or unlocked position (yellow = Ground, Pink = +12 volts). The Body ECU pulses them for a short time (~0.5 seconds) and then stops the feed to them, so to measure you will have to put one lead of the meter on pink and the other on yellow and then keep switch between locked and unlocked. You should see a brief flash on the meter to +12 volts in one direction and -12 volts in the other direction.
__________________
CTScott is offline   Reply With Quote
Old 11-14-2012, 05:03 PM   #10
danrachita
 
Drives: YARIS
Join Date: Nov 2012
Location: Romania
Posts: 7
Thank you Sir for this professional answer.
I will check tomorow all that fuses and if voltage come from ECU and i wil post result.
Thank you.
BR.
danrachita is offline   Reply With Quote
Old 11-15-2012, 01:41 PM   #11
danrachita
 
Drives: YARIS
Join Date: Nov 2012
Location: Romania
Posts: 7
Thank you Sir.
I solve the problem by replacing 25A D/L fuse.
Thank you.
BR.
danrachita is offline   Reply With Quote
Old 12-12-2012, 02:45 PM   #12
hatchbackkid82
 
hatchbackkid82's Avatar
 
Drives: 2007 Toyota Yaris Hatchback
Join Date: Apr 2007
Location: Takoma Park, MD
Posts: 1,831
Send a message via AIM to hatchbackkid82
I'm having the same problem as well on 2010 sedan. I've checked all my fuses that are related to the door locks and nothing. They are all fine, I use the keyless entry and it only unlocks the driver's side, the lights still fash when when I lock or unlock it. Any suggestions, I 'm ready to lose my mind over this
hatchbackkid82 is offline   Reply With Quote
Old 12-12-2012, 05:17 PM   #13
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,478
Quote:
Originally Posted by hatchbackkid82 View Post
I'm having the same problem as well on 2010 sedan. I've checked all my fuses that are related to the door locks and nothing. They are all fine, I use the keyless entry and it only unlocks the driver's side, the lights still fash when when I lock or unlock it. Any suggestions, I 'm ready to lose my mind over this
Do you have OEM keyless or aftermarket?
__________________
CTScott is offline   Reply With Quote
Old 12-13-2012, 09:29 AM   #14
hatchbackkid82
 
hatchbackkid82's Avatar
 
Drives: 2007 Toyota Yaris Hatchback
Join Date: Apr 2007
Location: Takoma Park, MD
Posts: 1,831
Send a message via AIM to hatchbackkid82
OEM Keyless
hatchbackkid82 is offline   Reply With Quote
Old 12-13-2012, 09:55 AM   #15
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,478
Quote:
Originally Posted by hatchbackkid82 View Post
OEM Keyless
If you press the unlock button twice, do the others then unlock?
__________________
CTScott is offline   Reply With Quote
Old 12-13-2012, 05:09 PM   #16
hatchbackkid82
 
hatchbackkid82's Avatar
 
Drives: 2007 Toyota Yaris Hatchback
Join Date: Apr 2007
Location: Takoma Park, MD
Posts: 1,831
Send a message via AIM to hatchbackkid82
just the driver's side, the passenger side did unlock sporadically now they just don't work at all
hatchbackkid82 is offline   Reply With Quote
Old 12-13-2012, 05:16 PM   #17
CTScott
ULTIMATE
 
CTScott's Avatar
 
Drives: 09 5dr LB, 2x 08 3dr LB
Join Date: Oct 2008
Location: USA, CT
Posts: 13,478
Quote:
Originally Posted by hatchbackkid82 View Post
just the driver's side, the passenger side did unlock sporadically now they just don't work at all
In that case, I would suspect the actual door lock actuator, if it is just the passenger door, and if it is all but the driver's that doesn't work, then I would suspect the relay within the body ECU (non really user replaceable) that drives the other three doors.
__________________
CTScott is offline   Reply With Quote
Old 12-13-2012, 11:27 PM   #18
DanMC
 
Drives: 2012 Toyota Yaris
Join Date: Sep 2012
Location: Canada
Posts: 100
Quote:
Originally Posted by danrachita View Post
Thank you Sir.
I solve the problem by replacing 25A D/L fuse.
Thank you.
BR.
Salut, ai rezolvat problema cu usiile ?...si noi avem o '12 si daca te pot ajuta cu ceva doar spune !
Dan
DanMC is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2012 Yaris SE Stuff computerlove87 Willing to Buy by private party 0 11-25-2011 03:06 PM
'54 T2 Yaris 1.0 VVTi automatic clutch / gearbox / starting problem Lettuce UK 0 09-30-2010 07:21 AM
NEWS: TOYOTA REVEALS ALL-NEW YARIS SEDAN AT 2006 LOS ANGELES AUTO SHOW VitzBoy General Yaris / Vitz Discussion 5 09-05-2010 09:53 PM
2007 Yaris Pricing Info ! YarisBueller New YARIS Purchase Forum 104 06-24-2009 05:54 PM


All times are GMT -4. The time now is 03:57 AM.




YarisWorld
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.