Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 04-20-2022, 09:27 AM   #1
Bramley
 
Drives: '57 Toyota Yaris TR VVT-i
Join Date: Apr 2022
Location: Dorset
Posts: 3
Charging light on, no horn, no indicators

Hi I'm new to this forum, my son has a 2007 Yaris TR. The car has been parked up for several month while he has been at University. I charged the battery to get the car started, it started immediately but the battery charging light stayed on and the indicators and horn do not work now. The hazard lights are working. Any ideas anyone. Thank you.
Bramley is offline   Reply With Quote
Old 04-20-2022, 07:30 PM   #2
ex-x-fire
 
Drives: 2010 yaris 3 door hatch
Join Date: Jun 2013
Location: Sheboygan Falls, Wi.
Posts: 417
Maybe try unhooking the battery to clear things. Then hook it back up and try it out.
ex-x-fire is offline   Reply With Quote
Old 04-21-2022, 02:59 AM   #3
Bramley
 
Drives: '57 Toyota Yaris TR VVT-i
Join Date: Apr 2022
Location: Dorset
Posts: 3
Charging light on, no horn, no indicators

Hi thank you, have tried that already - it made no difference.
Thanks for your imput
Bramley
Bramley is offline   Reply With Quote
Old 04-21-2022, 03:53 AM   #4
NYC-SE
 
NYC-SE's Avatar
 
Drives: 2014 Yaris SE
Join Date: Apr 2014
Location: NYC
Posts: 1,038
There's a fuse blown somewhere.
NYC-SE is offline   Reply With Quote
Old 04-21-2022, 08:41 AM   #5
Bramley
 
Drives: '57 Toyota Yaris TR VVT-i
Join Date: Apr 2022
Location: Dorset
Posts: 3
Charging light on, no horn, no indicators

Hi, thanks for your reply. I checked all fuses under the bonnet - all good. Do you think it may be one of the ones under the dashboard. I'm pretty the alternator is not charging although the car is starting ok for the time being - when the engine is running and the negative battery lead is removed the engine stops. Could it be the alternator that is done - but why no horn or turn indicators? Can't figure it out and the alternator looks like a real mare to take off just to check.
Thanks
Bramley is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken Horn FIXED! zerosl DIY / Maintenance / Service 0 10-10-2017 03:14 PM
Tail light parking light & license plate stop working SIRAY2 General Yaris / Vitz Discussion 1 06-03-2017 02:59 PM
yaris 2009 charging light problem ASEMX1 DIY / Maintenance / Service 1 02-13-2015 08:33 PM
Toyota Yaris Battery Light On - Repair gabo General Yaris / Vitz Discussion 1 08-24-2011 07:21 AM


All times are GMT -4. The time now is 04:46 PM.




YarisWorld
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.