Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 06-03-2024, 09:51 PM   #1
Guyon
 
Drives: 2009 Toyota Yaris 5MT
Join Date: Jul 2021
Location: Richmond, VA
Posts: 2
Question 2009 Yaris Hatch (XP90) Low Beams not coming on

Hey all,

Hoping someone can provide some insight on my low beam headlight failure. I noticed one day a couple weeks ago that the low beams were not actually coming on. The headlight indicator appears on the dash and the control backlighting come on, but the headlights do not, only the parking bulbs.

Pictured: Headlights on (left)/Headlights on + high beam (right, there is no difference aside from the lights actually turning on)


The high beams do turn on, but surprisingly the high beam light on the dash does not illuminate. This led me to believe that the headlight switch was bad so I replaced it, but unfortunately have no change in outcome.

Pictured: Headlights on, high beams off. Only parking lights on.


After reading many forum topics (including this excellent thread) I figured I may have a bad headlight relay (the one in the engine bay relay box). I replaced this too, but again, no result. Perhaps one hint is that there doesn't appear to be any difference whether this headlight relay is installed or not.

The relay I replaced lives in the little box labelled #2 (I do not have DRLs so I do not have the box labelled #3)

Diagram courtesy of this page.

Any help is appreciated. Thanks!

Last edited by Guyon; 06-03-2024 at 10:34 PM.
Guyon is offline   Reply With Quote
Old 06-04-2024, 03:28 AM   #2
dkwilfert
 
Drives: 2008 Yaris 2-Door (White)
Join Date: Jan 2014
Location: Knoxville, TN
Posts: 14
I would start with the simple stuff. Headlight bulbs first, then voltage at the headlight bulb sockets, and back up the wiring diagram from there.
dkwilfert is offline   Reply With Quote
Old 06-04-2024, 08:10 AM   #3
WeeYari
 
WeeYari's Avatar
 
Drives: 06 Polar White 5dr, 13 Soul 4u
Join Date: Oct 2008
Location: Georgetown, Ontario, Canada
Posts: 5,744
If you haven't already ruled out the bulbs, that should have been your first step. These are dual filament bulbs and the low beam filament always burns out first, often the left and right within days of each other.
__________________
WeeYari is offline   Reply With Quote
Old 06-04-2024, 04:59 PM   #4
Guyon
 
Drives: 2009 Toyota Yaris 5MT
Join Date: Jul 2021
Location: Richmond, VA
Posts: 2
You guys were right - it was the bulbs! Them both going off simultaneously and the high beam indicator not coming on really threw me off. Turns out at least one of two low beams have to be functional for the high beam light to function. I hope someone's google-fu leads them here at some point and it solves their problem too.
Guyon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
NEWS: TOYOTA REVEALS ALL-NEW YARIS SEDAN AT 2006 LOS ANGELES AUTO SHOW VitzBoy General Yaris / Vitz Discussion 7 09-20-2023 07:50 AM
Yaris RHD 2009 3 door hatch - how to fix hyper flashing LED turn signals? KermitAUS DIY / Maintenance / Service 0 08-08-2021 08:41 PM
Yaris coming soon? RualStorge New YARIS Purchase Forum 24 11-10-2010 12:11 PM
2007 Yaris Pricing Info ! YarisBueller New YARIS Purchase Forum 104 06-24-2009 04:54 PM


All times are GMT -4. The time now is 12:34 PM.




YarisWorld
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.