Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > Yaris TS Talk
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 07-03-2020, 07:06 PM   #1
Icosphere
I've made a post!
 
Drives: Yaris T-Sport 1.5
Join Date: Jul 2020
Location: London
Posts: 1
ODO meter display zero?

Hi there,

Due to the Pandemic lockdown for over 3 months, I haven't driven my car since and so when I tried starting it up, the battery was completely dead. I jump started it first 2 goes and successfully drove it for at least 30 minutes, hoping the battery would charge. Although haven't really driven it anywhere at length, the other day I tried to drive it again but it wouldn't ignite so I jump started it again but this time I notice the Odometer was showing zero. I seem to have lost my mileage information.

Does anyone have experience of this? What should I do to fix it? How much would be expected to get this fixed?

Thanks
Attached Images
File Type: jpg Dwb01JLHRomVpyAQ8sztOA.jpg (60.9 KB, 15 views)

Last edited by Icosphere; 07-03-2020 at 07:56 PM.
Icosphere is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 12:06 AM.




YarisWorld
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.