Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Second Generation Toyota Yaris Main Rooms > Fuel Economy Forum
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 07-15-2022, 06:28 PM   #1
RobertHog
 
Drives: 2009 Yaris Hatchback
Join Date: Jul 2022
Location: Arizona
Posts: 3
2009 Yaris

Hello I bought a 2009 Yaris Automatic trans with 92,000 miles on it. I am getting Awful MPG.
I think I am getting 21-23MPG in the city and 35+ on the highway.

I so far have.

1. New Sparkplugs
2. New MAF
3. New Injectors (2 were leaking and replaced and 2 were just cleaned.)
4. New Upstream and down stream sensors on the transmission. (These were changed while chasing down an intermittent problem when the transmission would shift odd turned out to be a bad plug on the speed sensor.)
5. Oil change
6. Air filter changed
7. Cleaned PCV valve
8. Flushed radiator
9. I have the Upstream fuel and O2 sensor I need to install still. ( The one upstream from the CAT.)

I could change the coils out if its needed but the car runs very smooth and I think they are ok.

I use the car for Uber eats delivery and was counting on 29MPG to help with my costs.

Dose anyone have any ideas I can try?
RobertHog is offline   Reply With Quote
Old 07-15-2022, 09:20 PM   #2
bronsin
 
bronsin's Avatar
 
Drives: 2009 Base Hatch 2 Dr Auto
Join Date: Dec 2008
Location: nj
Posts: 4,439
Is the check engine light on?
__________________
Synthetic Oil: Its All In Your Head
bronsin is offline   Reply With Quote
Old 07-16-2022, 12:32 AM   #3
sh0rtlife
 
Drives: 2007 5dr canadian import
Join Date: Dec 2016
Location: pacific north WET
Posts: 314
or are there any codes left after being cleared.....
sh0rtlife is offline   Reply With Quote
Old 07-16-2022, 03:39 AM   #4
RobertHog
 
Drives: 2009 Yaris Hatchback
Join Date: Jul 2022
Location: Arizona
Posts: 3
There are no codes and the check engine light is off. I do have a monitor that is plugged into the Port so I can see Engine temp and RPM's. The Monitor has a Data stream I can access is there any important data I can get from it to share with you all?

I averaged 23.5 tonight going 90 miles with about 20% of those miles being freeway.
RobertHog is offline   Reply With Quote
Old 07-16-2022, 03:56 AM   #5
RobertHog
 
Drives: 2009 Yaris Hatchback
Join Date: Jul 2022
Location: Arizona
Posts: 3
I also had the rear brakes done but I don't think they are dragging because I seem to coast well and I do not hear any dragging sound.
RobertHog is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2009 Yaris sedan problems BennyLava DIY / Maintenance / Service 5 12-26-2020 05:14 PM
Yaris 2 D4D 2009 without AC serpentine belt rasyaya DIY / Maintenance / Service 6 07-17-2014 09:02 AM
2009 Yaris and wind sailing GrayYaris Wheels, Tires and Suspension Forum sponsored by The Tire Rack 16 10-26-2013 07:52 PM
NEWS: TOYOTA REVEALS ALL-NEW YARIS SEDAN AT 2006 LOS ANGELES AUTO SHOW VitzBoy General Yaris / Vitz Discussion 5 09-05-2010 08:53 PM
August 2009 - DFW Yaris Yak SaerinRhoe Southwest 55 08-19-2009 11:55 AM


All times are GMT -4. The time now is 07:24 AM.




YarisWorld
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.