Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 06-28-2022, 10:49 PM   #1
24boosted
 
Drives: 09 yrs
Join Date: Oct 2015
Location: SC
Posts: 28
09 Yaris starting issue help!

09 Yaris 3dr with 120k miles.

Issue: Engine starts only with a tiny spritz of starting fluid. Will continue to fire up without the starting fluid for a couple of days then needs it again. Cranks continuously but does not start after two days. No CEL.

Parts replaced with brand new OEM parts:
fuel pump
fuel pump level
ignition coils
injector o-rings
spark plugs
crank position sensor
MAF
integration relay
battery

Engine compression across all cylinders (forget exact readings 190-200 psi all 4)
fuel pressure reads 47 psi at idle. Clean battery terminals, no corrosion.

ANY SUGGESTIONS is HIGHLY VALUED! Thanks in advance! CTScott still around?

Last edited by 24boosted; 06-28-2022 at 11:00 PM. Reason: Added additional info.
24boosted is offline   Reply With Quote
Old 06-29-2022, 10:03 PM   #2
sh0rtlife
 
Drives: 2007 5dr canadian import
Join Date: Dec 2016
Location: pacific north WET
Posts: 314
the fact your needing ether to start it tells me its a fuel issue almost 100%, yes a "weak" spark could do it too but weak spark will return instantly once cold

my money would be fuel based issue since you havnt..replace your fuel filters...cheap and fairly easy..yes you have good fuel pressure but you can have good presure and still have cloged filters

if the filters doesnt do it..replace the injectors even with used ones...they are my #1 suspect with what youve listed replaced and symptoms ....but do the filters FIRST!!!

the only other remote possibility that comes to mind would be the IAC....tho its fairly unuseual for an IAC to allow it to work for days...it too would typicaly be a once cold no start again
sh0rtlife is offline   Reply With Quote
Old 06-30-2022, 12:28 AM   #3
24boosted
 
Drives: 09 yrs
Join Date: Oct 2015
Location: SC
Posts: 28
Thanks! I will give it a shot and replace the fuel filter and see where it takes us.
Unfortunately the 2009+ fuel filters are pricey ~$160 , comes with part of the entire module, unlike the 06-08 the filter can be replaced and purchased separately for less than $40.
24boosted is offline   Reply With Quote
Old 06-30-2022, 11:34 AM   #4
sh0rtlife
 
Drives: 2007 5dr canadian import
Join Date: Dec 2016
Location: pacific north WET
Posts: 314
thing is clogged or multiple clogged injectors wont throw codes..only if they are having electrical issues will they toss codes...but a fuel filter thats plugged will cause low "flow" not low psi tooo thus why starting with the filters..cause if the injectors are plugged the filters are trashed
sh0rtlife is offline   Reply With Quote
Old 07-13-2022, 12:22 AM   #5
24boosted
 
Drives: 09 yrs
Join Date: Oct 2015
Location: SC
Posts: 28
I am at a loss. I installed the brand new Toyota fuel filter module and it started up fine for 3 days. Fired right up each time. Worked all day then all of a sudden it just cranks and won't fire up. I cleaned all of the injectors with carb cleaner on a 12 volt connector. I didn't drive the car just warmed it up each time.

Try new injectors? This car is prob not worth the amount I spent on all of the new parts, not to mention time wasted. lol
24boosted is offline   Reply With Quote
Old 07-13-2022, 08:26 PM   #6
Gutling
 
Drives: 2007 Toyota Yaris
Join Date: Dec 2021
Location: Franklin, NC
Posts: 8
maybe trash in your tank? new filter worked good, until clogged again. When you were changing the pump/filter, did you look around tank real good?
Gutling is offline   Reply With Quote
Old 07-14-2022, 01:23 AM   #7
24boosted
 
Drives: 09 yrs
Join Date: Oct 2015
Location: SC
Posts: 28
Going to drain and eliminate that variable.
24boosted is offline   Reply With Quote
Old 07-15-2022, 11:53 AM   #8
sh0rtlife
 
Drives: 2007 5dr canadian import
Join Date: Dec 2016
Location: pacific north WET
Posts: 314
the fact that you got it to run tells me its still a fuel issue, junk in the tank or failing injectors
sh0rtlife is offline   Reply With Quote
Old 08-12-2022, 01:50 AM   #9
IndestructibleYaris
 
Drives: 2007 Toyota Yaris Sedan
Join Date: Feb 2019
Location: Harrisburg, PA
Posts: 90
pump out fuel sample from bottom of tank, mine would run with misfires and hard starting with a third of the fuel being water and ethanol that fell out of suspension with the gasoline. That, or injectors. You can buy an injector tester on ebay for 25 dollars and it can clean and test injectors for flow using a consistent injector on time and a single graduated cylinder or injector drop testing in car, use the stock fuel rail as a holder for the injectors

On second thought, why no diagnostics? Fuel trims, maf reading, ECT, etc. are all valuable and should be considered before spending hundreds if not thousands on injectors, fuel pump, sensors, etc. Spark plug inspection costs nothing and may give you a clue as to what the issue is, whether it's bone dry or oil soaked from bad valve stem seals. Color also tells you how the mixture is doing, overall.

It really hurts to see no diagnostics other than starting fluid. Also, testing the fuel filter for flow only takes 15 minutes and would've saved you some coin. Pop off fuel hose, route into container wedged in between intake and cooling fan, and manually energize fuel pump top left pin with 12v positive and top right with ground (from driver's rear perspective).

Last edited by IndestructibleYaris; 08-12-2022 at 02:00 AM.
IndestructibleYaris is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting New Mods on an Old Yaris - Need inputs for the blank slate! plmille2 Cosmetic Modifications (Exterior/Interior) 8 05-24-2012 07:00 PM
2009 Yaris starting issue -need help cudchew DIY / Maintenance / Service 15 12-16-2011 02:24 AM
2007 Yaris Door Lock Issue bhola General Yaris / Vitz Discussion 7 10-05-2010 12:01 AM
NEWS: TOYOTA REVEALS ALL-NEW YARIS SEDAN AT 2006 LOS ANGELES AUTO SHOW VitzBoy General Yaris / Vitz Discussion 5 09-05-2010 08:53 PM


All times are GMT -4. The time now is 01:54 PM.




YarisWorld
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.