Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 09-06-2022, 09:53 AM   #1
k98shooter
 
Drives: 2012 Yaris Hatchback 3 door
Join Date: Jan 2022
Location: South Jersey, USA
Posts: 14
Erratic shifting from 3rd to 4th

Son's car. 2012 Yaris hatchback automatic with just over 60k miles. The car ran silky smooth until now... No CEL, no stored error codes.
This happens after engine warms up to operating temperature. When driving at 20-40 mph, at a steady speed, without accelerating, the transmission starts shifting randomly from 3rd to 4th. Appears randomly fluctuating between 3rd and 4th. Often it shifts to 4th prematurely, so there is a sensation of power loss as the RPM is still too low for 4th gear. The car runs just fine at highway speeds and shifts through gears just fine when accelerating hard. He took the car to Toyota dealer who said it appears transmission issue, but could not give more specific answer (even though he paid $150 for "diagnosis").
Your input is highly appreciated. I suspect on of the solenoid valves, just not sure which one. Perhaps best solution would be just to replace entire valve body?
k98shooter is offline   Reply With Quote
Old 09-06-2022, 10:42 AM   #2
bronsin
 
bronsin's Avatar
 
Drives: 2009 Base Hatch 2 Dr Auto
Join Date: Dec 2008
Location: nj
Posts: 4,507
Car was in some sort of accident recently, right?
__________________
Synthetic Oil: Its All In Your Head
bronsin is offline   Reply With Quote
Old 09-06-2022, 11:05 AM   #3
k98shooter
 
Drives: 2012 Yaris Hatchback 3 door
Join Date: Jan 2022
Location: South Jersey, USA
Posts: 14
No, that was a different car. This one was never in an accident.
k98shooter is offline   Reply With Quote
Old 09-06-2022, 12:13 PM   #4
bronsin
 
bronsin's Avatar
 
Drives: 2009 Base Hatch 2 Dr Auto
Join Date: Dec 2008
Location: nj
Posts: 4,507
What is the condition of the transmission oil? Is it clear red or is it black/dark brown?

I would consider dropping the automatic transmission oil pan and examining it for cleanliness IE Metal shavings and other unpleasant things.
__________________
Synthetic Oil: Its All In Your Head
bronsin is offline   Reply With Quote
Old 09-06-2022, 12:49 PM   #5
k98shooter
 
Drives: 2012 Yaris Hatchback 3 door
Join Date: Jan 2022
Location: South Jersey, USA
Posts: 14
It looks more red than brown. There was some super fine black power accumulation on magnets on fluid pan.

https://imgur.com/a/DGvbYu0
k98shooter is offline   Reply With Quote
Old 09-06-2022, 12:49 PM   #6
k98shooter
 
Drives: 2012 Yaris Hatchback 3 door
Join Date: Jan 2022
Location: South Jersey, USA
Posts: 14

Last edited by k98shooter; 09-06-2022 at 12:52 PM. Reason: Repost
k98shooter is offline   Reply With Quote
Old 09-06-2022, 01:14 PM   #7
bronsin
 
bronsin's Avatar
 
Drives: 2009 Base Hatch 2 Dr Auto
Join Date: Dec 2008
Location: nj
Posts: 4,507
Sounds pretty normal and there’s not many miles on the car. Nothing catastrophic anyway.

You’re you could always go to AAMCO and have them give an opinion.
__________________
Synthetic Oil: Its All In Your Head
bronsin is offline   Reply With Quote
Old 09-06-2022, 02:46 PM   #8
sh0rtlife
 
Drives: 2007 5dr canadian import
Join Date: Dec 2016
Location: pacific north WET
Posts: 351
its the year of the trransmission failures
buddys honda gave up, bought a used car..its didnt make it home...trans...wnet hunting for other rigs that he would be happy with....adds full of the right rigs all with trans issues...widened the search..TONS of trans issues

yours sounds more like a electrical issue than a mechanical one tho
sh0rtlife is offline   Reply With Quote
Old 09-07-2022, 05:01 PM   #9
xdarkxfirex
 
Drives: 2015 yaris le
Join Date: Feb 2015
Location: hamilton, on
Posts: 147
Try using some Lucas. It might help.
xdarkxfirex is offline   Reply With Quote
Old 09-17-2022, 03:58 PM   #10
k98shooter
 
Drives: 2012 Yaris Hatchback 3 door
Join Date: Jan 2022
Location: South Jersey, USA
Posts: 14
Replacement valve body fixed the problem. I don't know which solenoid was faulty, as the replacement VB came with solenoids.
k98shooter is offline   Reply With Quote
Old 09-17-2022, 05:10 PM   #11
bronsin
 
bronsin's Avatar
 
Drives: 2009 Base Hatch 2 Dr Auto
Join Date: Dec 2008
Location: nj
Posts: 4,507
Good work. Interesting there was no code thrown
__________________
Synthetic Oil: Its All In Your Head
bronsin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 Yaris manual trans shifting from 2nd to 3rd not smooth gnx547 General Yaris / Vitz Discussion 6 07-30-2022 09:15 AM
3rd 4th & 5th gear rattle fishlurcher DIY / Maintenance / Service 3 07-30-2015 08:40 AM
Experimenting with bypassing the AT 4th gear prohibition when cold CTScott Performance Modifications 28 03-22-2015 08:16 AM
2nd Gen owner's impressions: 3 days with a 3rd Gen (2013 5-door LE 18k miles) nookandcrannycar General Yaris / Vitz Discussion 7 02-22-2014 08:16 PM
yaris jerks a bit when shifting to 3rd gear. abdallah380 DIY / Maintenance / Service 3 09-19-2009 03:45 PM


All times are GMT -4. The time now is 02:39 PM.




YarisWorld
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.