Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Second Generation Toyota Yaris Main Rooms > Regional Forums > UK
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 03-12-2019, 05:20 AM   #1
Johnbuddy2
I've made a post!
 
Drives: 2013 Yaris 1.33 vvt-i trend
Join Date: Mar 2019
Location: Scotland
Posts: 1
Multifunction display has died

Hi all, we have a 2013 Yaris 1.33 vvt-i trend. On Friday the mfd completely died. The radio/Bluetooth/reverse camera was all working fine on Friday morning, came out after a few hours at work and it was dead as a dodo. All other areas of car work fine, eg lights mirror etc. It's just the whole display is blank and won't work. I bought autocare from Arnold Clark with the car 20 months ago but they won't touch it as they say media isn't covered.(but if there's no power is this not electrical) I've had it in at local garage who's checked fuses and put it on his code reader but it's not showing anything. He has suggested there is no power going to the unit. I have booked it into Toyota themselves who want to put it on their diagnostics but earliest they can take us is 3 weeks away. Does anyone have any experience of this issue and can offer a resolve or suggestion, thanks
Johnbuddy2 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:32 AM.




YarisWorld
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.