Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > Wheels, Tires and Suspension Forum sponsored by The Tire Rack
 

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 12-30-2009, 03:29 AM   #1
Parmas
 
Parmas's Avatar
 
Drives: Vitz RS Turbo
Join Date: Nov 2008
Location: ML
Posts: 575
Launching @ 4Krpm problem .... need tips

I wish to solve the problem of launching at high rpm. I own a Vitz\Echo hatchback 2001 model and when I launch @ 4krpm from a dead stop its like the left wheel hops and hammers all body of the car (especially the dash). This problem was already there when I was all stock. First I thought I need some good tires so I said until replacement I prevent hard launches.

Now the engine was upgraded to turbo, the gearbox upgraded with LSD and tires upgraded to Toyo 888 series and the problem seems to be on the 2 wheels now!!

I have all things related to suspension still stock... so from where to begin?? Please I am in a budget so don't throw words if you are unsure.

I don't know if it's a problem with my car or the model itself... I am sure that Toyota Starlets haven't that problem.
Parmas is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
electrical problem with car need help badly!! Adriaan DIY / Maintenance / Service 20 05-07-2010 12:40 AM
How can I get in touch with Toyota Regional Offices in Houston? woof DIY / Maintenance / Service 11 11-28-2009 09:29 PM
Service Problem Lizardboy DIY / Maintenance / Service 19 10-06-2006 09:12 PM


All times are GMT -4. The time now is 09:17 PM.




YarisWorld
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.