Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 02-19-2022, 04:09 PM   #1
caffaro
 
Drives: 2007 2D Hatchback
Join Date: Feb 2022
Location: United States
Posts: 3
Need help identifying a cut/chewed wire

Hi everyone. After leaving my car parked outside my house while out of the country for two months, I found my poor Yaris with a few problems. Namely:

1) The speedometer does not work
2) The P/S warning light is on and the EPS does not appear to be working (steering wheel is very stiff, difficult to turn at low speeds)
3) Malfunction indicator lamp showing

I tested my battery and discovered it was in low health, so went ahead and replaced it. This took care of the malfunction warning, but not the other problems.

As I go to double check the battery is secured, I notice a glaring issue --- a cut wire (hopefully chewed by a rodent and not cut by a person).

https://imgur.com/a/6ejrett

I have a decent knowledge of engines and DIY maintenance, but am completely ignorant when it comes to electronics and wiring. I also have no clue what the cylindrical component is that the wire is leading to.

So my questions are:
1) What is this wire? Is it possible that this wire is somehow connecting the VSS to the ECU? I kind of doubt it, since it isn't feeding directly into the ECU, but I have no idea where the VSS is actually located.
2) I'm not entirely clear how the EPS functions, but is it possible that a bad VSS would be causing the EPS to shut down and/or go into failsafe mode?

I am really, really hoping that fixing this snapped wire will resolve my issues. I still don't have a trusted mechanic in this area. Dude who did some (mediocre) work for me a few years ago told me he wouldn't touch it and suggested I take it to the dealership. I've got an appointment tomorrow, but I'm a bit terrified they're going to tell me something crazy, like that they want to replace the entire harness.

Anyway, any thoughts or info is very appreciated. Cheers!
caffaro is offline   Reply With Quote
Old 02-19-2022, 11:44 PM   #2
Turbiini
 
Drives: 1983 carina 2NZ-FTE
Join Date: Dec 2020
Location: finland
Posts: 20
looks aftermarket car alarm. nothing to do with vss or steering
Turbiini is offline   Reply With Quote
Old 02-20-2022, 12:15 PM   #3
IndestructibleYaris
 
Drives: 2007 Toyota Yaris Sedan
Join Date: Feb 2019
Location: Harrisburg, PA
Posts: 74
Check the EPS fuse, and all the fuses while you're at it
IndestructibleYaris is offline   Reply With Quote
Old 02-21-2022, 12:50 PM   #4
caffaro
 
Drives: 2007 2D Hatchback
Join Date: Feb 2022
Location: United States
Posts: 3
Thanks for the response y'all. Turb, that makes sense and explains why I didn't see this component in any of the diagrams I checked. Indeed, the alarm installed by the previous owners hasn't worked for years now. Can't believe I never noticed this cut wire, but it was tucked back behind the motor and out of site.

Fuses all look good and none of the wiring is visibly damaged. Took it into the shop today, so we'll see what they say. Is it reasonable to hypothesize that a faulty VSS would cause the EPS to go into failsafe mode?
caffaro is offline   Reply With Quote
Old 02-21-2022, 02:29 PM   #5
caffaro
 
Drives: 2007 2D Hatchback
Join Date: Feb 2022
Location: United States
Posts: 3
Adding an update for posterity, in case anyone stumbles on this trying to diagnose a similar problem. The wiring running from the VSS to the control unit got completely chewed through by a rodent. The lack of a speed signal caused the EPS to go into failsafe mode.

Learned my lesson about taking the proper steps to protect against rodent damage when leaving the car undriven.
caffaro is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
yaris tachometer installation tutorial if you need <3 2010yarisHBbase General Yaris / Vitz Discussion 2 04-22-2022 12:45 AM
DIY keyless entry Viper 211HV w/ pics tmontague DIY / Maintenance / Service 17 08-01-2019 03:30 PM
Scion XD LED mirror install pics aplenty enviri DIY / Maintenance / Service 76 07-21-2019 02:10 PM
diy HID projector w/ halo headlight install tmontague DIY / Maintenance / Service 17 02-04-2016 11:34 AM
Blitz S/C being installed this Saturday! LtNoogie Forced Induction Forum 179 12-14-2012 08:53 PM


All times are GMT -4. The time now is 09:08 AM.




YarisWorld
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.