Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

Reply
 
Thread Tools Display Modes
Old 01-11-2022, 10:06 PM   #1
Hiro
 
Drives: 2007 Hatchback Auto
Join Date: Jan 2022
Location: USA
Posts: 14
No crank non-starter/solenoid issue Help PLZ

Went into a ditch then have let the car sit ever since, the car hasn't run for a year now. I don't know if I turned it over at all after the wreck at all which doesn't help to know if something was damaged then.

I hit the ground and a big log pretty hard but other than the bumper and radiator things look good. The shift lever on front of transmission was bent and shift cable broke off lever, after bending it back I am able to move it into park but with no change to start condition.


I know there are probably several things that could cause this, here is what I have done so far...

New battery and no crank or click, engine does crank when supplying 12 volts directly to solenoid terminal (small signal wire).

Tested shift lever neutral safety switch, terminals have continuity when in park position and non otherwise so looks functional to me.

Tried starting with shift lever in park/neutral positions and with brake on.

Checked fuses ( I think i found them all).

Checked Starter and Ignition Relay they are good.



Any help would be appreciated, it would really be nice to get my Yaris going again to save money on gas.

Thanks in advance,
Hiro.

Pictures of how the car looks now and of transmission shift lever/neutral safety switch:
Attached Images
File Type: jpg torn appart.JPG (34.9 KB, 20 views)
File Type: jpg Transmision shift lever.JPG (41.0 KB, 17 views)

Last edited by Hiro; 01-12-2022 at 02:22 AM.
Hiro is offline   Reply With Quote
Old 01-11-2022, 10:43 PM   #2
alanwagen
 
Drives: 2015Yaris, Son's car, 10 Prius
Join Date: May 2010
Location: Texas
Posts: 168
Engine may be locked up.
alanwagen is offline   Reply With Quote
Old 01-11-2022, 11:30 PM   #3
Hiro
 
Drives: 2007 Hatchback Auto
Join Date: Jan 2022
Location: USA
Posts: 14
Engine seams fine

Quote:
Originally Posted by alanwagen View Post
Engine may be locked up.
Engine is fine. I don't have power going to starter, engine cranks when i give it power directly.
Hiro is offline   Reply With Quote
Old Today, 03:10 AM   #4
Hiro
 
Drives: 2007 Hatchback Auto
Join Date: Jan 2022
Location: USA
Posts: 14
After replacing the broken shift cable it started right up, I think that the shift lever was not going all the way into position.
Hiro is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Issue where dashlights either turn on or fade on when car off razingman DIY / Maintenance / Service 0 01-17-2021 01:24 PM
Random No Start Issue Darkhorse6 DIY / Maintenance / Service 6 05-11-2016 01:46 AM
yaris voltage issue yaris2010RS DIY / Maintenance / Service 11 12-29-2012 05:20 PM
08 HB DRL Issue BruceLee Cosmetic Modifications (Exterior/Interior) 3 02-18-2012 11:59 PM
Minor issue with NST crank pulley at takeoff YarisSedan Performance Modifications 0 05-12-2009 02:06 AM


All times are GMT -4. The time now is 10:52 PM.




YarisWorld
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.