Toyota Yaris Forums - Ultimate Yaris Enthusiast Site
 

 


 
Go Back   Toyota Yaris Forums - Ultimate Yaris Enthusiast Site > Technical Forums > DIY / Maintenance / Service
  The Tire Rack

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 12-09-2015, 11:19 AM   #1
johnnashfcup
 
Drives: Yaris D4D (2007)
Join Date: Dec 2015
Location: Porto (Portugal)
Posts: 2
Engine Power problem

Hi guys,

I have a Toyota Yaris (Year 2007) with 140 000 kms. It hasn't given me any problems so far. Still, yesterday when I was driving in the highway as fast as 125km/hour, I noticed it was loosing power. Even when I reduced the gearbox, the engine still responded very poorly. This morning, when I was driving in the highway, I had the same problem. The only way to keep the car going was by reducing the engine to the third gear and keep it going with the engine rotations very high.

Any idea about what could be causing this? Could it be the turbo colapsing?


Best
johnnashfcup is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Zage Turbo Kit Install - Toyota Yaris Focus_Sh1ft Forced Induction Forum 160 02-06-2022 08:14 PM
The Nitrous Thread ChinoCharles Performance Modifications 116 02-16-2016 03:07 PM
DIY: Intake Installation redyaris DIY / Maintenance / Service 53 08-23-2014 05:34 AM
tooter's manifold adventure... tooter Performance Modifications 1465 07-31-2014 08:11 PM
aftermarket power lock problem mauiyaris In Car Entertainment + Electronics (audio / video / alarm) 17 08-24-2010 02:40 PM


All times are GMT -4. The time now is 01:50 AM.




YarisWorld
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.